~ubuntu-branches/ubuntu/saucy/network-manager-applet/saucy-updates

« back to all changes in this revision

Viewing changes to debian/patches/hide_policy_items_env_var.patch

  • Committer: Package Import Robot
  • Author(s): Mathieu Trudel-Lapierre
  • Date: 2013-02-05 16:15:00 UTC
  • mfrom: (1.2.33)
  • Revision ID: package-import@ubuntu.com-20130205161500-nax1yrh7klr0o8ir
Tags: 0.9.7.995+git201301311844.0376019-0ubuntu1
* upstream snapshot 2013-01-31 18:44:13 (GMT)
  + 03760194e54eaeaf493e9b45c4835e84524d8650
* debian/patches/nm-applet-use-indicator.patch: refreshed.
* debian/patches/lp1048516_dont_req_keyring_in_greeter.patch: refreshed.
* debian/patches/lp289466_always_show_tray_icon.patch: refreshed.
* debian/patches/lp829673_gconf_hide_applet.patch: refreshed.
* debian/patches/position_dialogs_to_center_of_the_screen.patch: refreshed.
* debian/patches/hide_policy_items_env_var.patch: refreshed.
* debian/patches/lp1048520_delay_pin_dialog_in_greeter.patch: refreshed.
* debian/patches/nm-applet-use-indicator.patch: fix the addition of separator
  menu items to avoid multiple separators added in a block.
* debian/control: bump network-manager Depends and Build-Depends to the
  appropriate snapshot version.

Show diffs side-by-side

added added

removed removed

Lines of Context:
16
16
===================================================================
17
17
--- a/src/applet.c
18
18
+++ b/src/applet.c
19
 
@@ -1606,8 +1606,16 @@ nma_menu_device_get_menu_item (NMDevice
 
19
@@ -1639,8 +1639,16 @@ nma_menu_device_get_menu_item (NMDevice
20
20
                                       (GClosureNotify) applet_device_info_destroy, 0);
21
21
                if (is_permission_yes (applet, NM_CLIENT_PERMISSION_NETWORK_CONTROL))
22
22
                        gtk_widget_set_sensitive (item, TRUE);
34
34
                break;
35
35
        }
36
36
        default:
37
 
@@ -1745,6 +1753,8 @@ nma_menu_add_vpn_submenu (GtkWidget *men
 
37
@@ -1778,6 +1786,8 @@ nma_menu_add_vpn_submenu (GtkWidget *men
38
38
        GtkMenuItem *item;
39
39
        GSList *list, *iter;
40
40
        int num_vpn_active = 0;
43
43
 
44
44
        vpn_menu = GTK_MENU (gtk_menu_new ());
45
45
 
46
 
@@ -1812,30 +1822,58 @@ nma_menu_add_vpn_submenu (GtkWidget *men
 
46
@@ -1845,30 +1855,58 @@ nma_menu_add_vpn_submenu (GtkWidget *men
47
47
                gtk_menu_shell_append (GTK_MENU_SHELL (vpn_menu), GTK_WIDGET (item));
48
48
        }
49
49
 
109
109
        }
110
110
 
111
111
        g_slist_free (list);
112
 
@@ -1921,6 +1959,8 @@ nma_set_notifications_enabled_cb (GtkWid
 
112
@@ -1954,6 +1992,8 @@ nma_set_notifications_enabled_cb (GtkWid
113
113
 static void nma_menu_show_cb (GtkWidget *menu, NMApplet *applet)
114
114
 {
115
115
        guint32 n_wifi;
118
118
 
119
119
        g_return_if_fail (menu != NULL);
120
120
        g_return_if_fail (applet != NULL);
121
 
@@ -1940,10 +1980,21 @@ static void nma_menu_show_cb (GtkWidget
 
121
@@ -1973,10 +2013,21 @@ static void nma_menu_show_cb (GtkWidget
122
122
        n_wifi = nma_menu_add_devices (menu, applet);
123
123
 
124
124
        if (n_wifi > 0 && nm_client_wireless_get_enabled (applet->nm_client)) {
141
141
        }
142
142
 
143
143
        nma_menu_add_vpn_submenu (menu, applet);
144
 
@@ -2119,6 +2170,7 @@ nma_context_menu_update (NMApplet *apple
 
144
@@ -2152,6 +2203,7 @@ nma_context_menu_update (NMApplet *apple
145
145
                 * so set the "Edit Connections..." menu item insensitive.
146
146
                 */
147
147
                gtk_widget_set_sensitive (applet->connections_menu_item, FALSE);
149
149
        }
150
150
 }
151
151
 
152
 
@@ -4017,6 +4069,10 @@ static void nma_init (NMApplet *applet)
 
152
@@ -4117,6 +4169,10 @@ static void nma_init (NMApplet *applet)
153
153
        applet->icon_theme = NULL;
154
154
        applet->notification = NULL;
155
155
        applet->icon_size = 16;
214
214
===================================================================
215
215
--- a/src/applet.h
216
216
+++ b/src/applet.h
217
 
@@ -101,6 +101,7 @@ typedef struct
218
 
        GSettings *gsettings;
 
217
@@ -110,6 +110,7 @@ typedef struct
 
218
 #endif
219
219
 
220
220
        gboolean visible;
221
221
+       gboolean hide_policy_items;
226
226
===================================================================
227
227
--- a/src/applet-device-cdma.c
228
228
+++ b/src/applet-device-cdma.c
229
 
@@ -467,7 +467,12 @@ cdma_add_menu_item (NMDevice *device,
 
229
@@ -377,7 +377,12 @@ cdma_add_menu_item (NMDevice *device,
230
230
                        item = gtk_check_menu_item_new_with_label (_("New Mobile Broadband (CDMA) connection..."));
231
231
 
232
232
                        gtk_widget_set_sensitive (GTK_WIDGET (item), allowed);
244
244
===================================================================
245
245
--- a/src/applet-device-gsm.c
246
246
+++ b/src/applet-device-gsm.c
247
 
@@ -523,8 +523,12 @@ gsm_add_menu_item (NMDevice *device,
 
247
@@ -433,8 +433,12 @@ gsm_add_menu_item (NMDevice *device,
248
248
                        /* Default connection item */
249
249
                        item = gtk_check_menu_item_new_with_label (_("New Mobile Broadband (GSM) connection..."));
250
250
                        gtk_widget_set_sensitive (GTK_WIDGET (item), allowed);