~ubuntu-branches/ubuntu/trusty/gdisk/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/kfreebsd_character_devices.diff

  • Committer: Package Import Robot
  • Author(s): Guillaume Delacour
  • Date: 2013-07-31 21:42:39 UTC
  • mfrom: (1.1.7)
  • Revision ID: package-import@ubuntu.com-20130731214239-21j7jf9rqpcafu6t
Tags: 0.8.7-1
* New upstream release
* Refresh patch debian/patches/manpages.diff (hyphen as minus)
* Recommends groff-base instead of depends on it (Closes: #698622)
* debian/patches/kfreebsd_character_devices.diff: all devices are characters
  devices on kFreeBSD, thanks Jeff Epler (Closes: #696813)
* Run test suite at build time, thanks Michael Terry (Closes: #695173)
  + debian/patches/fix-change_disk_uid-test.diff: exit with 1 in case of
    error
  + debian/rules: launch gdisk_test.sh test script in override_dh_auto_test
* Build a second gdisk package without Unicode support (Closes: #702544):
  + debian/control
  + debian/doc-base
  + debian/docs (same content)
  + debian/manpages (same content)
* Bump to Standards-Version 3.9.4 (no changes needed)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Jeff Epler <jepler@unpythonic.net>
 
2
Subject: All devices are characters devices on kFreeBSD
 
3
Last-Update: 2013-07-31
 
4
Bug-Debian: http://bugs.debian.org/696813
 
5
Forwarded: https://sourceforge.net/p/gptfdisk/mailman/message/31237858/
 
6
 
 
7
--- a/diskio-unix.cc
 
8
+++ b/diskio-unix.cc
 
9
@@ -73,7 +73,8 @@
 
10
          if (fstat64(fd, &st) == 0) {
 
11
             if (S_ISDIR(st.st_mode))
 
12
                cerr << "The specified path is a directory!\n";
 
13
-#if !defined(__FreeBSD__) && !defined(__APPLE__)
 
14
+#if !(defined(__FreeBSD__) || defined(__FreeBSD_kernel__)) \
 
15
+                       && !defined(__APPLE__)
 
16
             else if (S_ISCHR(st.st_mode))
 
17
                cerr << "The specified path is a character device!\n";
 
18
 #endif