~ubuntu-branches/ubuntu/trusty/gnomeradio/trusty

« back to all changes in this revision

Viewing changes to debian/patches/gnomeradio-alsa.patch

  • Committer: Package Import Robot
  • Author(s): POJAR GEORGE
  • Date: 2013-09-20 13:31:33 UTC
  • Revision ID: package-import@ubuntu.com-20130920133133-otwactksfjh4bwev
Tags: 1.8-2ubuntu23
* Updated debian/patches/gnomeradio-tray_menu.patch:
  - Fixed menu item not update conform new order when we use move up[down]
    swap. (LP: #1232931)
  - Fixed conditional jump or move depends on uninitialized value.
  - Added function to switch to preset in settings preset list when changed
    them from tray menu.
  - Cleaned up the files relating to the tray icon. Neither gui.c, prefs.c nor
    record.c touch the internals of trayicon.c anymore.
* Updated debian/patches/gnomeradio-preferences.patch:
  - Added option to disable audio loopback mode in Preferences settings.
  - Moved in separate GOptionGroup all command line parameters which refers to
    audio loopback mode.
* Updated debian/patches/gnomeradio-device.patch: Not need radio_mute() when
  exit or session die, already is called in radio_stop().
* Updated debian/patches/gnomeradio-station_list.patch: Fixed pointer targets
  in passing argument differ in signedness.
* Removed the content against configure and Makefile.in, since we use
  autoreconf anyways, from:
  - debian/patches/gnomeradio-gstreamer-1.0.patch.
  - debian/patches/gnomeradio-volume_button.patch.
* Updated debian/patches/gnomeradio-volume_button.patch: Removed unused
  vol_down[up].xpm icons.
* debian/gnomeradio.1: Updated man page.   

Show diffs side-by-side

added added

removed removed

Lines of Context:
4
4
Index: gnomeradio-1.8/src/alsa_stream.c
5
5
===================================================================
6
6
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
7
 
+++ gnomeradio-1.8/src/alsa_stream.c    2013-09-25 22:45:52.216651000 +0000
 
7
+++ gnomeradio-1.8/src/alsa_stream.c    2013-09-29 23:34:39.614658000 +0000
8
8
@@ -0,0 +1,640 @@
9
9
+/*
10
10
+ *  ALSA streaming support
649
649
Index: gnomeradio-1.8/src/alsa_stream.h
650
650
===================================================================
651
651
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
652
 
+++ gnomeradio-1.8/src/alsa_stream.h    2013-09-25 22:45:52.216651000 +0000
 
652
+++ gnomeradio-1.8/src/alsa_stream.h    2013-09-29 23:34:39.614658000 +0000
653
653
@@ -0,0 +1,34 @@
654
654
+
655
655
+/*
688
688
Index: gnomeradio-1.8/src/get_media_devices.c
689
689
===================================================================
690
690
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
691
 
+++ gnomeradio-1.8/src/get_media_devices.c      2013-09-25 22:46:18.000000000 +0000
 
691
+++ gnomeradio-1.8/src/get_media_devices.c      2013-09-29 23:34:52.000000000 +0000
692
692
@@ -0,0 +1,595 @@
693
693
+/*
694
694
+   Copyright © 2011 by Mauro Carvalho Chehab <mchehab@redhat.com>
1288
1288
Index: gnomeradio-1.8/src/get_media_devices.h
1289
1289
===================================================================
1290
1290
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
1291
 
+++ gnomeradio-1.8/src/get_media_devices.h      2013-09-25 22:45:52.216651000 +0000
 
1291
+++ gnomeradio-1.8/src/get_media_devices.h      2013-09-29 23:34:39.614658000 +0000
1292
1292
@@ -0,0 +1,168 @@
1293
1293
+/*
1294
1294
+   Copyright © 2011 by Mauro Carvalho Chehab <mchehab@redhat.com>
1460
1460
+                                     const enum device_type not_desired_type);
1461
1461
Index: gnomeradio-1.8/configure.in
1462
1462
===================================================================
1463
 
--- gnomeradio-1.8.orig/configure.in    2013-09-25 22:45:52.216651000 +0000
1464
 
+++ gnomeradio-1.8/configure.in 2013-09-25 22:46:21.000000000 +0000
 
1463
--- gnomeradio-1.8.orig/configure.in    2013-09-29 23:34:39.614658000 +0000
 
1464
+++ gnomeradio-1.8/configure.in 2013-09-29 23:34:55.000000000 +0000
1465
1465
@@ -5,7 +5,7 @@
1466
1466
 AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
1467
1467
 
1511
1511
+AC_OUTPUT
1512
1512
Index: gnomeradio-1.8/src/gui.c
1513
1513
===================================================================
1514
 
--- gnomeradio-1.8.orig/src/gui.c       2013-09-25 22:45:52.216651000 +0000
1515
 
+++ gnomeradio-1.8/src/gui.c    2013-09-25 22:46:22.000000000 +0000
 
1514
--- gnomeradio-1.8.orig/src/gui.c       2013-09-29 23:34:39.614658000 +0000
 
1515
+++ gnomeradio-1.8/src/gui.c    2013-09-29 23:34:58.000000000 +0000
1516
1516
@@ -36,6 +36,7 @@
1517
1517
 #include "lirc.h"
1518
1518
 #include "prefs.h"
1556
1556
                
1557
1557
                *f = freq;
1558
1558
                fsd->stations = g_list_append(fsd->stations, f);
1559
 
@@ -792,8 +803,19 @@
 
1559
@@ -790,8 +801,19 @@
1560
1560
        if (vol) {
1561
1561
                old_vol = vol;
1562
1562
                vol = 0;
1576
1576
        }       
1577
1577
        mixer_set_volume(vol);
1578
1578
        gtk_volume_button_set_value(mute_button, vol);
1579
 
@@ -1196,6 +1218,97 @@
 
1579
@@ -1192,6 +1214,97 @@
1580
1580
        return FALSE;
1581
1581
 }
1582
1582
 
1674
1674
 int main(int argc, char* argv[])
1675
1675
 {
1676
1676
        GList *ptr;
1677
 
@@ -1204,23 +1317,38 @@
 
1677
@@ -1200,23 +1313,38 @@
1678
1678
        gboolean do_scan = FALSE;
1679
1679
        GOptionContext *ctx;
1680
1680
        const GOptionEntry entries[] = {
1718
1718
        /* Main app */
1719
1719
        main_visible = FALSE;
1720
1720
        app = gnome_radio_gui();
1721
 
@@ -1243,11 +1371,12 @@
 
1721
@@ -1239,11 +1367,12 @@
1722
1722
        }
1723
1723
 
1724
1724
        load_settings();
1732
1732
                } else {
1733
1733
                        initial_frequency_scan(app);
1734
1734
                        set_first_time_flag();
1735
 
@@ -1280,12 +1409,12 @@
 
1735
@@ -1276,12 +1405,12 @@
1736
1736
                gtk_dialog_run (GTK_DIALOG (dialog));
1737
1737
                gtk_widget_destroy (dialog);
1738
1738
 */
1747
1747
 /* Connect the Session Management signals
1748
1748
  */
1749
1749
 
1750
 
@@ -1326,7 +1455,7 @@
 
1750
@@ -1322,7 +1451,7 @@
1751
1751
 {
1752
1752
        DBusGConnection *connection;
1753
1753
        DBusGProxy      *proxy;
1758
1758
 
1759
1759
Index: gnomeradio-1.8/src/Makefile.am
1760
1760
===================================================================
1761
 
--- gnomeradio-1.8.orig/src/Makefile.am 2013-09-25 22:45:52.216651000 +0000
1762
 
+++ gnomeradio-1.8/src/Makefile.am      2013-09-25 22:46:22.000000000 +0000
 
1761
--- gnomeradio-1.8.orig/src/Makefile.am 2013-09-29 23:34:39.614658000 +0000
 
1762
+++ gnomeradio-1.8/src/Makefile.am      2013-09-29 23:34:58.000000000 +0000
1763
1763
@@ -1,35 +1,39 @@
1764
1764
-INCLUDES = -I$(top_srcdir) -I$(includedir) \
1765
1765
-           $(GNOME_CFLAGS) $(GSTREAMER_CFLAGS) $(XML_CFLAGS)\
1833
1833
+gnomeradio_LDADD = $(ALSA_LIBS) $(GNOME_LIBS) $(GSTREAMER_LIBS) $(XML_LIBS) $(LIRC)
1834
1834
Index: gnomeradio-1.8/src/radio.c
1835
1835
===================================================================
1836
 
--- gnomeradio-1.8.orig/src/radio.c     2013-09-25 22:45:52.216651000 +0000
1837
 
+++ gnomeradio-1.8/src/radio.c  2013-09-25 22:48:40.658468832 +0000
 
1836
--- gnomeradio-1.8.orig/src/radio.c     2013-09-29 23:34:39.614658000 +0000
 
1837
+++ gnomeradio-1.8/src/radio.c  2013-09-29 23:35:59.362147207 +0000
1838
1838
@@ -26,6 +26,14 @@
1839
1839
 #include "radio.h"
1840
1840
 #include "v4l1.h"
1894
1894
+                       if (alsa_playback == NULL)
1895
1895
+                               alsa_playback = "default";
1896
1896
+
1897
 
+                       fprintf(stderr, "alsa: Using loopback device: capture: %s (%s), output: %s\n",
 
1897
+                       fprintf(stderr, "alsa: Using audio loopback device from %s (%s) to %s\n",
1898
1898
+                               alsa_capture, device, alsa_playback);
1899
1899
+               }
1900
1900
+       }