~ubuntu-branches/ubuntu/trusty/gnomeradio/trusty

« back to all changes in this revision

Viewing changes to debian/patches/gnomeradio-alsamixer.patch

  • Committer: Package Import Robot
  • Author(s): POJAR GEORGE
  • Date: 2013-09-20 13:31:33 UTC
  • Revision ID: package-import@ubuntu.com-20130920133133-otwactksfjh4bwev
Tags: 1.8-2ubuntu23
* Updated debian/patches/gnomeradio-tray_menu.patch:
  - Fixed menu item not update conform new order when we use move up[down]
    swap. (LP: #1232931)
  - Fixed conditional jump or move depends on uninitialized value.
  - Added function to switch to preset in settings preset list when changed
    them from tray menu.
  - Cleaned up the files relating to the tray icon. Neither gui.c, prefs.c nor
    record.c touch the internals of trayicon.c anymore.
* Updated debian/patches/gnomeradio-preferences.patch:
  - Added option to disable audio loopback mode in Preferences settings.
  - Moved in separate GOptionGroup all command line parameters which refers to
    audio loopback mode.
* Updated debian/patches/gnomeradio-device.patch: Not need radio_mute() when
  exit or session die, already is called in radio_stop().
* Updated debian/patches/gnomeradio-station_list.patch: Fixed pointer targets
  in passing argument differ in signedness.
* Removed the content against configure and Makefile.in, since we use
  autoreconf anyways, from:
  - debian/patches/gnomeradio-gstreamer-1.0.patch.
  - debian/patches/gnomeradio-volume_button.patch.
* Updated debian/patches/gnomeradio-volume_button.patch: Removed unused
  vol_down[up].xpm icons.
* debian/gnomeradio.1: Updated man page.   

Show diffs side-by-side

added added

removed removed

Lines of Context:
4
4
Index: gnomeradio-1.8/src/mixer.c
5
5
===================================================================
6
6
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
7
 
+++ gnomeradio-1.8/src/mixer.c  2013-09-24 15:29:22.427420129 +0000
 
7
+++ gnomeradio-1.8/src/mixer.c  2013-09-26 13:29:11.354432810 +0000
8
8
@@ -0,0 +1,128 @@
9
9
+/**
10
10
+ * Copyright (C) 2002, 2003 Doug Bell <drbell@users.sourceforge.net>
137
137
Index: gnomeradio-1.8/src/mixer.h
138
138
===================================================================
139
139
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
140
 
+++ gnomeradio-1.8/src/mixer.h  2013-09-24 15:29:22.427420129 +0000
 
140
+++ gnomeradio-1.8/src/mixer.h  2013-09-26 13:29:11.354432810 +0000
141
141
@@ -0,0 +1,86 @@
142
142
+/**
143
143
+ * Copyright (C) 2002, 2003 Doug Bell <drbell@users.sourceforge.net>
227
227
+#endif /* MIXER_H_INCLUDED */
228
228
Index: gnomeradio-1.8/src/tech.c
229
229
===================================================================
230
 
--- gnomeradio-1.8.orig/src/tech.c      2013-09-24 15:29:22.435420129 +0000
 
230
--- gnomeradio-1.8.orig/src/tech.c      2013-09-26 13:29:11.362432810 +0000
231
231
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
232
232
@@ -1,171 +0,0 @@
233
233
-/*
403
403
-}
404
404
Index: gnomeradio-1.8/src/tech.h
405
405
===================================================================
406
 
--- gnomeradio-1.8.orig/src/tech.h      2013-09-24 15:29:22.435420129 +0000
 
406
--- gnomeradio-1.8.orig/src/tech.h      2013-09-26 13:29:11.362432810 +0000
407
407
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
408
408
@@ -1,34 +0,0 @@
409
409
-/*
442
442
-#endif
443
443
Index: gnomeradio-1.8/src/gui.c
444
444
===================================================================
445
 
--- gnomeradio-1.8.orig/src/gui.c       2013-09-24 15:29:22.435420129 +0000
446
 
+++ gnomeradio-1.8/src/gui.c    2013-09-24 15:29:22.431420129 +0000
 
445
--- gnomeradio-1.8.orig/src/gui.c       2013-09-26 13:29:11.362432810 +0000
 
446
+++ gnomeradio-1.8/src/gui.c    2013-09-26 13:29:59.598431376 +0000
447
447
@@ -30,7 +30,7 @@
448
448
 #include <stdlib.h>
449
449
 #include "gui.h"
607
607
 }
608
608
 
609
609
 static gboolean redraw_status_window(void)
610
 
@@ -431,12 +415,11 @@
 
610
@@ -434,7 +418,7 @@
 
611
        if (settings.mute_on_exit)
 
612
                radio_stop();
611
613
 
612
 
 void exit_gnome_radio(void)
613
 
 {
614
 
-       if (settings.mute_on_exit)
615
 
-       {
616
 
+       if (settings.mute_on_exit) {
617
 
                radio_mute();
618
 
                radio_stop();
619
 
        }
620
614
-       mixer_close();
621
615
+       mixer->close_device();
622
616
        save_settings();
623
617
        gtk_main_quit();
624
618
 }
625
 
@@ -487,27 +470,22 @@
 
619
@@ -485,27 +469,22 @@
626
620
 
627
621
 static void volume_value_changed_cb(GtkVolumeButton *button, gpointer user_data)
628
622
 {
660
654
                return FALSE;
661
655
        
662
656
        if (vol != (int)volume->value)
663
 
@@ -731,16 +709,6 @@
 
657
@@ -729,16 +708,6 @@
664
658
        Recording* recording;
665
659
        char *filename;
666
660
        
677
671
        /* You can translate the filename for a recording:
678
672
         * args for this format are: path, station title, time 
679
673
         */ 
680
 
@@ -798,7 +766,7 @@
 
674
@@ -796,7 +765,7 @@
681
675
 void toggle_volume(void)
682
676
 {
683
677
        static int old_vol;
686
680
        
687
681
        if (vol) {
688
682
                old_vol = vol;
689
 
@@ -817,21 +785,21 @@
 
683
@@ -815,21 +784,21 @@
690
684
                        alsa_thread_startup(alsa_playback, alsa_capture,
691
685
                                            alsa_latency, stderr, alsa_debug);
692
686
        }       
714
708
        }
715
709
        toggle_volume();
716
710
 }
717
 
@@ -987,9 +955,10 @@
 
711
@@ -985,9 +954,10 @@
718
712
        stfw_button = gtk_button_new();
719
713
        stbw_button = gtk_button_new();
720
714
        about_button = gtk_button_new();
728
722
        rec_button = gtk_button_new();
729
723
        /*help_button = gtk_button_new();*/
730
724
 
731
 
@@ -1000,7 +969,7 @@
 
725
@@ -998,7 +968,7 @@
732
726
        gtk_container_add(GTK_CONTAINER(stfw_button), stfw_pixmap);
733
727
        gtk_container_add(GTK_CONTAINER(stbw_button), stbw_pixmap);
734
728
        gtk_container_add(GTK_CONTAINER(about_button), about_pixmap);
737
731
        gtk_container_add(GTK_CONTAINER(rec_button), rec_pixmap);
738
732
        /*gtk_container_add(GTK_CONTAINER(help_button), help_pixmap);*/
739
733
 
740
 
@@ -1054,7 +1023,7 @@
 
734
@@ -1052,7 +1022,7 @@
741
735
 /*     gtk_scale_set_digits(GTK_SCALE(vol_scale), 0);
742
736
        gtk_scale_set_draw_value(GTK_SCALE(vol_scale), FALSE);
743
737
 
746
740
 
747
741
        gtk_widget_set_size_request(drawing_area, DIGIT_WIDTH*6+10+SIGNAL_WIDTH+STEREO_WIDTH, DIGIT_HEIGTH+10);
748
742
 
749
 
@@ -1065,7 +1034,7 @@
 
743
@@ -1063,7 +1033,7 @@
750
744
        gtk_box_pack_start(GTK_BOX(hbox2), stfw_button, FALSE, FALSE, 2);
751
745
        gtk_box_pack_start(GTK_BOX(hbox2), scfw_button, FALSE, FALSE, 2);
752
746
        gtk_box_pack_start(GTK_BOX(hbox2), vseparator1, FALSE, FALSE, 2);
755
749
        /*gtk_box_pack_start(GTK_BOX(hbox2), vseparator2, TRUE, TRUE, 3);*/
756
750
        gtk_box_pack_start(GTK_BOX(hbox2), rec_button, FALSE, FALSE, 2);
757
751
        gtk_box_pack_start(GTK_BOX(hbox2), vseparator4, FALSE, FALSE, 2);
758
 
@@ -1106,7 +1075,7 @@
 
752
@@ -1104,7 +1074,7 @@
759
753
        g_signal_connect(G_OBJECT(app), "delete_event", G_CALLBACK(delete_event_cb), NULL);
760
754
        g_signal_connect(G_OBJECT(quit_button), "clicked", G_CALLBACK(quit_button_clicked_cb), NULL);
761
755
        g_signal_connect(G_OBJECT(adj), "value-changed", G_CALLBACK(adj_value_changed_cb), (gpointer) app);
764
758
        g_signal_connect(G_OBJECT(stfw_button), "pressed", G_CALLBACK(step_button_pressed_cb), (gpointer)TRUE);
765
759
        g_signal_connect(G_OBJECT(stbw_button), "pressed", G_CALLBACK(step_button_pressed_cb), (gpointer)FALSE);
766
760
        g_signal_connect(G_OBJECT(stfw_button), "clicked", G_CALLBACK(step_button_clicked_cb), (gpointer)TRUE);
767
 
@@ -1127,7 +1096,7 @@
 
761
@@ -1125,7 +1095,7 @@
768
762
        gtk_widget_set_tooltip_text(about_button, _("About Gnomeradio"));
769
763
        gtk_widget_set_tooltip_text(rec_button, _("Record radio as OGG, Flac, Wave or MP3"));
770
764
        gtk_widget_set_tooltip_text(prefs_button, _("Edit your Preferences"));
773
767
        gtk_widget_set_tooltip_text(quit_button, _("Quit"));
774
768
        text = g_strdup_printf(_("Frequency: %.2f MHz"), gtk_adjustment_get_value(adj)/STEPS);
775
769
        gtk_widget_set_tooltip_text(freq_scale, text);
776
 
@@ -1145,12 +1114,11 @@
777
 
 static void
778
 
 session_die_cb(void)
779
 
 {
780
 
-       if (settings.mute_on_exit)
781
 
-       {
782
 
+       if (settings.mute_on_exit) {
783
 
                radio_mute();
 
770
@@ -1146,7 +1116,7 @@
 
771
        if (settings.mute_on_exit)
784
772
                radio_stop();
785
 
        }
 
773
 
786
774
-       mixer_close();
787
775
+       mixer->close_device();
788
776
        gtk_main_quit();
789
777
        exit (0);
790
778
 }
791
 
@@ -1174,7 +1142,7 @@
 
779
@@ -1170,7 +1140,7 @@
792
780
 gboolean
793
781
 key_press_event_cb(GtkWidget *app, GdkEventKey *event, gpointer data)
794
782
 {
797
785
        
798
786
        switch (event->keyval)
799
787
        {
800
 
@@ -1206,12 +1174,12 @@
 
788
@@ -1202,12 +1172,12 @@
801
789
                                break;
802
790
                case GDK_KEY_KP_Add:
803
791
                case GDK_KEY_plus:      
812
800
                                /*gtk_adjustment_set_value(volume,(volume->value < 5) ? 0 : volume->value-5);*/
813
801
                                break;
814
802
        }
815
 
@@ -1372,8 +1340,8 @@
 
803
@@ -1368,8 +1338,8 @@
816
804
 
817
805
        load_settings();
818
806
 
822
810
        if (is_first_start() || do_scan) {
823
811
                if (!radio_is_init()) {
824
812
                        fprintf(stderr, "Could not scan. Radio is not initialized\n");
825
 
@@ -1393,6 +1361,7 @@
 
813
@@ -1389,6 +1359,7 @@
826
814
 
827
815
        gtk_widget_show_all(app);
828
816
        main_visible = TRUE;
832
820
        create_tray_icon(app);
833
821
Index: gnomeradio-1.8/src/gui.h
834
822
===================================================================
835
 
--- gnomeradio-1.8.orig/src/gui.h       2013-09-24 15:29:22.435420129 +0000
836
 
+++ gnomeradio-1.8/src/gui.h    2013-09-24 15:29:22.431420129 +0000
 
823
--- gnomeradio-1.8.orig/src/gui.h       2013-09-26 13:29:11.362432810 +0000
 
824
+++ gnomeradio-1.8/src/gui.h    2013-09-26 13:29:11.358432810 +0000
837
825
@@ -30,10 +30,9 @@
838
826
 struct Gnomeradio_Settings
839
827
 {
857
845
 void scfw_button_clicked_cb(GtkButton *button, gpointer data);
858
846
Index: gnomeradio-1.8/src/prefs.c
859
847
===================================================================
860
 
--- gnomeradio-1.8.orig/src/prefs.c     2013-09-24 15:29:22.435420129 +0000
861
 
+++ gnomeradio-1.8/src/prefs.c  2013-09-24 15:29:22.431420129 +0000
 
848
--- gnomeradio-1.8.orig/src/prefs.c     2013-09-26 13:29:11.362432810 +0000
 
849
+++ gnomeradio-1.8/src/prefs.c  2013-09-26 13:29:11.358432810 +0000
862
850
@@ -26,7 +26,7 @@
863
851
 #include "gui.h"
864
852
 #include "rec_tech.h"
1114
1102
        record_hdr = g_strconcat("<span weight=\"bold\">", _("Record Settings"), "</span>", NULL);
1115
1103
Index: gnomeradio-1.8/src/trayicon.c
1116
1104
===================================================================
1117
 
--- gnomeradio-1.8.orig/src/trayicon.c  2013-09-24 15:29:22.435420129 +0000
1118
 
+++ gnomeradio-1.8/src/trayicon.c       2013-09-24 15:29:22.431420129 +0000
 
1105
--- gnomeradio-1.8.orig/src/trayicon.c  2013-09-26 13:29:11.362432810 +0000
 
1106
+++ gnomeradio-1.8/src/trayicon.c       2013-09-26 13:29:11.358432810 +0000
1119
1107
@@ -23,7 +23,7 @@
1120
1108
 #include <gtk/gtk.h>
1121
1109
 #include "gui.h"
1136
1124
        g_signal_connect(G_OBJECT(mute_menuitem), "toggled", (GCallback)mute_menuitem_toggled_cb, (gpointer)app);
1137
1125
Index: gnomeradio-1.8/src/record.c
1138
1126
===================================================================
1139
 
--- gnomeradio-1.8.orig/src/record.c    2013-09-24 15:29:22.435420129 +0000
1140
 
+++ gnomeradio-1.8/src/record.c 2013-09-24 15:29:22.431420129 +0000
 
1127
--- gnomeradio-1.8.orig/src/record.c    2013-09-26 13:29:11.362432810 +0000
 
1128
+++ gnomeradio-1.8/src/record.c 2013-09-26 13:29:11.358432810 +0000
1141
1129
@@ -27,7 +27,6 @@
1142
1130
 #include <gtk/gtk.h>
1143
1131
 #include <glib/gi18n.h>
1148
1136
 
1149
1137
Index: gnomeradio-1.8/src/lirc.c
1150
1138
===================================================================
1151
 
--- gnomeradio-1.8.orig/src/lirc.c      2013-09-24 15:29:22.435420129 +0000
1152
 
+++ gnomeradio-1.8/src/lirc.c   2013-09-24 15:30:33.743418009 +0000
 
1139
--- gnomeradio-1.8.orig/src/lirc.c      2013-09-26 13:29:11.362432810 +0000
 
1140
+++ gnomeradio-1.8/src/lirc.c   2013-09-26 13:29:11.358432810 +0000
1153
1141
@@ -27,7 +27,7 @@
1154
1142
 #include "lirc.h"
1155
1143
 #include "gui.h"
1185
1173
        else if (strcasecmp (cmd, "mute") == 0)
1186
1174
Index: gnomeradio-1.8/data/gnomeradio.schemas.in
1187
1175
===================================================================
1188
 
--- gnomeradio-1.8.orig/data/gnomeradio.schemas.in      2013-09-24 15:29:22.435420129 +0000
1189
 
+++ gnomeradio-1.8/data/gnomeradio.schemas.in   2013-09-24 15:29:22.431420129 +0000
 
1176
--- gnomeradio-1.8.orig/data/gnomeradio.schemas.in      2013-09-26 13:29:11.362432810 +0000
 
1177
+++ gnomeradio-1.8/data/gnomeradio.schemas.in   2013-09-26 13:29:11.358432810 +0000
1190
1178
@@ -8,7 +8,7 @@
1191
1179
       <default>TRUE</default>
1192
1180
       <locale name="C">
1250
1238
        
1251
1239
Index: gnomeradio-1.8/src/Makefile.am
1252
1240
===================================================================
1253
 
--- gnomeradio-1.8.orig/src/Makefile.am 2013-09-24 15:29:22.435420129 +0000
1254
 
+++ gnomeradio-1.8/src/Makefile.am      2013-09-24 15:29:22.431420129 +0000
 
1241
--- gnomeradio-1.8.orig/src/Makefile.am 2013-09-26 13:29:11.362432810 +0000
 
1242
+++ gnomeradio-1.8/src/Makefile.am      2013-09-26 13:29:11.358432810 +0000
1255
1243
@@ -15,11 +15,11 @@
1256
1244
        get_media_devices.h     \
1257
1245
        gui.h                   \
1283
1271
Index: gnomeradio-1.8/src/mixer-alsa.c
1284
1272
===================================================================
1285
1273
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
1286
 
+++ gnomeradio-1.8/src/mixer-alsa.c     2013-09-24 15:29:22.431420129 +0000
 
1274
+++ gnomeradio-1.8/src/mixer-alsa.c     2013-09-26 13:29:11.358432810 +0000
1287
1275
@@ -0,0 +1,238 @@
1288
1276
+/**
1289
1277
+ * Copyright (C) 2006 Philipp Hahn <pmhahn@users.sourceforge.net>
1526
1514
Index: gnomeradio-1.8/src/mixer-oss.c
1527
1515
===================================================================
1528
1516
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
1529
 
+++ gnomeradio-1.8/src/mixer-oss.c      2013-09-24 15:29:22.431420129 +0000
 
1517
+++ gnomeradio-1.8/src/mixer-oss.c      2013-09-26 13:29:11.358432810 +0000
1530
1518
@@ -0,0 +1,261 @@
1531
1519
+/**
1532
1520
+ * Copyright (C) 2002, 2003 Doug Bell <drbell@users.sourceforge.net>
1791
1779
+};
1792
1780
Index: gnomeradio-1.8/src/prefs.h
1793
1781
===================================================================
1794
 
--- gnomeradio-1.8.orig/src/prefs.h     2013-09-24 15:29:22.435420129 +0000
1795
 
+++ gnomeradio-1.8/src/prefs.h  2013-09-24 15:29:22.431420129 +0000
 
1782
--- gnomeradio-1.8.orig/src/prefs.h     2013-09-26 13:29:11.362432810 +0000
 
1783
+++ gnomeradio-1.8/src/prefs.h  2013-09-26 13:29:11.358432810 +0000
1796
1784
@@ -22,6 +22,15 @@
1797
1785
 gboolean save_settings(void);
1798
1786
 gboolean load_settings(void);