~ubuntu-branches/ubuntu/trusty/hfsprogs/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/30-formatting_strings.patch

  • Committer: Bazaar Package Importer
  • Author(s): Rogério Brito
  • Date: 2008-10-07 05:08:48 UTC
  • Revision ID: james.westby@ubuntu.com-20081007050848-41lpw5sihm0kh2wp
Tags: 332.14-5
* debian/patches: break-up the Gentoo patch into smaller patches.
* debian/patches: reorder the patches.
* debian/patches: refresh the patches.
* debian/patches: remove mention of pdisk (Closes: #482868) (LP: #234749).
* debian/control: include Homepage field.
* debian/control: update Standards-Version to 3.8.0. No changes required.
* debian/control: include DM-Upload-Allowed, as I am a DM now.
* debian/control: remove statement about using journals (LP: #164151).
* debian/rules: add -Wextra compilation flag.
* debian/rules: use quilt.make and remove home-brew solution.
* debian/watch: create watch file (lintian warning).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: hfsprogs-332.14/fsck_hfs.tproj/dfalib/BTreeTreeOps.c
 
2
===================================================================
 
3
--- hfsprogs-332.14.orig/fsck_hfs.tproj/dfalib/BTreeTreeOps.c   2008-10-07 05:08:02.000000000 -0300
 
4
+++ hfsprogs-332.14/fsck_hfs.tproj/dfalib/BTreeTreeOps.c        2008-10-07 05:08:12.000000000 -0300
 
5
@@ -223,7 +223,7 @@
 
6
         //
 
7
         if (curNodeNum == 0)
 
8
         {
 
9
-//          Panic("\pSearchTree: curNodeNum is zero!");
 
10
+            Panic("SearchTree: curNodeNum is zero!");
 
11
             err = fsBTInvalidNodeErr;
 
12
             goto ErrorExit;
 
13
         }
 
14
@@ -433,7 +433,7 @@
 
15
                M_ExitOnError (err);
 
16
                
 
17
                if ( DEBUG_BUILD && updateParent && newRoot )
 
18
-                       DebugStr("\p InsertLevel: New root from primary key, update from secondary key...");
 
19
+                       DebugStr("InsertLevel: New root from primary key, update from secondary key...");
 
20
        }
 
21
 
 
22
        //////////////////////// Update Parent(s) ///////////////////////////////
 
23
@@ -448,7 +448,7 @@
 
24
                
 
25
                secondaryKey = nil;
 
26
                
 
27
-               PanicIf ( (level == btreePtr->treeDepth), "\p InsertLevel: unfinished insert!?");
 
28
+               PanicIf ( (level == btreePtr->treeDepth), "InsertLevel: unfinished insert!?");
 
29
 
 
30
                ++level;
 
31
 
 
32
@@ -456,7 +456,7 @@
 
33
                index = treePathTable [level].index;
 
34
                parentNodeNum = treePathTable [level].node;
 
35
 
 
36
-               PanicIf ( parentNodeNum == 0, "\p InsertLevel: parent node is zero!?");
 
37
+               PanicIf ( parentNodeNum == 0, "InsertLevel: parent node is zero!?");
 
38
 
 
39
                err = GetNode (btreePtr, parentNodeNum, &parentNode);   // released as target node in next level up
 
40
                M_ExitOnError (err);
 
41
@@ -470,7 +470,7 @@
 
42
                {
 
43
                        //���debug: check if ptr == targetNodeNum
 
44
                        GetRecordByIndex (btreePtr, parentNode.buffer, index, &keyPtr, &recPtr, &recSize);
 
45
-                       PanicIf( (*(UInt32 *) recPtr) != targetNodeNum, "\p InsertLevel: parent ptr doesn't match target node!");
 
46
+                       PanicIf( (*(UInt32 *) recPtr) != targetNodeNum, "InsertLevel: parent ptr doesn't match target node!");
 
47
                        
 
48
                        // need to delete and re-insert this parent key/ptr
 
49
                        // we delete it here and it gets re-inserted in the
 
50
@@ -532,7 +532,7 @@
 
51
        (void) ReleaseNode (btreePtr, targetNode);
 
52
        (void) ReleaseNode (btreePtr, &siblingNode);
 
53
 
 
54
-       Panic ("\p InsertLevel: an error occured!");
 
55
+       Panic ("InsertLevel: an error occured!");
 
56
 
 
57
        return  err;
 
58
 
 
59
@@ -566,7 +566,7 @@
 
60
 
 
61
        *rootSplit = false;
 
62
        
 
63
-       PanicIf ( targetNode->buffer == siblingNode->buffer, "\p InsertNode: targetNode == siblingNode, huh?");
 
64
+       PanicIf ( targetNode->buffer == siblingNode->buffer, "InsertNode: targetNode == siblingNode, huh?");
 
65
        
 
66
        leftNodeNum = ((NodeDescPtr) targetNode->buffer)->bLink;
 
67
        rightNodeNum = ((NodeDescPtr) targetNode->buffer)->fLink;
 
68
@@ -606,7 +606,7 @@
 
69
        
 
70
        if ( leftNodeNum > 0 )
 
71
        {
 
72
-               PanicIf ( siblingNode->buffer != nil, "\p InsertNode: siblingNode already aquired!");
 
73
+               PanicIf ( siblingNode->buffer != nil, "InsertNode: siblingNode already aquired!");
 
74
 
 
75
                if ( siblingNode->buffer == nil )
 
76
                {
 
77
@@ -614,7 +614,7 @@
 
78
                        M_ExitOnError (err);
 
79
                }
 
80
 
 
81
-               PanicIf ( ((NodeDescPtr) siblingNode->buffer)->fLink != nodeNum, "\p InsertNode, RotateLeft: invalid sibling link!" );
 
82
+               PanicIf ( ((NodeDescPtr) siblingNode->buffer)->fLink != nodeNum, "InsertNode, RotateLeft: invalid sibling link!" );
 
83
 
 
84
                if ( !key->skipRotate )         // are rotates allowed?
 
85
                {
 
86
@@ -703,7 +703,7 @@
 
87
 
 
88
        targetNodeNum = treePathTable[level].node;
 
89
        targetNodePtr = targetNode->buffer;
 
90
-       PanicIf (targetNodePtr == nil, "\pDeleteTree: targetNode has nil buffer!");
 
91
+       PanicIf (targetNodePtr == nil, "DeleteTree: targetNode has nil buffer!");
 
92
 
 
93
        DeleteRecord (btreePtr, targetNodePtr, index);
 
94
                
 
95
@@ -797,7 +797,7 @@
 
96
                         
 
97
                        //���debug: check if ptr == targetNodeNum
 
98
                        GetRecordByIndex (btreePtr, parentNode.buffer, index, &keyPtr, &recPtr, &recSize);
 
99
-                       PanicIf( (*(UInt32 *) recPtr) != targetNodeNum, "\p DeleteTree: parent ptr doesn't match targetNodeNum!!");
 
100
+                       PanicIf( (*(UInt32 *) recPtr) != targetNodeNum, " DeleteTree: parent ptr doesn't match targetNodeNum!!");
 
101
                        
 
102
                        // need to delete and re-insert this parent key/ptr
 
103
                        DeleteRecord (btreePtr, parentNode.buffer, index);
 
104
@@ -1018,7 +1018,7 @@
 
105
                                                                                keyPtr, keyLength, recPtr, recSize);
 
106
                        if ( !didItFit )
 
107
                        {
 
108
-                               Panic ("\pRotateLeft: InsertKeyRecord (left) returned false!");
 
109
+                               Panic ("RotateLeft: InsertKeyRecord (left) returned false!");
 
110
                                err = fsBTBadRotateErr;
 
111
                                goto ErrorExit;
 
112
                        }
 
113
@@ -1031,7 +1031,7 @@
 
114
                        didItFit = RotateRecordLeft (btreePtr, leftNode, rightNode);
 
115
                        if ( !didItFit )
 
116
                        {
 
117
-                               Panic ("\pRotateLeft: RotateRecordLeft returned false!");
 
118
+                               Panic ("RotateLeft: RotateRecordLeft returned false!");
 
119
                                err = fsBTBadRotateErr;
 
120
                                goto ErrorExit;
 
121
                        }
 
122
@@ -1048,7 +1048,7 @@
 
123
                                                                        keyPtr, keyLength, recPtr, recSize);
 
124
                if ( !didItFit )
 
125
                {
 
126
-                       Panic ("\pRotateLeft: InsertKeyRecord (right) returned false!");
 
127
+                       Panic ("RotateLeft: InsertKeyRecord (right) returned false!");
 
128
                        err = fsBTBadRotateErr;
 
129
                        goto ErrorExit;
 
130
                }
 
131
@@ -1117,7 +1117,7 @@
 
132
        right = rightNode->buffer;
 
133
        left  = leftNode->buffer;
 
134
        
 
135
-       PanicIf ( right->bLink != 0 && left == 0, "\p SplitLeft: left sibling missing!?" );
 
136
+       PanicIf ( right->bLink != 0 && left == 0, " SplitLeft: left sibling missing!?" );
 
137
        
 
138
        //�� type should be kLeafNode or kIndexNode
 
139
        
 
140
@@ -1240,8 +1240,8 @@
 
141
        Boolean                         didItFit;
 
142
        UInt16                          keyLength;      
 
143
        
 
144
-       PanicIf (leftNode == nil, "\pAddNewRootNode: leftNode == nil");
 
145
-       PanicIf (rightNode == nil, "\pAddNewRootNode: rightNode == nil");
 
146
+       PanicIf (leftNode == nil, "AddNewRootNode: leftNode == nil");
 
147
+       PanicIf (rightNode == nil, "AddNewRootNode: rightNode == nil");
 
148
        
 
149
        
 
150
        /////////////////////// Initialize New Root Node ////////////////////////////
 
151
@@ -1264,7 +1264,7 @@
 
152
        didItFit = InsertKeyRecord ( btreePtr, rootNode.buffer, 0, keyPtr, keyLength,
 
153
                                                                 (UInt8 *) &rightNode->bLink, 4 );
 
154
 
 
155
-       PanicIf ( !didItFit, "\pAddNewRootNode:InsertKeyRecord failed for left index record");
 
156
+       PanicIf ( !didItFit, "AddNewRootNode:InsertKeyRecord failed for left index record");
 
157
 
 
158
 
 
159
        //////////////////// Insert Right Node Index Record /////////////////////////
 
160
@@ -1275,7 +1275,7 @@
 
161
        didItFit = InsertKeyRecord ( btreePtr, rootNode.buffer, 1, keyPtr, keyLength,
 
162
                                                                 (UInt8 *) &leftNode->fLink, 4 );
 
163
 
 
164
-       PanicIf ( !didItFit, "\pAddNewRootNode:InsertKeyRecord failed for right index record");
 
165
+       PanicIf ( !didItFit, "AddNewRootNode:InsertKeyRecord failed for right index record");
 
166
 
 
167
 
 
168
 #if DEBUG_TREEOPS
 
169
@@ -1355,7 +1355,7 @@
 
170
        }
 
171
        rightPtr = rightNodePtr->buffer;
 
172
        
 
173
-       PanicIf ( leftPtr->fLink != 0 && rightPtr == 0, "\p SplitRight: right sibling missing!?" );
 
174
+       PanicIf ( leftPtr->fLink != 0 && rightPtr == 0, "SplitRight: right sibling missing!?" );
 
175
        
 
176
        //�� type should be kLeafNode or kIndexNode
 
177
        
 
178
@@ -1557,7 +1557,7 @@
 
179
                                                                        keyPtr, keyLength, recPtr, recSize);
 
180
                if ( !didItFit )
 
181
                {
 
182
-                       Panic ("\pRotateRight: InsertKeyRecord (left) returned false!");
 
183
+                       Panic ("RotateRight: InsertKeyRecord (left) returned false!");
 
184
                        err = fsBTBadRotateErr;
 
185
                        goto ErrorExit;
 
186
                }
 
187
@@ -1572,7 +1572,7 @@
 
188
                didItFit = RotateRecordRight( btreePtr, leftNodePtr, rightNodePtr );
 
189
                if ( !didItFit )
 
190
                {
 
191
-                       Panic ("\pRotateRight: RotateRecordRight returned false!");
 
192
+                       Panic ("RotateRight: RotateRecordRight returned false!");
 
193
                        err = fsBTBadRotateErr;
 
194
                        goto ErrorExit;
 
195
                }
 
196
@@ -1583,7 +1583,7 @@
 
197
                                                                                keyPtr, keyLength, recPtr, recSize);
 
198
                        if ( !didItFit )
 
199
                        {
 
200
-                               Panic ("\pRotateRight: InsertKeyRecord (left) returned false!");
 
201
+                               Panic ("RotateRight: InsertKeyRecord (left) returned false!");
 
202
                                err = fsBTBadRotateErr;
 
203
                                goto ErrorExit;
 
204
                        }
 
205
@@ -1607,7 +1607,7 @@
 
206
                                                                        keyPtr, keyLength, recPtr, recSize);
 
207
                if ( !didItFit )
 
208
                {
 
209
-                       Panic ("\pRotateRight: InsertKeyRecord (right) returned false!");
 
210
+                       Panic ("RotateRight: InsertKeyRecord (right) returned false!");
 
211
                        err = fsBTBadRotateErr;
 
212
                        goto ErrorExit;
 
213
                }
 
214
Index: hfsprogs-332.14/fsck_hfs.tproj/dfalib/SBTree.c
 
215
===================================================================
 
216
--- hfsprogs-332.14.orig/fsck_hfs.tproj/dfalib/SBTree.c 2008-10-07 05:08:08.000000000 -0300
 
217
+++ hfsprogs-332.14/fsck_hfs.tproj/dfalib/SBTree.c      2008-10-07 05:08:12.000000000 -0300
 
218
@@ -93,7 +93,7 @@
 
219
                        CopyMemory(&resultIterator->key, foundKey, CalcKeySize(btcb, &resultIterator->key));    //�� warning, this could overflow user's buffer!!!
 
220
 
 
221
                if ( DEBUG_BUILD && !ValidHFSRecord(data, btcb, *dataSize) )
 
222
-                       DebugStr("\pSearchBTreeRecord: bad record?");
 
223
+                       DebugStr("SearchBTreeRecord: bad record?");
 
224
        }
 
225
 
 
226
 ErrorExit:
 
227
@@ -190,7 +190,7 @@
 
228
                CopyMemory(&iterator->key, key, CalcKeySize(btcb, &iterator->key));     //�� warning, this could overflow user's buffer!!!
 
229
                
 
230
                if ( DEBUG_BUILD && !ValidHFSRecord(data, btcb, *dataSize) )
 
231
-                       DebugStr("\pGetBTreeRecord: bad record?");
 
232
+                       DebugStr("GetBTreeRecord: bad record?");
 
233
 
 
234
        }
 
235
        
 
236
@@ -222,7 +222,7 @@
 
237
        CopyMemory(key, &iterator.key, CalcKeySize(btcb, (BTreeKey *) key));    //�� should we range check against maxkeylen?
 
238
 
 
239
        if ( DEBUG_BUILD && !ValidHFSRecord(data, btcb, dataSize) )
 
240
-               DebugStr("\pInsertBTreeRecord: bad record?");
 
241
+               DebugStr("InsertBTreeRecord: bad record?");
 
242
 
 
243
        result = BTInsertRecord( fcb, &iterator, &btRecord, dataSize );
 
244
 
 
245
@@ -284,7 +284,7 @@
 
246
        CopyMemory(key, &iterator.key, CalcKeySize(btcb, (BTreeKey *) key));            //�� should we range check against maxkeylen?
 
247
 
 
248
        if ( DEBUG_BUILD && !ValidHFSRecord(newData, btcb, dataSize) )
 
249
-               DebugStr("\pReplaceBTreeRecord: bad record?");
 
250
+               DebugStr("ReplaceBTreeRecord: bad record?");
 
251
 
 
252
        result = BTReplaceRecord( fcb, &iterator, &btRecord, dataSize );
 
253
 
 
254
@@ -323,7 +323,7 @@
 
255
        else
 
256
        {
 
257
                if ( DEBUG_BUILD )
 
258
-                       DebugStr("\pSetEndOfForkProc: minEOF is smaller than current size!");
 
259
+                       DebugStr("SetEndOfForkProc: minEOF is smaller than current size!");
 
260
                return -1;
 
261
        }
 
262
 
 
263
@@ -349,7 +349,7 @@
 
264
        //      Make sure we got at least as much space as we needed
 
265
        //
 
266
        if (filePtr->fcbLogicalSize < minEOF) {
 
267
-               Panic("\pSetEndOfForkProc: disk too full to extend B-tree file");
 
268
+               Panic("SetEndOfForkProc: disk too full to extend B-tree file");
 
269
                return dskFulErr;
 
270
        }
 
271
        
 
272
@@ -421,7 +421,7 @@
 
273
        if ( (keyLen < 6) || (keyLen > btcb->maxKeyLength) )
 
274
        {
 
275
                if ( DEBUG_BUILD )
 
276
-                       DebugStr("\pCheckBTreeKey: bad key length!");
 
277
+                       DebugStr("CheckBTreeKey: bad key length!");
 
278
                return fsBTInvalidKeyLengthErr;
 
279
        }
 
280