~ubuntu-branches/ubuntu/trusty/hfsprogs/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/diskdev_cmds_system_check-332.14.patch

  • Committer: Bazaar Package Importer
  • Author(s): Rogério Brito
  • Date: 2008-10-07 05:08:48 UTC
  • Revision ID: james.westby@ubuntu.com-20081007050848-41lpw5sihm0kh2wp
Tags: 332.14-5
* debian/patches: break-up the Gentoo patch into smaller patches.
* debian/patches: reorder the patches.
* debian/patches: refresh the patches.
* debian/patches: remove mention of pdisk (Closes: #482868) (LP: #234749).
* debian/control: include Homepage field.
* debian/control: update Standards-Version to 3.8.0. No changes required.
* debian/control: include DM-Upload-Allowed, as I am a DM now.
* debian/control: remove statement about using journals (LP: #164151).
* debian/rules: add -Wextra compilation flag.
* debian/rules: use quilt.make and remove home-brew solution.
* debian/watch: create watch file (lintian warning).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: hfsprogs-332.14/fsck_hfs.tproj/fsck_hfs.c
2
 
===================================================================
3
 
--- hfsprogs-332.14.orig/fsck_hfs.tproj/fsck_hfs.c      2007-07-23 17:18:26.000000000 -0300
4
 
+++ hfsprogs-332.14/fsck_hfs.tproj/fsck_hfs.c   2007-07-23 20:35:33.000000000 -0300
5
 
@@ -109,7 +109,7 @@
6
 
        else
7
 
                progname = *argv;
8
 
 
9
 
-       while ((ch = getopt(argc, argv, "dfglm:npqruy")) != EOF) {
10
 
+       while ((ch = getopt(argc, argv, "dfglm:napqruy")) != EOF) {
11
 
                switch (ch) {
12
 
                case 'd':
13
 
                        debug++;
14
 
@@ -145,6 +145,7 @@
15
 
                        yflag = 0;
16
 
                        break;
17
 
 
18
 
+               case 'a':
19
 
                case 'p':
20
 
                        preen++;
21
 
                        break;
22
 
@@ -535,7 +536,7 @@
23
 
        (void) fprintf(stderr, "  l = live fsck (lock down and test-only)\n");
24
 
        (void) fprintf(stderr, "  m arg = octal mode used when creating lost+found directory \n");
25
 
        (void) fprintf(stderr, "  n = assume a no response \n");
26
 
-       (void) fprintf(stderr, "  p = just fix normal inconsistencies \n");
27
 
+       (void) fprintf(stderr, "  p, a = just fix normal inconsistencies \n");
28
 
        (void) fprintf(stderr, "  q = quick check returns clean, dirty, or failure \n");
29
 
        (void) fprintf(stderr, "  r = rebuild catalog btree \n");
30
 
        (void) fprintf(stderr, "  u = usage \n");