~ubuntu-branches/ubuntu/trusty/ocamlnet/trusty

« back to all changes in this revision

Viewing changes to debian/patches/Add-rpath-to-Apache-module.patch

  • Committer: Bazaar Package Importer
  • Author(s): Stéphane Glondu
  • Date: 2011-09-02 14:12:33 UTC
  • mfrom: (18.2.3 sid)
  • Revision ID: james.westby@ubuntu.com-20110902141233-zbj0ygxb92u6gy4z
Tags: 3.4-1
* New upstream release
  - add a new NetcgiRequire directive to ease dependency management
    (Closes: #637147)
  - remove patches that were applied upstream:
    + Added-missing-shebang-lines-in-example-shell-scripts
    + Try-also-ocamlc-for-POSIX-threads

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Stefano Zacchiroli <zack@debian.org>
 
2
Date: Tue, 6 Oct 2009 15:34:00 +0200
 
3
Subject: Add rpath to Apache module
 
4
 
 
5
Add rpath to Apache module, pointing to `ocamlc -where`. Rationale:
 
6
ensure libcamlrun_shared.so can be found.
 
7
 
 
8
Signed-off-by: Stefano Zacchiroli <zack@debian.org>
 
9
---
 
10
 src/netcgi2-apache/Makefile.def |    2 +-
 
11
 1 files changed, 1 insertions(+), 1 deletions(-)
 
12
 
 
13
diff --git a/src/netcgi2-apache/Makefile.def b/src/netcgi2-apache/Makefile.def
 
14
index 7b1bb61..e93bae8 100644
 
15
--- a/src/netcgi2-apache/Makefile.def
 
16
+++ b/src/netcgi2-apache/Makefile.def
 
17
@@ -50,7 +50,7 @@ endif
 
18
 ### Only works with OCaml >= 3.11 on plafforms where PIC differs from non-PIC
 
19
 ### See http://caml.inria.fr/mantis/view.php?id=3866
 
20
 mod_netcgi_apache.so: $(MOD_OBJECTS)
 
21
-       $(APXS) -c -o $@ $^ -L$(APACHE_OCAMLLIBDIR) $(patsubst -lcamlrun,-lcamlrun_shared,$(APACHE_OCAMLLIBS))
 
22
+       $(APXS) -c -o $@ $^ -L$(APACHE_OCAMLLIBDIR) -Wl,--rpath,$(APACHE_OCAMLLIBDIR) $(patsubst -lcamlrun,-lcamlrun_shared,$(APACHE_OCAMLLIBS))
 
23
        test -f .libs/$@ && cp .libs/$@ .
 
24
 
 
25
 netcgi_apache_mod.lo: netcgi_apache_mod.o
 
26
--