~ubuntu-branches/ubuntu/trusty/xscreensaver/trusty

« back to all changes in this revision

Viewing changes to debian/patches/28_rotate.patch

  • Committer: Bazaar Package Importer
  • Author(s): Robert Ancell
  • Date: 2009-11-30 13:33:13 UTC
  • mfrom: (1.1.8 upstream) (2.1.6 squeeze)
  • Revision ID: james.westby@ubuntu.com-20091130133313-3b5nz2e7hvbb8h3l
Tags: 5.10-3ubuntu1
* Merge with Debian unstable, remaining changes: (LP: #489062)
  - debian/control: add Build-Depends on ubuntu-artwork
  - debian/rules: use /usr/share/backgrounds
  - debian/control: Move xli | xloadimage recommends to suggests
  - debian/split-hacks.config: Use different set of default hacks to Debian
  - debian/source_xscreensaver.py: Add apport hook
  - debian/patches/53_XScreenSaver.ad.in.patch: Use Ubuntu branding

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 06_rotate.dpatch by Ted Gould <ted@ubuntu.com>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: No description.
6
 
 
7
 
@DPATCH@
8
 
diff -urNad xscreensaver-5.04~/driver/xscreensaver-getimage.c xscreensaver-5.04/driver/xscreensaver-getimage.c
9
 
--- xscreensaver-5.04~/driver/xscreensaver-getimage.c   2006-09-18 02:03:58.000000000 +0100
10
 
+++ xscreensaver-5.04/driver/xscreensaver-getimage.c    2008-01-23 12:09:57.000000000 +0000
11
 
@@ -400,6 +400,7 @@
12
 
     }
13
 
   else
14
 
     {
15
 
+         pb = gdk_pixbuf_apply_embedded_orientation(pb);
16
 
       int w = gdk_pixbuf_get_width (pb);
17
 
       int h = gdk_pixbuf_get_height (pb);
18
 
       int srcx, srcy, destx, desty, w2, h2;