~ubuntu-branches/ubuntu/utopic/armel-cross-toolchain-base/utopic

« back to all changes in this revision

Viewing changes to debian/patches/binutils/add-multiarch-dirs-for-linker.patch

  • Committer: Package Import Robot
  • Author(s): Marcin Juszkiewicz, Wookey, Marcin Juszkiewicz
  • Date: 2012-05-15 15:39:42 UTC
  • Revision ID: package-import@ubuntu.com-20120515153942-snhd05521kh55sh8
Tags: 1.83
[ Wookey ]
* Debian switched to gcc-4.7 so we have to too.

[ Marcin Juszkiewicz ]
* GCC-4.7 related changes:
  - added patch to drop --disable-multiarch for stage1
  - refreshed enable-multiarch-directories.patch
* Dropped creation of /usr/TRIPLET/include/TRIPLET/asm directory under
        Debian.
* Moved cross binutils to separate source package as this will make
  armel-cross-toolchain-base (a-c-t-b) arch:all so less building. Also
  allows to kill a-c-t-b when we will get cross-arch build dependencies.
* Build gcc-4.6/cross for building eglibc/cross and then gcc-4.7/cross to
        have libgcc1/cross. This part will be reverted when eglibc will be
        compiled with gcc-4.7 version.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff -Naru binutils-2.22-orig/debian/rules binutils-2.22/debian/rules
2
 
--- binutils-2.22-orig/debian/rules     2012-04-10 09:44:17.000000000 +0200
3
 
+++ binutils-2.22/debian/rules  2012-04-10 09:45:08.288687102 +0200
4
 
@@ -50,6 +50,13 @@
 
1
Author: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
 
2
Subject: Make ld/gold search multiarch directories
 
3
 
 
4
Patch does few things:
 
5
 
 
6
1. Moves code which handle TARGET and debian/target into first part of
 
7
   debian/rules - we need it to set DEB_TARGET_MULTIARCH which is used
 
8
   by ld/genscripts.sh
 
9
2. Uses DEB_TARGET_MULTIARCH to add multiarch directories into SEARCH_DIR
 
10
   of ld.
 
11
3. Sets MULTIARCH_DIRNAME in gold/configure(.ac) for all cases: native, 
 
12
   cross, 'reverse native' so we always have ld which checks multiarch
 
13
   directories
 
14
 
 
15
 
 
16
Index: binutils-2.22/debian/rules
 
17
===================================================================
 
18
--- binutils-2.22.orig/debian/rules     2012-01-07 08:16:06.000000000 +0000
 
19
+++ binutils-2.22/debian/rules  2012-04-15 08:15:41.374745488 +0000
 
20
@@ -46,6 +46,13 @@
5
21
 install_script = install -m 755
6
22
 install_binary = install -m 755 -s
7
23
 
15
31
 vafilt = $(subst $(2)=,,$(filter $(2)=%,$(1)))
16
32
 DPKG_VARS := $(shell dpkg-architecture)
17
33
 DEB_BUILD_GNU_TYPE     ?= $(call vafilt,$(DPKG_VARS),DEB_BUILD_GNU_TYPE)
18
 
@@ -57,6 +64,19 @@
 
34
@@ -53,6 +60,19 @@
19
35
 DEB_HOST_GNU_TYPE      ?= $(call vafilt,$(DPKG_VARS),DEB_HOST_GNU_TYPE)
20
36
 DEB_HOST_MULTIARCH     ?= $(call vafilt,$(DPKG_VARS),DEB_HOST_MULTIARCH)
21
37
 
35
51
 ifeq (,$(DEB_HOST_MULTIARCH))
36
52
   ifeq ($(DEB_HOST_ARCH),i386)
37
53
     DEB_HOST_MULTIARCH = i386-linux-gnu
38
 
@@ -151,13 +171,6 @@
 
54
@@ -141,13 +161,6 @@
39
55
   with_multiarch = disabled in DEB_BUILD_OPTIONS
40
56
 endif
41
57
 
49
65
 # PF is the installation prefix for the package without the leading slash.
50
66
 # It's "usr" for gcc releases, so use this if not explicitly set
51
67
 ifeq ($(PF),)
52
 
@@ -1181,14 +1194,6 @@
 
68
@@ -1124,14 +1137,6 @@
53
69
 # cross targets #
54
70
 #################
55
71
 
64
80
 # Process the following only if $(TARGET) is set
65
81
 ifneq (,$(TARGET))
66
82
 
67
 
diff -Naru binutils-2.22-orig/gold/configure binutils-2.22/gold/configure
68
 
--- binutils-2.22-orig/gold/configure   2012-04-10 09:44:28.620687107 +0200
69
 
+++ binutils-2.22/gold/configure        2012-04-10 09:45:21.584687102 +0200
 
83
Index: binutils-2.22/gold/configure
 
84
===================================================================
 
85
--- binutils-2.22.orig/gold/configure   2012-03-08 18:17:45.000000000 +0000
 
86
+++ binutils-2.22/gold/configure        2012-04-15 08:15:41.374745488 +0000
70
87
@@ -7259,8 +7259,8 @@
71
88
 ac_compiler_gnu=$ac_cv_c_compiler_gnu
72
89
 
78
95
   if test -n "$multiarch"; then
79
96
     MULTIARCH_DIRNAME='-DMULTIARCH_DIRNAME=\"'$multiarch'\"'
80
97
   fi
81
 
diff -Naru binutils-2.22-orig/gold/configure.ac binutils-2.22/gold/configure.ac
82
 
--- binutils-2.22-orig/gold/configure.ac        2012-04-10 09:44:28.624687107 +0200
83
 
+++ binutils-2.22/gold/configure.ac     2012-04-10 09:45:21.584687102 +0200
 
98
Index: binutils-2.22/gold/configure.ac
 
99
===================================================================
 
100
--- binutils-2.22.orig/gold/configure.ac        2012-03-08 18:17:45.000000000 +0000
 
101
+++ binutils-2.22/gold/configure.ac     2012-04-15 08:15:41.374745488 +0000
84
102
@@ -492,8 +492,8 @@
85
103
 
86
104
 AC_LANG_POP(C++)
92
110
   if test -n "$multiarch"; then
93
111
     MULTIARCH_DIRNAME='-DMULTIARCH_DIRNAME=\"'$multiarch'\"'
94
112
   fi
95
 
diff -Naru binutils-2.22-orig/ld/genscripts.sh binutils-2.22/ld/genscripts.sh
96
 
--- binutils-2.22-orig/ld/genscripts.sh 2012-04-10 09:44:28.440687107 +0200
97
 
+++ binutils-2.22/ld/genscripts.sh      2012-04-10 09:45:21.776687102 +0200
 
113
Index: binutils-2.22/ld/genscripts.sh
 
114
===================================================================
 
115
--- binutils-2.22.orig/ld/genscripts.sh 2012-03-08 18:17:45.000000000 +0000
 
116
+++ binutils-2.22/ld/genscripts.sh      2012-04-15 08:15:41.374745488 +0000
98
117
@@ -301,6 +301,9 @@
99
118
        LIB_SEARCH_DIRS="${LIB_SEARCH_DIRS}SEARCH_DIR(\"$dir\"); "
100
119
     done