~ubuntu-branches/ubuntu/utopic/armel-cross-toolchain-base/utopic

« back to all changes in this revision

Viewing changes to debian/patches/gcc/enable-multiarch-directories.patch

  • Committer: Package Import Robot
  • Author(s): Marcin Juszkiewicz, Wookey, Marcin Juszkiewicz
  • Date: 2012-05-15 15:39:42 UTC
  • Revision ID: package-import@ubuntu.com-20120515153942-snhd05521kh55sh8
Tags: 1.83
[ Wookey ]
* Debian switched to gcc-4.7 so we have to too.

[ Marcin Juszkiewicz ]
* GCC-4.7 related changes:
  - added patch to drop --disable-multiarch for stage1
  - refreshed enable-multiarch-directories.patch
* Dropped creation of /usr/TRIPLET/include/TRIPLET/asm directory under
        Debian.
* Moved cross binutils to separate source package as this will make
  armel-cross-toolchain-base (a-c-t-b) arch:all so less building. Also
  allows to kill a-c-t-b when we will get cross-arch build dependencies.
* Build gcc-4.6/cross for building eglibc/cross and then gcc-4.7/cross to
        have libgcc1/cross. This part will be reverted when eglibc will be
        compiled with gcc-4.7 version.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
Index: gcc/debian/patches/cross-add-multiarch.diff
2
2
===================================================================
3
3
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
4
 
+++ gcc/debian/patches/cross-add-multiarch.diff 2012-04-03 11:02:58.456757857 +0000
 
4
+++ gcc/debian/patches/cross-add-multiarch.diff 2012-04-15 15:09:08.278742528 +0000
5
5
@@ -0,0 +1,12 @@
6
6
+Index: gcc/src/gcc/cppdefault.c
7
7
+===================================================================
8
 
+--- gcc.orig/src/gcc/cppdefault.c      2010-11-29 14:09:41.000000000 +0000
9
 
++++ gcc/src/gcc/cppdefault.c   2012-02-15 12:24:40.218526769 +0000
10
 
+@@ -36,7 +36,6 @@
 
8
+--- gcc.orig/src/gcc/cppdefault.c      2012-01-06 00:14:32.000000000 +0000
 
9
++++ gcc/src/gcc/cppdefault.c   2012-04-15 15:08:23.450742535 +0000
 
10
+@@ -32,7 +32,6 @@
 
11
11
12
+ #if defined (CROSS_DIRECTORY_STRUCTURE) && !defined (TARGET_SYSTEM_ROOT)
12
13
+ # undef LOCAL_INCLUDE_DIR
13
 
+ # undef SYSTEM_INCLUDE_DIR
14
 
+-# undef STANDARD_INCLUDE_DIR
 
14
+-# undef NATIVE_SYSTEM_HEADER_DIR
15
15
+ #else
16
16
+ # undef CROSS_INCLUDE_DIR
17
17
+ #endif
18
18
Index: gcc/debian/rules.patch
19
19
===================================================================
20
 
--- gcc.orig/debian/rules.patch 2012-02-28 21:06:56.000000000 +0000
21
 
+++ gcc/debian/rules.patch      2012-04-03 11:02:58.456757857 +0000
22
 
@@ -238,7 +238,7 @@
23
 
   ifeq ($(trunk_build),yes)
24
 
     debian_patches += cross-include-trunk cross-fixes-trunk
25
 
   else
26
 
-    debian_patches += cross-include cross-fixes
27
 
+    debian_patches += cross-include cross-fixes cross-add-multiarch
28
 
   endif
29
 
 endif
30
 
 
 
20
--- gcc.orig/debian/rules.patch 2012-04-09 20:28:04.000000000 +0000
 
21
+++ gcc/debian/rules.patch      2012-04-15 15:08:44.970742533 +0000
 
22
@@ -211,7 +211,7 @@
 
23
 endif
 
24
 
 
25
 ifeq ($(DEB_CROSS),yes)
 
26
-  debian_patches += cross-include cross-fixes
 
27
+  debian_patches += cross-include cross-fixes cross-add-multiarch
 
28
 endif
 
29
 
 
30
 ifeq ($(DEB_TARGET_ARCH_OS),hurd)