~ubuntu-branches/ubuntu/utopic/gnat-4.9/utopic-proposed

« back to all changes in this revision

Viewing changes to debian/patches/gcc-as-needed.diff

  • Committer: Package Import Robot
  • Author(s): Matthias Klose
  • Date: 2014-07-29 19:34:08 UTC
  • mfrom: (3.1.9 sid)
  • Revision ID: package-import@ubuntu.com-20140729193408-9057666uwi75ag71
Tags: 4.9.1-1ubuntu1
Regenerate the control file.

Show diffs side-by-side

added added

removed removed

Lines of Context:
4
4
===================================================================
5
5
--- a/src/gcc/config/aarch64/aarch64-linux.h
6
6
+++ b/src/gcc/config/aarch64/aarch64-linux.h
7
 
@@ -25,6 +25,7 @@
 
7
@@ -27,6 +27,7 @@
8
8
 
9
9
 #define LINUX_TARGET_LINK_SPEC  "%{h*}         \
10
10
    --hash-style=gnu                            \
16
16
===================================================================
17
17
--- a/src/gcc/config/ia64/linux.h
18
18
+++ b/src/gcc/config/ia64/linux.h
19
 
@@ -58,7 +58,7 @@
 
19
@@ -58,7 +58,7 @@ do {                                          \
20
20
 #define GLIBC_DYNAMIC_LINKER "/lib/ld-linux-ia64.so.2"
21
21
 
22
22
 #undef LINK_SPEC
29
29
===================================================================
30
30
--- a/src/gcc/config/sparc/linux.h
31
31
+++ b/src/gcc/config/sparc/linux.h
32
 
@@ -86,7 +86,7 @@
 
32
@@ -86,7 +86,7 @@ extern const char *host_detect_local_cpu
33
33
 #define GLIBC_DYNAMIC_LINKER "/lib/ld-linux.so.2"
34
34
 
35
35
 #undef  LINK_SPEC
42
42
===================================================================
43
43
--- a/src/gcc/config/s390/linux.h
44
44
+++ b/src/gcc/config/s390/linux.h
45
 
@@ -65,7 +65,7 @@
 
45
@@ -65,7 +65,7 @@ along with GCC; see the file COPYING3.
46
46
 
47
47
 #undef  LINK_SPEC
48
48
 #define LINK_SPEC \
55
55
===================================================================
56
56
--- a/src/gcc/config/rs6000/linux64.h
57
57
+++ b/src/gcc/config/rs6000/linux64.h
58
 
@@ -385,11 +385,11 @@
 
58
@@ -417,11 +417,11 @@ extern int dot_symbols;
59
59
                                           " -m elf64ppc")
60
60
 #endif
61
61
 
73
73
===================================================================
74
74
--- a/src/gcc/config/rs6000/sysv4.h
75
75
+++ b/src/gcc/config/rs6000/sysv4.h
76
 
@@ -799,7 +799,7 @@
 
76
@@ -773,7 +773,7 @@ ENDIAN_SELECT(" -mbig", " -mlittle", DEF
77
77
 #define GNU_USER_DYNAMIC_LINKER \
78
78
   CHOOSE_DYNAMIC_LINKER (GLIBC_DYNAMIC_LINKER, UCLIBC_DYNAMIC_LINKER)
79
79
 
86
86
===================================================================
87
87
--- a/src/gcc/config/i386/gnu-user64.h
88
88
+++ b/src/gcc/config/i386/gnu-user64.h
89
 
@@ -57,6 +57,7 @@
 
89
@@ -57,6 +57,7 @@ see the files COPYING3 and COPYING.RUNTI
90
90
                    %{" SPEC_32 ":-m " GNU_USER_LINK_EMULATION32 "} \
91
91
                    %{" SPEC_X32 ":-m " GNU_USER_LINK_EMULATIONX32 "} \
92
92
   --hash-style=gnu \
98
98
===================================================================
99
99
--- a/src/gcc/config/i386/gnu-user.h
100
100
+++ b/src/gcc/config/i386/gnu-user.h
101
 
@@ -74,7 +74,7 @@
 
101
@@ -74,7 +74,7 @@ along with GCC; see the file COPYING3.
102
102
   { "link_emulation", GNU_USER_LINK_EMULATION },\
103
103
   { "dynamic_linker", GNU_USER_DYNAMIC_LINKER }
104
104
 
111
111
===================================================================
112
112
--- a/src/gcc/config/alpha/linux-elf.h
113
113
+++ b/src/gcc/config/alpha/linux-elf.h
114
 
@@ -37,7 +37,7 @@
 
114
@@ -37,7 +37,7 @@ along with GCC; see the file COPYING3.
115
115
 
116
116
 #define ELF_DYNAMIC_LINKER     GNU_USER_DYNAMIC_LINKER
117
117
 
124
124
===================================================================
125
125
--- a/src/gcc/config/arm/linux-elf.h
126
126
+++ b/src/gcc/config/arm/linux-elf.h
127
 
@@ -68,6 +68,7 @@
 
127
@@ -73,6 +73,7 @@
128
128
      -dynamic-linker " GNU_USER_DYNAMIC_LINKER "} \
129
129
    -X \
130
130
    --hash-style=gnu \
132
132
    %{mbig-endian:-EB} %{mlittle-endian:-EL}" \
133
133
    SUBTARGET_EXTRA_LINK_SPEC
134
134
 
 
135
Index: b/src/gcc/config/mips/gnu-user.h
 
136
===================================================================
135
137
--- a/src/gcc/config/mips/gnu-user.h
136
138
+++ b/src/gcc/config/mips/gnu-user.h
137
 
@@ -56,6 +56,7 @@
 
139
@@ -56,6 +56,7 @@ along with GCC; see the file COPYING3.
138
140
 #undef GNU_USER_TARGET_LINK_SPEC
139
141
 #define GNU_USER_TARGET_LINK_SPEC \
140
142
  "%(endian_spec) \
142
144
   %{shared:-shared} \
143
145
   %{!shared: \
144
146
     %{!static: \
 
147
Index: b/src/gcc/config/mips/gnu-user64.h
 
148
===================================================================
145
149
--- a/src/gcc/config/mips/gnu-user64.h
146
150
+++ b/src/gcc/config/mips/gnu-user64.h
147
 
@@ -34,6 +34,7 @@
 
151
@@ -34,6 +34,7 @@ along with GCC; see the file COPYING3.
148
152
 #define GNU_USER_TARGET_LINK_SPEC "\
149
153
 %{G*} %{EB} %{EL} %{mips1} %{mips2} %{mips3} %{mips4} \
150
154
 %{shared} \
152
156
  %(endian_spec) \
153
157
   %{!shared: \
154
158
     %{!static: \
 
159
Index: b/src/libjava/Makefile.am
 
160
===================================================================
155
161
--- a/src/libjava/Makefile.am
156
162
+++ b/src/libjava/Makefile.am
157
 
@@ -625,7 +625,7 @@
 
163
@@ -628,7 +628,7 @@ libgcj_bc.la: $(libgcj_bc_la_OBJECTS) $(
158
164
        rm .libs/libgcj_bc.so; \
159
165
        mv .libs/libgcj_bc.so.1.0.0 .libs/libgcj_bc.so; \
160
166
        $(libgcj_bc_dummy_LINK) -xc /dev/null -Wl,-soname,libgcj_bc.so.1 \
163
169
        rm .libs/libgcj_bc.so.1; \
164
170
        $(LN_S) libgcj_bc.so.1.0.0 .libs/libgcj_bc.so.1
165
171
 
 
172
Index: b/src/libjava/Makefile.in
 
173
===================================================================
166
174
--- a/src/libjava/Makefile.in
167
175
+++ b/src/libjava/Makefile.in
168
 
@@ -10573,7 +10573,7 @@
 
176
@@ -10600,7 +10600,7 @@ libgcj_bc.la: $(libgcj_bc_la_OBJECTS) $(
169
177
        rm .libs/libgcj_bc.so; \
170
178
        mv .libs/libgcj_bc.so.1.0.0 .libs/libgcj_bc.so; \
171
179
        $(libgcj_bc_dummy_LINK) -xc /dev/null -Wl,-soname,libgcj_bc.so.1 \