~ubuntu-branches/ubuntu/utopic/gnomeradio/utopic

« back to all changes in this revision

Viewing changes to debian/patches/gnomeradio-record_information.patch

  • Committer: Package Import Robot
  • Author(s): POJAR GEORGE
  • Date: 2013-12-24 10:38:24 UTC
  • Revision ID: package-import@ubuntu.com-20131224103824-ud5r2yrtyblv9ew6
Tags: 1.8-2ubuntu26
* debian/patches/gnomeradio-g_object.patch: Removed useless calls to the
  G_OBJECT() macro. (LP: #1267306)
* Updated debian/patches/gnomeradio-about.patch: Update COPYING file with
  latest versions from gnu.org. (LP: #1266203)
* Updated debian/patches/gnomeradio-gtk_stock.patch: UI make it more sleek, 
  remove relief from the UI buttons. (LP: #1265154)
* Updated debian/patches/gnomeradio-gtk_application.patch: Make the main
  window a GtkApplicationWindow.
* Updated debian/patches/gnomeradio-ngettext.patch: Fix localization, use
  g_dngettext instead of ngettext.
* Updated debian/patches/gnomeradio-record_information.patch: Use GDateTime
  instead of time_t.
* Moved changes from debian/patches/gnomeradio-thread_safe.patch to
  debian/patches/gnomeradio-alsa.patch and removed it as result.
* debian/control: Updated to Standards-Version 3.9.5, no changes needed.

Show diffs side-by-side

added added

removed removed

Lines of Context:
3
3
Author: Pojar George <geoubuntu@gmail.com> 
4
4
Index: gnomeradio-1.8/src/record.c
5
5
===================================================================
6
 
--- gnomeradio-1.8.orig/src/record.c    2013-09-24 15:27:39.355423193 +0000
7
 
+++ gnomeradio-1.8/src/record.c 2013-09-24 15:27:39.351423194 +0000
 
6
--- gnomeradio-1.8.orig/src/record.c    2014-01-05 13:43:51.860036562 +0000
 
7
+++ gnomeradio-1.8/src/record.c 2014-01-05 13:43:51.844036562 +0000
8
8
@@ -32,9 +32,11 @@
9
9
 #include "prefs.h"
10
10
 
331
331
        g_signal_connect(G_OBJECT(button), "clicked", G_CALLBACK(button_clicked_cb), recording);
332
332
Index: gnomeradio-1.8/src/gui.c
333
333
===================================================================
334
 
--- gnomeradio-1.8.orig/src/gui.c       2013-09-24 15:27:39.355423193 +0000
335
 
+++ gnomeradio-1.8/src/gui.c    2013-09-24 15:27:39.351423194 +0000
 
334
--- gnomeradio-1.8.orig/src/gui.c       2014-01-05 13:43:51.860036562 +0000
 
335
+++ gnomeradio-1.8/src/gui.c    2014-01-05 13:43:51.848036562 +0000
336
336
@@ -61,7 +61,6 @@
337
337
 static GtkWidget *drawing_area;
338
338
 static GdkPixbuf *digits, *signal_s, *stereo;
341
341
 
342
342
 static int timeout_id, bp_timeout_id = -1, bp_timeout_steps = 0;
343
343
 
344
 
@@ -738,7 +737,7 @@
 
344
@@ -737,12 +736,14 @@
 
345
 void rec_button_clicked_cb(GtkButton *button, gpointer app)
 
346
 {
 
347
        char *station;
 
348
-       char time_str[100];
 
349
-       time_t t;
 
350
+       gchar *time;
 
351
+       GDateTime *date;
345
352
        
346
 
        t = time(NULL);
 
353
-       t = time(NULL);
 
354
+       date = g_date_time_new_now_local ();
 
355
+       g_assert (date);
347
356
        /* consult man strftime to translate this. This is a filename, so don't use "/" or ":", please */
348
357
-       strftime(time_str, 100, _("%B-%d-%Y_%H-%M-%S"), localtime(&t));
349
 
+       strftime(time_str, 100, _("%Y%m%d-%H%M%S"), localtime(&t));
 
358
+       time = g_date_time_format (date, _("%Y%m%d-%H%M%S"));
 
359
+       g_date_time_unref (date);
350
360
        
351
361
        if (mom_ps < 0) {
352
362
                station = g_strdup_printf(_("%.2f MHz"), rint(gtk_adjustment_get_value(adj))/STEPS);
353
 
@@ -905,7 +904,7 @@
 
363
@@ -761,8 +762,9 @@
 
364
                gtk_dialog_run (GTK_DIALOG (errdialog));
 
365
                gtk_widget_destroy (errdialog);
 
366
        } else */
 
367
-       start_recording(rec_settings.destination, station, time_str);
 
368
+       start_recording(rec_settings.destination, station, time);
 
369
        g_free(station);
 
370
+       g_free(time);
 
371
 }
 
372
 
 
373
 void toggle_volume(void)
 
374
@@ -908,7 +910,7 @@
354
375
        GtkWidget *app;
355
376
        GtkWidget *prefs_button, *quit_button, *scfw_button, *scbw_button;
356
377
        GtkWidget *stfw_button, *stbw_button, *about_button, *rec_button;
359
380
        GtkWidget *stfw_pixmap, *stbw_pixmap, *about_pixmap;
360
381
        GtkWidget *freq_up_pixmap, *freq_down_pixmap;
361
382
        GdkPixbuf *freq_up_pixbuf, *freq_down_pixbuf;
362
 
@@ -1080,7 +1079,7 @@
 
383
@@ -1083,7 +1085,7 @@
363
384
        gtk_widget_set_tooltip_text(stbw_button, _("0.05 MHz Backwards"));
364
385
        gtk_widget_set_tooltip_text(stfw_button, _("0.05 MHz Forwards"));
365
386
        gtk_widget_set_tooltip_text(about_button, _("About"));
370
391
        gtk_widget_set_tooltip_text(quit_button, _("Quit"));
371
392
Index: gnomeradio-1.8/src/rec_tech.c
372
393
===================================================================
373
 
--- gnomeradio-1.8.orig/src/rec_tech.c  2013-09-24 15:27:39.355423193 +0000
374
 
+++ gnomeradio-1.8/src/rec_tech.c       2013-09-24 15:27:39.351423194 +0000
 
394
--- gnomeradio-1.8.orig/src/rec_tech.c  2014-01-05 13:43:51.860036562 +0000
 
395
+++ gnomeradio-1.8/src/rec_tech.c       2014-01-05 13:43:51.848036562 +0000
375
396
@@ -23,8 +23,64 @@
376
397
 #include <sys/stat.h>
377
398
 #include <unistd.h>