~ubuntu-branches/ubuntu/utopic/psicode/utopic

« back to all changes in this revision

Viewing changes to debian/patches/01_DESTDIR.dpatch

  • Committer: Package Import Robot
  • Author(s): Michael Banck
  • Date: 2012-03-29 01:26:55 UTC
  • mfrom: (5.1.2 sid)
  • Revision ID: package-import@ubuntu.com-20120329012655-8lnngrup9p40ow4z
Tags: 3.4.0-3
* debian/control: Add CC3, MRCCSD and SCS-MP2 energies, RHF hessian and
  closed-shell MP2 gradient to features, clarify that MP2-R12 is an
  explicitly correlated method.
* debian/patches/09_system_libint.dpatch: New patch, modifies the build
  system to use the system libint and not compile and link in the shipped
  libint codes.
* debian/control (Build-Depends): Added libint-dev.
* debian/rules (DEB_MAKE_CHECK_TARGET): Run quicktests target to invoke the
  test suite.
* debian/rules: Rewritten for dh.
* debian/control (Build-Depends): Bumped debhelper version to 8, removed
  cdbs and dpatch.
* debian/patches: Moved to source version 3.0 (quilt).
* debian/source/format: New file.
* debian/rules (override_dh_auto_install): Install some test suite input
  files as examples.
* debian/dirs: Added examples directory.
* debian/TODO: Updated.
* debian/control (Standards-Version): Bumped to 3.9.3.
* debian/rules (override_dh_auto_test): Do not abort build on test suite
  failure.
* debian/rules (override_dh_auto_build): New rule, build the user manual in
  addition to the main code.
* debian/control (Build-Depends): Added texlive-latex-recommended.
* debian/patches/10_makerules_doc.patch: New patch, build the postscript
  file by default and deletes some more generated files on realclean.
* debian/rules (override_dh_auto_install): Install postscript user manual
  into documentation directory.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 01_DESTDIR.dpatch by Daniel Leidert <daniel.leidert@wgdd.de> and
3
 
##     Michael Banck <mbanck@debian.org>
4
 
##
5
 
## All lines beginning with `## DP:' are a description of the patch.
6
 
## DP: Upstream misses to support DESTDIR in a few cases. This patch should
7
 
## DP:   forwarded to upstream as usual.
8
 
 
9
 
@DPATCH@
10
 
diff -urNad psicode~/doc/doxygen/Makefile.in psicode/doc/doxygen/Makefile.in
11
 
--- psicode~/doc/doxygen/Makefile.in    2008-03-02 20:43:44.000000000 +0100
12
 
+++ psicode/doc/doxygen/Makefile.in     2009-02-22 16:20:10.000000000 +0100
13
 
@@ -3,7 +3,7 @@
14
 
 
15
 
 include ../MakeVars
16
 
 
17
 
-DOXYDIR = $(htmldir)/doxygen
18
 
+DOXYDIR = $(DESTDIR)$(htmldir)/doxygen
19
 
 DOXYCFG = doxygen.cfg
20
 
 
21
 
 all:: html
22
 
@@ -12,18 +12,17 @@
23
 
 html: $(DOXYCFG)
24
 
        $(DOXYGEN) $<
25
 
 
26
 
-realclean::
27
 
-       /bin/rm -rf html latex man
28
 
-       /bin/rm -rf *~
29
 
+realclean:: clean
30
 
+       $(RM) -r html latex man
31
 
 
32
 
 clean::
33
 
-       /bin/rm -rf *~
34
 
+       $(RM) -r *~
35
 
 
36
 
 install:: install_html
37
 
 
38
 
 .PHONY: install_html
39
 
 install_html::
40
 
-       $(MKDIRS) $(htmldir)/doxygen
41
 
+       $(MKDIRS) $(DOXYDIR)
42
 
        $(INSTALL_DATA) html/* $(DOXYDIR)
43
 
 
44
 
 include ../MakeRules
45
 
diff -urNad psicode~/lib/ruby/Makefile.in psicode/lib/ruby/Makefile.in
46
 
--- psicode~/lib/ruby/Makefile.in       2008-06-18 19:27:56.000000000 +0200
47
 
+++ psicode/lib/ruby/Makefile.in        2009-02-22 16:20:10.000000000 +0100
48
 
@@ -29,10 +29,10 @@
49
 
 cceom.rb       ccsort.rb      cints.rb       cphf.rb        detci.rb       input.rb       optking.rb     psi3.rb        testcases.rb 
50
 
 
51
 
 install: $(RUBYSRC)
52
 
-       $(MKDIRS) $(rubydatadir)
53
 
+       $(MKDIRS) $(DESTDIR)$(rubydatadir)
54
 
        for rbfile in $(RUBYSRC); \
55
 
           do \
56
 
-            ($(INSTALL_DATA) $(srcdir)/$${rbfile} $(rubydatadir)) || exit 1; \
57
 
+            ($(INSTALL_DATA) $(srcdir)/$${rbfile} $(DESTDIR)$(rubydatadir)) || exit 1; \
58
 
           done
59
 
 
60
 
 install_man: