~ubuntu-branches/ubuntu/utopic/psicode/utopic

« back to all changes in this revision

Viewing changes to debian/patches/07_464867_move_executables.patch

  • Committer: Package Import Robot
  • Author(s): Michael Banck
  • Date: 2012-03-29 01:26:55 UTC
  • mfrom: (5.1.2 sid)
  • Revision ID: package-import@ubuntu.com-20120329012655-8lnngrup9p40ow4z
Tags: 3.4.0-3
* debian/control: Add CC3, MRCCSD and SCS-MP2 energies, RHF hessian and
  closed-shell MP2 gradient to features, clarify that MP2-R12 is an
  explicitly correlated method.
* debian/patches/09_system_libint.dpatch: New patch, modifies the build
  system to use the system libint and not compile and link in the shipped
  libint codes.
* debian/control (Build-Depends): Added libint-dev.
* debian/rules (DEB_MAKE_CHECK_TARGET): Run quicktests target to invoke the
  test suite.
* debian/rules: Rewritten for dh.
* debian/control (Build-Depends): Bumped debhelper version to 8, removed
  cdbs and dpatch.
* debian/patches: Moved to source version 3.0 (quilt).
* debian/source/format: New file.
* debian/rules (override_dh_auto_install): Install some test suite input
  files as examples.
* debian/dirs: Added examples directory.
* debian/TODO: Updated.
* debian/control (Standards-Version): Bumped to 3.9.3.
* debian/rules (override_dh_auto_test): Do not abort build on test suite
  failure.
* debian/rules (override_dh_auto_build): New rule, build the user manual in
  addition to the main code.
* debian/control (Build-Depends): Added texlive-latex-recommended.
* debian/patches/10_makerules_doc.patch: New patch, build the postscript
  file by default and deletes some more generated files on realclean.
* debian/rules (override_dh_auto_install): Install postscript user manual
  into documentation directory.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
## 07_464867_move_executables.patch by Michael Banck <mbanck@debian.org>
 
2
##
 
3
## All lines beginning with `## DP:' are a description of the patch.
 
4
## DP: Add /usr/lib/psi to the $PATH so that the moved executables are found.
 
5
## DP:
 
6
## DP: <URL:http://bugs.debian.org/464867>
 
7
--- psicode-3.4.0.orig/src/bin/psi3/runcmd.cc
 
8
+++ psicode-3.4.0/src/bin/psi3/runcmd.cc
 
9
@@ -14,6 +14,11 @@
 
10
 void runcmd(int *errcod, char *cmd)
 
11
 {
 
12
 
 
13
+  /* Debian places the helper executables into /usr/lib/psi */
 
14
+  char *path = getenv("PATH");
 
15
+  strcat(path, ":/usr/lib/psi");
 
16
+  putenv(path);
 
17
+
 
18
   /*
 
19
   i = system(cmd);
 
20
   *errcod = WEXITSTATUS(i);