~ubuntu-branches/ubuntu/vivid/logrotate/vivid

« back to all changes in this revision

Viewing changes to debian/patches/dst.patch

  • Committer: Bazaar Package Importer
  • Author(s): Martin Pitt
  • Date: 2008-11-07 14:57:09 UTC
  • mfrom: (1.1.3 upstream)
  • Revision ID: james.westby@ubuntu.com-20081107145709-s8ktufsiktmkuidl
Tags: 3.7.7-1ubuntu1
* Merge with Debian experimental (LP: #64964). Remaining Ubuntu changes:
  - debian/control: Drop mailx to Suggests for Ubuntu; it's only used on
    request, and we don't configure an MTA by default.

Show diffs side-by-side

added added

removed removed

Lines of Context:
18
18
setting lastRotated.tm_isdst correctly prior to the mktime() call.
19
19
 
20
20
 
21
 
Index: logrotate-3.7.1/logrotate.c
 
21
Index: logrotate-3.7.7/logrotate.c
22
22
===================================================================
23
 
--- logrotate-3.7.1.orig/logrotate.c    2006-04-08 21:36:03.268110593 +0100
24
 
+++ logrotate-3.7.1/logrotate.c 2006-04-08 21:36:11.342764986 +0100
25
 
@@ -78,6 +78,7 @@
26
 
        states[i].lastRotated.tm_mon = now.tm_mon;
27
 
        states[i].lastRotated.tm_mday = now.tm_mday;
28
 
        states[i].lastRotated.tm_year = now.tm_year;
29
 
+       states[i].lastRotated.tm_isdst = now.tm_isdst;
 
23
--- logrotate-3.7.7.orig/logrotate.c    2008-11-07 02:12:38.863555890 +0000
 
24
+++ logrotate-3.7.7/logrotate.c 2008-11-07 02:13:25.071920510 +0000
 
25
@@ -84,6 +84,8 @@
 
26
        new->lastRotated.tm_mon = now.tm_mon;
 
27
        new->lastRotated.tm_mday = now.tm_mday;
 
28
        new->lastRotated.tm_year = now.tm_year;
 
29
+       new->lastRotated.tm_hour = now.tm_hour;
 
30
+       new->lastRotated.tm_isdst = now.tm_isdst;
30
31
 
31
 
        /* fill in the rest of the st->lastRotated fields */
32
 
        lr_time = mktime(&states[i].lastRotated);
 
32
        /* fill in the rest of the new->lastRotated fields */
 
33
        lr_time = mktime(&new->lastRotated);