~ubuntu-branches/ubuntu/vivid/logrotate/vivid

« back to all changes in this revision

Viewing changes to debian/patches/script-argument.patch

  • Committer: Bazaar Package Importer
  • Author(s): Martin Pitt
  • Date: 2008-11-07 14:57:09 UTC
  • mfrom: (1.1.3 upstream)
  • Revision ID: james.westby@ubuntu.com-20081107145709-s8ktufsiktmkuidl
Tags: 3.7.7-1ubuntu1
* Merge with Debian experimental (LP: #64964). Remaining Ubuntu changes:
  - debian/control: Drop mailx to Suggests for Ubuntu; it's only used on
    request, and we don't configure an MTA by default.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Closes: #330783
2
 
 
3
 
Allow the use of $1 in scripts.
4
 
 
5
 
 
6
 
Index: logrotate-3.7.1/logrotate.c
7
 
===================================================================
8
 
--- logrotate-3.7.1.orig/logrotate.c    2006-04-08 21:47:41.000000000 +0100
9
 
+++ logrotate-3.7.1/logrotate.c 2006-04-08 22:01:23.722498089 +0100
10
 
@@ -101,7 +101,7 @@
11
 
     }
12
 
 
13
 
     if (!fork()) {
14
 
-       execl("/bin/sh", "sh", "-c", script, NULL);
15
 
+       execl("/bin/sh", "sh", "-c", script, "sh", logfn, NULL);
16
 
        exit(1);
17
 
     }
18