~ubuntu-branches/ubuntu/vivid/newt/vivid

« back to all changes in this revision

Viewing changes to debian/patches/python-dbg.patch

  • Committer: Package Import Robot
  • Author(s): Matthias Klose
  • Date: 2012-11-08 14:50:00 UTC
  • mfrom: (2.1.20 sid)
  • Revision ID: package-import@ubuntu.com-20121108145000-0yfrol7obct0jufq
Tags: 0.52.14-11ubuntu1
* Merge with Debian; remaining changes:
  - Port python module to python3.
  - Fix installation for multiple python3 versions.
  - Move libnewt to /lib and whiptail to /bin so they can be used by
    friendly-recovery on systems that have a separate /usr.
  - debian/libnewt0.52.install, debian/libnewt0.52.postinst,
    debian/palette => debian/palette.original:
    - move palette from /usr to /etc such that they can be edited by an
      admin.
* Configure --with-colorsfile=/etc/newt/palette.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Author: Michael Vogt at Ubuntu
 
2
Description: Build for python-dbg package
 
3
Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=531725
 
4
Forwarded: not-needed
 
5
Last-Updated: 2012-01-09
 
6
 
 
7
Index: newt-0.52.14/Makefile.in
 
8
===================================================================
 
9
--- newt-0.52.14.orig/Makefile.in       2011-12-03 10:32:16.000000000 +0000
 
10
+++ newt-0.52.14/Makefile.in    2011-12-03 10:33:48.000000000 +0000
 
11
@@ -85,6 +85,8 @@
 
12
                        PLFLAGS=`$$ver-config --libs`; \
 
13
                $(CC) $(CPPFLAGS) $$PIFLAGS $$PCFLAGS -c -o $$ver/snackmodule.o snackmodule.c ;\
 
14
                $(CC) --shared $$PLDFLAGS $$PLFLAGS $(LDFLAGS) -o $$ver/_snackmodule.so $$ver/snackmodule.o -L.  -lnewt $(LIBS);\
 
15
+                $(CC) $(subst -O2,-O0,$(CFLAGS)) -I/usr/include/$${ver}_d -fPIC -c -o $$ver/snackmodule_d.o snackmodule.c ;\
 
16
+                $(CC) --shared $(SHCFLAGS) -o $$ver/_snackmodule_d.so $$ver/snackmodule_d.o -L .  -lnewt  ;\
 
17
        done || :
 
18
        touch $@
 
19
 
 
20
@@ -144,6 +146,7 @@
 
21
        [ -n "$(PYTHONVERS)" ] && for ver in $(PYTHONVERS) ; do \
 
22
           [ -d $(instroot)/$(libdir)/$$ver/site-packages ] || install -m 755 -d $(instroot)/$(libdir)/$$ver/site-packages ;\
 
23
           install -m 755 $$ver/_snackmodule.so $(instroot)/$(libdir)/$$ver/site-packages ;\
 
24
+          install -m 755 $$ver/_snackmodule_d.so $(instroot)/$(libdir)/$$ver/site-packages ;\
 
25
           install -m 644 snack.py $(instroot)/$(libdir)/$$ver/site-packages ;\
 
26
        done || :
 
27