~ubuntu-branches/ubuntu/vivid/sysstat/vivid-proposed

« back to all changes in this revision

Viewing changes to debian/patches/00-Makefile.patch

  • Committer: Package Import Robot
  • Author(s): Robert Luberda
  • Date: 2011-12-03 17:38:42 UTC
  • mfrom: (1.2.12)
  • Revision ID: package-import@ubuntu.com-20111203173842-9hrhekn3639twx4p
Tags: 10.0.3-1
* New upstream (stable) release.
* Switch to devhelper v9.
* debian/control: Add VCS fields, update source/options.
* debian/rules: remove .pc/.dpkg-source-unapply file in configure target
  to fix broken behaviour of dpkg-buildpackage (see Bug#649521).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Robert Luberda <robert@debian.org>
 
2
Date: Tue, 23 Mar 2010 22:04:47 +0100
 
3
Subject: 00-Makefile
 
4
 
1
5
Makefile fixes.
 
6
---
 
7
 Makefile.in |   42 ++++++++++++++++++++++--------------------
 
8
 1 files changed, 22 insertions(+), 20 deletions(-)
2
9
 
3
 
Index: sysstat/Makefile.in
4
 
===================================================================
5
 
--- sysstat.orig/Makefile.in    2011-08-28 19:45:44.000000000 +0200
6
 
+++ sysstat/Makefile.in 2011-08-28 19:45:47.000000000 +0200
 
10
diff --git a/Makefile.in b/Makefile.in
 
11
index d1ea853..60c10f9 100644
 
12
--- a/Makefile.in
 
13
+++ b/Makefile.in
7
14
@@ -69,9 +69,9 @@ NLS_DIR = $(PREFIX)/share/locale
8
15
 SYSCONFIG_DIR = @SYSCONFIG_DIR@
9
16
 
16
23
 DFLAGS += -DSA_DIR=\"$(SA_DIR)\" -DSADC_PATH=\"$(SADC_PATH)\"
17
24
 DFLAGS += $(DFSENSORS)
18
25
 
19
 
@@ -237,8 +237,9 @@ else
 
26
@@ -239,8 +239,9 @@ else
20
27
 locales:
21
28
 endif
22
29
 
28
35
 
29
36
 # Phony targets
30
37
 .PHONY: clean distclean install install_base install_all uninstall \
31
 
@@ -271,9 +272,6 @@ ifeq ($(INSTALL_DOC),y)
 
38
@@ -273,9 +274,6 @@ ifeq ($(INSTALL_DOC),y)
32
39
        $(INSTALL_DATA) $(MANGRPARG) man/nfsiostat.1 $(DESTDIR)$(MAN1_DIR)
33
40
        rm -f $(DESTDIR)$(MAN1_DIR)/cifsiostat.1*
34
41
        $(INSTALL_DATA) $(MANGRPARG) man/cifsiostat.1 $(DESTDIR)$(MAN1_DIR)
38
45
 ifeq ($(COMPRESS_MANPG),y)
39
46
        $(ZIP) $(DESTDIR)$(MAN8_DIR)/sa1.8
40
47
        $(ZIP) $(DESTDIR)$(MAN8_DIR)/sa2.8
41
 
@@ -304,8 +302,15 @@ ifdef REQUIRE_NLS
 
48
@@ -306,8 +304,15 @@ ifdef REQUIRE_NLS
42
49
        done
43
50
 endif
44
51
 
56
63
        mkdir -p $(DESTDIR)$(SA_LIB_DIR)
57
64
        mkdir -p $(DESTDIR)$(SA_DIR)
58
65
 ifeq ($(CLEAN_SA_DIR),y)
59
 
@@ -314,7 +319,7 @@ ifeq ($(CLEAN_SA_DIR),y)
 
66
@@ -316,7 +321,7 @@ ifeq ($(CLEAN_SA_DIR),y)
60
67
        -rmdir --ignore-fail-on-non-empty $(DESTDIR)$(SA_DIR)/[0-9]?????
61
68
 endif
62
69
        mkdir -p $(DESTDIR)$(BIN_DIR)
65
72
        mkdir -p $(DESTDIR)$(SYSCONFIG_DIR)
66
73
        $(INSTALL_BIN) sa1 $(DESTDIR)$(SA_LIB_DIR)
67
74
        $(INSTALL_BIN) sa2 $(DESTDIR)$(SA_LIB_DIR)
68
 
@@ -326,18 +331,15 @@ endif
 
75
@@ -328,18 +333,15 @@ endif
69
76
        $(INSTALL_BIN) pidstat $(DESTDIR)$(BIN_DIR)
70
77
        $(INSTALL_BIN) nfsiostat $(DESTDIR)$(BIN_DIR)
71
78
        $(INSTALL_BIN) cifsiostat $(DESTDIR)$(BIN_DIR)
90
97
 endif
91
98
 
92
99
 install_all: install_base cron/crontab sysstat \
93
 
@@ -477,7 +479,7 @@ clean:
 
100
@@ -479,7 +481,7 @@ clean:
94
101
        rm -f sadc sar sadf iostat mpstat pidstat nfsiostat cifsiostat *.o *.a core TAGS
95
102
        find nls -name "*.gmo" -exec rm -f {} \;
96
103
 
99
106
        rm -f sa1 sa2 sysstat cron/crontab version.h sysconfig.h
100
107
        rm -f sysstat.sysconfig cron/sysstat.crond cron/sysstat.cron.daily
101
108
        rm -f cron/sysstat.cron.hourly cron/sysstat.crond.sample cron/sysstat.crond.sample.in
 
109
--