~ubuntu-branches/ubuntu/vivid/xfce4-netload-plugin/vivid-proposed

« back to all changes in this revision

Viewing changes to debian/patches/01_fix-snprintf-format.patch

  • Committer: Package Import Robot
  • Author(s): Yves-Alexis Perez
  • Date: 2012-01-14 13:38:21 UTC
  • mfrom: (1.1.5)
  • Revision ID: package-import@ubuntu.com-20120114133821-wcootttf8teoc234
Tags: 1.1.0-1
* New upstream release.
  - makes it possible to select bits or bytes as unit.        closes: #652892
* debian/rules:
  - use debhelper 9 and dpkg-dev 1.16.1 hardening support
* debian/control:
  - drop hardening-includes build-dep.
  - update debhelper build-dep for hardening support.
  - add dpkg-dev build-dep for hardening support.
  - replace libxfcegui4 build-dep by libxfce4ui one.
* debian/compat bumped to 9.
* debian/patches
  - 01_fix-snprintf-format dropped, included upstream.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff --git a/panel-plugin/net.c b/panel-plugin/net.c
2
 
index 261e466..e5afd5c 100644
3
 
--- a/panel-plugin/net.c
4
 
+++ b/panel-plugin/net.c
5
 
@@ -194,7 +194,7 @@ int get_interface_up(netdata* data)
6
 
         return FALSE;
7
 
     }
8
 
     
9
 
-    snprintf(ifr.ifr_name, IF_NAMESIZE, data->ifdata.if_name);
10
 
+    snprintf(ifr.ifr_name, IF_NAMESIZE, "%s", data->ifdata.if_name);
11
 
     if (ioctl(sockfd, SIOCGIFFLAGS, &ifr) != 0)
12
 
     {
13
 
         PRINT_DBG("Error in ioctl(sockfd): %s", strerror(errno));
14
 
@@ -231,7 +231,7 @@ char* get_ip_address(netdata* data)
15
 
         return NULL;
16
 
     }
17
 
     
18
 
-    snprintf(ifr.ifr_name, IF_NAMESIZE, data->ifdata.if_name);
19
 
+    snprintf(ifr.ifr_name, IF_NAMESIZE, "%s", data->ifdata.if_name);
20
 
     if (ioctl(sockfd, SIOCGIFADDR, &ifr) != 0)
21
 
     {
22
 
            if (errno != EADDRNOTAVAIL)