~ubuntu-branches/ubuntu/wily/alltray/wily

« back to all changes in this revision

Viewing changes to debian/patches/10-dont-use-pop-up-bubble.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Ignace Mouzannar
  • Date: 2010-11-20 16:16:12 UTC
  • mfrom: (2.1.3 sid)
  • Revision ID: james.westby@ubuntu.com-20101120161612-12y0wqt6g86fb7hu
Tags: 0.71b-1
* New upstream release. (Closes: #602233)
  - Fixes no windows hiding when using compiz. (Closes: #579503)
* debian/control:
  - Bumped Standards-Version to 3.9.1.
* debian/patches:
  - Removed 01_minor_type.diff as it has been integrated upstream.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 10-dont-use-pop-up-bubble.dpatch by Kyran Lange <kyran.lange@gmail.com>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Fix "alltray trayicons use their own tooltip theme" (LP: #355077)
6
 
## DP: src/trayicon.c and src/utils.c: Apply revision 25 from 
7
 
## DP: old-maintenance branch upstream in order to stop alltray using its 
8
 
## DP: own pop-up bubble for tooltips
9
 
 
10
 
@DPATCH@
11
 
diff -urNad alltray-0.69~/src/trayicon.c alltray-0.69/src/trayicon.c
12
 
--- alltray-0.69~/src/trayicon.c        2006-06-23 04:15:16.000000000 +0930
13
 
+++ alltray-0.69/src/trayicon.c 2009-04-16 12:39:06.000000000 +0930
14
 
@@ -385,22 +385,6 @@
15
 
     
16
 
 }
17
 
 
18
 
-gboolean icon_window_enter_event(GtkWidget *widget, GdkEventButton * event,
19
 
-    gpointer user_data)
20
 
-{
21
 
-  
22
 
-  win_struct *win= (win_struct*) user_data;
23
 
-  
24
 
-  if (debug) printf ("icon window enter event\n");
25
 
-    
26
 
-  win->balloon_message_allowed=TRUE;
27
 
-
28
 
-  show_balloon (win, win->title, 0);
29
 
-  
30
 
-  return FALSE;
31
 
-
32
 
-}
33
 
-
34
 
 void create_tray_and_dock (win_struct *win)
35
 
 {
36
 
   
37
 
@@ -479,12 +463,6 @@
38
 
   g_signal_connect ((gpointer) win->plug, "configure_event",
39
 
                     G_CALLBACK (icon_window_configure_event),
40
 
                     (gpointer) win);
41
 
-  
42
 
-  
43
 
-  g_signal_connect ((gpointer) win->plug, "enter_notify_event",
44
 
-                    G_CALLBACK (icon_window_enter_event),
45
 
-                    (gpointer) win);
46
 
-
47
 
 
48
 
   dock_window (win->manager_window, win->plug_xlib);
49
 
 
50
 
diff -urNad alltray-0.69~/src/utils.c alltray-0.69/src/utils.c
51
 
--- alltray-0.69~/src/utils.c   2009-04-16 12:39:06.000000000 +0930
52
 
+++ alltray-0.69/src/utils.c    2009-04-16 12:39:06.000000000 +0930
53
 
@@ -1517,7 +1517,7 @@
54
 
       win->title=g_strdup (title);
55
 
     
56
 
     if (debug) printf ("win->title: %s\n", win->title);
57
 
-        
58
 
+    gtk_widget_set_tooltip_text(win->plug, win->title);
59
 
     g_free(title);
60
 
     
61
 
     if (win->title_time)