~ubuntu-branches/ubuntu/wily/alltray/wily

« back to all changes in this revision

Viewing changes to debian/patches/15-dont-remove-from-pager.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Ignace Mouzannar
  • Date: 2010-11-20 16:16:12 UTC
  • mfrom: (2.1.3 sid)
  • Revision ID: james.westby@ubuntu.com-20101120161612-12y0wqt6g86fb7hu
Tags: 0.71b-1
* New upstream release. (Closes: #602233)
  - Fixes no windows hiding when using compiz. (Closes: #579503)
* debian/control:
  - Bumped Standards-Version to 3.9.1.
* debian/patches:
  - Removed 01_minor_type.diff as it has been integrated upstream.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 15-dont-remove-from-pager.dpatch by Kyran Lange <kyran.lange@gmail.com>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Fix "alltray hides applications from gnome-panel desktop switcher"
6
 
## DP: (LP: #118484)
7
 
## DP: src/utils.c: Do not hide application window from the pager.
8
 
## DP: From revision 26 upstream in the old-maintenance branch.
9
 
 
10
 
@DPATCH@
11
 
diff -urNad alltray-0.69~/src/utils.c alltray-0.69/src/utils.c
12
 
--- alltray-0.69~/src/utils.c   2009-04-16 15:20:57.000000000 +0930
13
 
+++ alltray-0.69/src/utils.c    2009-04-16 15:20:58.000000000 +0930
14
 
@@ -1919,8 +1919,6 @@
15
 
       if (win->sticky)
16
 
         sticky (parent_xlib);
17
 
       
18
 
-      skip_pager(parent_xlib, TRUE);
19
 
-      
20
 
       if (win->skip_tasklist)
21
 
         skip_taskbar (win, TRUE);
22