~ubuntu-branches/ubuntu/wily/ddclient/wily

« back to all changes in this revision

Viewing changes to debian/patches/bug468320_minmax_logic.diff

  • Committer: Bazaar Package Importer
  • Author(s): Bhavani Shankar
  • Date: 2009-01-05 19:22:17 UTC
  • mfrom: (2.1.5 squeeze)
  • Revision ID: james.westby@ubuntu.com-20090105192217-jr30aidvw01t1cd2
Tags: 3.7.3-5ubuntu1
* Merge from debian unstable, remaining changes: LP: #314064
  - Remove stop links from rc0 and rc6:
    + debian/rules: call dh_installinit with -- start 20 2 3 4 5 . stop 20 1 .
    + debian/ddclient.init: change Default-Stop: to 1
  - debian/patches: add sample_ubuntu.diff

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
This patch fixes the logic that restricts the min and max interval settings.
 
2
It makes sure that the internal values are the absolute max and min values.
 
3
Patch provided by Chris Carr, see http://bugs.debian.org/468320
 
4
 
 
5
Index: ddclient-3.7.3/ddclient
 
6
===================================================================
 
7
--- ddclient-3.7.3.orig/ddclient        2009-01-04 22:06:59.210757449 +0100
 
8
+++ ddclient-3.7.3/ddclient     2009-01-04 22:07:33.843760250 +0100
 
9
@@ -1000,7 +1000,7 @@
 
10
     $opt{'use'} = 'web' if !define($opt{'use'}) && defined($opt{'web'});
 
11
 
 
12
     ## sanity check
 
13
-    $opt{'max-interval'}       = max(interval(opt('max-interval')), interval(default('max-interval')));
 
14
+    $opt{'max-interval'}       = min(interval(opt('max-interval')), interval(default('max-interval')));
 
15
     $opt{'min-interval'}       = max(interval(opt('min-interval')), interval(default('min-interval')));
 
16
     $opt{'min-error-interval'} = max(interval(opt('min-error-interval')), interval(default('min-error-interval')));
 
17