~ubuntu-branches/ubuntu/wily/ecasound/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/0004-build-shared-libecasoundc.patch

  • Committer: Package Import Robot
  • Author(s): Alessandro Ghedini, Alessandro Ghedini, Alessio Treglia
  • Date: 2012-05-22 21:31:25 UTC
  • Revision ID: package-import@ubuntu.com-20120522213125-f14ecq0rlvp6boes
Tags: 2.8.1-7
[ Alessandro Ghedini ]
* Adjust Ruby bindings package name in the dh_fixperms override
  (fixes executable-not-elf-or-script)
* ecasound-el is Section: lisp
* Update ecasound.rb install path as per new Ruby Policy
* Update emacsen install and remove scripts (Closes: #671568)
* Drop 1001-disable_python_tests.patch (the tests are not run anyway)
* Use debian-pkg-add-load-path-item in emacsen startup script
  (Closes: #671551)
* Set up ecasound-ewf-mode with .ewf files (Closes: #672184)
* Add more DEP3 headers to the patches
* Add 04_fix-ecasound.el-ewf-regexp.patch
* Check if the elisp package dir exists in the startup script
* Build depend on python-all and not python-all-dev since we only ship the
  native Python module
* Remove misleading paragraph from long descriptions

[ Alessio Treglia ]
* Remove myself from the Uploaders field.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From: Alessandro Ghedini <al3xbio@gmail.com>
2
 
Date: Sun, 6 Feb 2011 19:32:41 +0100
3
 
Subject: [PATCH] build shared libecasoundc
4
 
 
5
 
Build libecasoundc as shared library instead of static
6
 
---
7
 
 libecasoundc/Makefile.am |    4 ++--
8
 
 libecasoundc/Makefile.in |    4 ++--
9
 
 2 files changed, 4 insertions(+), 4 deletions(-)
10
 
 
11
 
--- a/libecasoundc/Makefile.am
12
 
+++ b/libecasoundc/Makefile.am
13
 
@@ -14,9 +14,9 @@
14
 
 # !!!
15
 
 # remember to update eca-version.cpp
16
 
 if ECA_AM_DEBUG_MODE
17
 
-eca_ldflags = -version-info @LIBECASOUNDC_VERSION@:0:@LIBECASOUNDC_VERSION_AGE@ -static
18
 
+eca_ldflags = -version-info @LIBECASOUNDC_VERSION@:0:@LIBECASOUNDC_VERSION_AGE@ -shared -fPIC
19
 
 else
20
 
-eca_ldflags = -s -version-info @LIBECASOUNDC_VERSION@:0:@LIBECASOUNDC_VERSION_AGE@ -static
21
 
+eca_ldflags = -s -version-info @LIBECASOUNDC_VERSION@:0:@LIBECASOUNDC_VERSION_AGE@ -shared -fPIC
22
 
 endif
23
 
 
24
 
 INCLUDES = -I$(srcdir)
25
 
--- a/libecasoundc/Makefile.in
26
 
+++ b/libecasoundc/Makefile.in
27
 
@@ -261,7 +261,7 @@
28
 
 top_srcdir = @top_srcdir@
29
 
 EXTRA_DIST = ChangeLog
30
 
 AUTOMAKE_OPTIONS = foreign
31
 
-@ECA_AM_DEBUG_MODE_FALSE@eca_ldflags = -s -version-info @LIBECASOUNDC_VERSION@:0:@LIBECASOUNDC_VERSION_AGE@ -static
32
 
+@ECA_AM_DEBUG_MODE_FALSE@eca_ldflags = -s -version-info @LIBECASOUNDC_VERSION@:0:@LIBECASOUNDC_VERSION_AGE@ -shared -fPIC
33
 
 
34
 
 # ----------------------------------------------------------------------
35
 
 # defines
36
 
@@ -269,7 +269,7 @@
37
 
 
38
 
 # !!!
39
 
 # remember to update eca-version.cpp
40
 
-@ECA_AM_DEBUG_MODE_TRUE@eca_ldflags = -version-info @LIBECASOUNDC_VERSION@:0:@LIBECASOUNDC_VERSION_AGE@ -static
41
 
+@ECA_AM_DEBUG_MODE_TRUE@eca_ldflags = -version-info @LIBECASOUNDC_VERSION@:0:@LIBECASOUNDC_VERSION_AGE@ -shared -fPIC
42
 
 INCLUDES = -I$(srcdir)
43
 
 @ECA_AM_DEBUG_MODE_FALSE@lib_LTLIBRARIES = libecasoundc.la
44
 
 # -I$(top_srcdir)/libecasound