~ubuntu-branches/ubuntu/wily/ecasound/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/03_build-shared-libkvutils.patch

  • Committer: Package Import Robot
  • Author(s): Alessandro Ghedini, Alessandro Ghedini, Alessio Treglia
  • Date: 2012-05-22 21:31:25 UTC
  • Revision ID: package-import@ubuntu.com-20120522213125-f14ecq0rlvp6boes
Tags: 2.8.1-7
[ Alessandro Ghedini ]
* Adjust Ruby bindings package name in the dh_fixperms override
  (fixes executable-not-elf-or-script)
* ecasound-el is Section: lisp
* Update ecasound.rb install path as per new Ruby Policy
* Update emacsen install and remove scripts (Closes: #671568)
* Drop 1001-disable_python_tests.patch (the tests are not run anyway)
* Use debian-pkg-add-load-path-item in emacsen startup script
  (Closes: #671551)
* Set up ecasound-ewf-mode with .ewf files (Closes: #672184)
* Add more DEP3 headers to the patches
* Add 04_fix-ecasound.el-ewf-regexp.patch
* Check if the elisp package dir exists in the startup script
* Build depend on python-all and not python-all-dev since we only ship the
  native Python module
* Remove misleading paragraph from long descriptions

[ Alessio Treglia ]
* Remove myself from the Uploaders field.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Build shared libkvutils instead of static
 
2
Origin: vendor
 
3
Forwarded: not-needed
 
4
Author: Alessandro Ghedini <ghedo@debian.org>
 
5
Reviewed-by: Alessandro Ghedini <ghedo@debian.org>
 
6
Last-Update: 2012-05-09
 
7
 
 
8
--- a/kvutils/Makefile.am
 
9
+++ b/kvutils/Makefile.am
 
10
@@ -56,7 +56,7 @@
 
11
                        kvu_value_queue.h
 
12
 
 
13
 libkvutils_la_SOURCES = $(kvutil_sources) $(kvutil_headers)
 
14
-libkvutils_la_LDFLAGS = -version-info @LIBKVUTILS_VERSION@:0:@LIBKVUTILS_VERSION_AGE@ -static
 
15
+libkvutils_la_LDFLAGS = -version-info @LIBKVUTILS_VERSION@:0:@LIBKVUTILS_VERSION_AGE@ -shared -fPIC
 
16
 
 
17
 libkvutils_debug_la_SOURCES = $(libkvutils_la_SOURCES)
 
18
 libkvutils_debug_la_LDFLAGS = $(libkvutils_la_LDFLAGS)
 
19
--- a/kvutils/Makefile.in
 
20
+++ b/kvutils/Makefile.in
 
21
@@ -299,7 +299,7 @@
 
22
                        kvu_value_queue.h
 
23
 
 
24
 libkvutils_la_SOURCES = $(kvutil_sources) $(kvutil_headers)
 
25
-libkvutils_la_LDFLAGS = -version-info @LIBKVUTILS_VERSION@:0:@LIBKVUTILS_VERSION_AGE@ -static
 
26
+libkvutils_la_LDFLAGS = -version-info @LIBKVUTILS_VERSION@:0:@LIBKVUTILS_VERSION_AGE@ -shared -fPIC
 
27
 libkvutils_debug_la_SOURCES = $(libkvutils_la_SOURCES)
 
28
 libkvutils_debug_la_LDFLAGS = $(libkvutils_la_LDFLAGS)
 
29
 libkvutils_tester_SOURCES = libkvutils_tester.cpp
 
30
--- a/libecasound/Makefile.am
 
31
+++ b/libecasound/Makefile.am
 
32
@@ -364,7 +364,7 @@
 
33
 
 
34
 libecasound_la_SOURCES = $(ecasound_common1_src) $(ecasound_common2_src)
 
35
 libecasound_debug_la_SOURCES = $(ecasound_common1_src) $(ecasound_common2_src)
 
36
-libecasound_la_LDFLAGS = -export-dynamic $(eca_ldflags) -static
 
37
+libecasound_la_LDFLAGS = -export-dynamic $(eca_ldflags) -static -L$(top_builddir)/kvutils -lkvutils
 
38
 libecasound_la_LIBADD = $(eca_libadd)
 
39
 libecasound_debug_la_LDFLAGS = $(libecasound_la_LDFLAGS)
 
40
 libecasound_debug_la_LIBADD = $(libecasound_la_LIBADD)
 
41
--- a/libecasound/Makefile.in
 
42
+++ b/libecasound/Makefile.in
 
43
@@ -708,7 +708,7 @@
 
44
 
 
45
 libecasound_la_SOURCES = $(ecasound_common1_src) $(ecasound_common2_src)
 
46
 libecasound_debug_la_SOURCES = $(ecasound_common1_src) $(ecasound_common2_src)
 
47
-libecasound_la_LDFLAGS = -export-dynamic $(eca_ldflags) -static
 
48
+libecasound_la_LDFLAGS = -export-dynamic $(eca_ldflags) -static -L$(top_builddir)/kvutils -lkvutils
 
49
 libecasound_la_LIBADD = $(eca_libadd)
 
50
 libecasound_debug_la_LDFLAGS = $(libecasound_la_LDFLAGS)
 
51
 libecasound_debug_la_LIBADD = $(libecasound_la_LIBADD)