~ubuntu-branches/ubuntu/wily/morse/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/01alarm_time_t.patch

  • Committer: Package Import Robot
  • Author(s): Nanakos Chrysostomos
  • Date: 2015-06-10 11:26:20 UTC
  • mfrom: (7.1.3 sid)
  • Revision ID: package-import@ubuntu.com-20150610112620-q00v2tou9427gf42
Tags: 2.5-1
* New upstream release.
* Bump S-V to 3.9.6.
* Clean Lintian messages.
* Fix AlarmSet declaration and definition match (Closes: Bug#749420).
* Update watch file (Closes: Bug#784861).
* Fix build (omit morseALSA and morseLinux) for non-Linux arches
  - drop 02makefile.patch, build and install via debian/rules
* Fix -X crash (Closes: #716099, #716111, #716218, #716298)
* Adjust Maintainer/Uploaders fields

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Fix AlarmSet function definition and declaration match.
 
2
Author: Nanakos Chrysostomos <nanakos@wired-net.gr>
 
3
Bug-Debian: http://bugs.debian.org/749420
 
4
 
 
5
--- morse-2.5.orig/morse.d/alarm.c
 
6
+++ morse-2.5/morse.d/alarm.c
 
7
@@ -16,7 +16,7 @@ static void ualarm();
 
8
 static void AlarmHandler();
 
9
 
 
10
 void AlarmSet(time)
 
11
-    int time;
 
12
+    time_t time;
 
13
 {
 
14
     struct sigaction handler;
 
15