~ubuntu-branches/ubuntu/wily/morse/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/01makefile

  • Committer: Package Import Robot
  • Author(s): Nanakos Chrysostomos
  • Date: 2015-06-10 11:26:20 UTC
  • mfrom: (7.1.3 sid)
  • Revision ID: package-import@ubuntu.com-20150610112620-q00v2tou9427gf42
Tags: 2.5-1
* New upstream release.
* Bump S-V to 3.9.6.
* Clean Lintian messages.
* Fix AlarmSet declaration and definition match (Closes: Bug#749420).
* Update watch file (Closes: Bug#784861).
* Fix build (omit morseALSA and morseLinux) for non-Linux arches
  - drop 02makefile.patch, build and install via debian/rules
* Fix -X crash (Closes: #716099, #716111, #716218, #716298)
* Adjust Maintainer/Uploaders fields

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Minor Makefile changes needed for Debian
2
 
Author: Nanakos Chrysostomos <nanakos@wired-net.gr>
3
 
 
4
 
--- morse-2.4.orig/Makefile
5
 
+++ morse-2.4/Makefile
6
 
@@ -37,10 +37,16 @@ ALL=  $(DOCS) Makefile $(SOURCES) test_i
7
 
        qso.d/*.[ch] qso.d/Makefile
8
 
 
9
 
 default:
10
 
-       make testmorse
11
 
+       make all
12
 
 
13
 
 all: morse QSO morse.1 QSO.1
14
 
 
15
 
+install: all
16
 
+       install morse.d/morsePA $(DESTDIR)/usr/bin/morse
17
 
+       install morse.d/morseLinux $(DESTDIR)/usr/bin
18
 
+       install morse.d/morseX11 $(DESTDIR)/usr/bin
19
 
+       install qso.d/QSO $(DESTDIR)/usr/bin
20
 
+
21
 
 morse:
22
 
        cd morse.d && make DEVICE=${DEVICE}
23
 
        ln morse.d/morse ./morse