~ubuntu-branches/ubuntu/wily/wmcdplay/wily

« back to all changes in this revision

Viewing changes to debian/patches/add_debugging_comments.patch

  • Committer: Package Import Robot
  • Author(s): Doug Torrance
  • Date: 2014-07-30 17:21:08 UTC
  • Revision ID: package-import@ubuntu.com-20140730172108-jsrnmgou9enr1xwy
Tags: 1.0beta1-12
* New maintainer (Closes: #632877).
* Switch to dpkg-source 3.0 (quilt) format.
  - Add debian/source/format.
  - Convert patches from previous versions; now appear in debian/patches.
* debian/control
  - Remove redundant Section and Priority fields.
  - Add Homepage, Vcs-* fields.
* debian/copyright
  - Update to machine-readable format version 1.0.
* debian/dirs
  - Remove file; directories already created by build process.
* debian/install
  - New file; install artwork.
* debian/manpages
  - New file.
* debian/patches/fix_hurd_ftbfs.patch
  - Fix FTBFS on Hurd; thanks to Samuel Thibault <sthibault@debian.org>
    (Closes: #647964).
* debian/rules
  - Simplify to use dh.
  - Previous debian/rules used install -s, which resulted in a stripped binary
    even when DEB_BUILD_OPTIONS=nostrip was specified.  This no longer occurs
    (Closes: #438267).
  - Pass CXXFLAGS and LDFLAGS to make to enable hardening.
* debian/watch
  - New file.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Add debugging comments to cdctl.h.
 
2
 Patch created for some version between 1.0beta1-5 and and 1.0beta1-8.
 
3
 Converted to quilt for 1.0beta-12.
 
4
Author: Doug Torrance <dtorrance@monmouthcollege.edu>
 
5
Last-Update: 2014-07-29
 
6
 
 
7
--- a/cdctl.h
 
8
+++ b/cdctl.h
 
9
@@ -213,9 +213,19 @@
 
10
                    start = cd_trklist[status_track].track_start;
 
11
                    stop = start + cd_trklist[status_track].track_len - _CDCTL_SENSITIVITY;
 
12
                    now = ((sc.cdsc_absaddr.msf.minute) * 60 + sc.cdsc_absaddr.msf.second) * 75 + sc.cdsc_absaddr.msf.frame - CD_MSF_OFFSET;
 
13
+/*
 
14
+cout << "=============" << endl;
 
15
+cout << "start:" << start << endl;
 
16
+cout << "stop:" << stop << endl;
 
17
+cout << "now:" << now << endl;
 
18
+*/
 
19
                   if(now>0 && (now<start || now>=stop)){
 
20
                       status_state=ssPlaying;
 
21
                       selecttrack();
 
22
+/*
 
23
+cout << "Play track " << status_track << endl;
 
24
+cout << "=============" << endl;
 
25
+*/
 
26
                       doStatus();
 
27
                       return;
 
28
                    }