~ubuntu-branches/ubuntu/wily/wmcdplay/wily

« back to all changes in this revision

Viewing changes to debian/patches/set_remain_to_zero.patch

  • Committer: Package Import Robot
  • Author(s): Doug Torrance
  • Date: 2014-07-30 17:21:08 UTC
  • Revision ID: package-import@ubuntu.com-20140730172108-jsrnmgou9enr1xwy
Tags: 1.0beta1-12
* New maintainer (Closes: #632877).
* Switch to dpkg-source 3.0 (quilt) format.
  - Add debian/source/format.
  - Convert patches from previous versions; now appear in debian/patches.
* debian/control
  - Remove redundant Section and Priority fields.
  - Add Homepage, Vcs-* fields.
* debian/copyright
  - Update to machine-readable format version 1.0.
* debian/dirs
  - Remove file; directories already created by build process.
* debian/install
  - New file; install artwork.
* debian/manpages
  - New file.
* debian/patches/fix_hurd_ftbfs.patch
  - Fix FTBFS on Hurd; thanks to Samuel Thibault <sthibault@debian.org>
    (Closes: #647964).
* debian/rules
  - Simplify to use dh.
  - Previous debian/rules used install -s, which resulted in a stripped binary
    even when DEB_BUILD_OPTIONS=nostrip was specified.  This no longer occurs
    (Closes: #438267).
  - Pass CXXFLAGS and LDFLAGS to make to enable hardening.
* debian/watch
  - New file.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Set remain variable to zero.
 
2
 This avoids an possible undeclared variable error five lines later if remain
 
3
 is never set:
 
4
    "if(remain<2250)"
 
5
 .
 
6
 Patch created for some version between 1.0beta1-5 and and 1.0beta1-8.
 
7
 Converted to quilt for 1.0beta-12.
 
8
Author: Doug Torrance <dtorrance@monmouthcollege.edu>
 
9
Last-Update: 2014-07-29
 
10
 
 
11
--- a/wmcdplay.cc
 
12
+++ b/wmcdplay.cc
 
13
@@ -485,7 +485,7 @@
 
14
             drawText(art_ledpos[1][0], art_ledpos[1][1], trackstr);
 
15
       }
 
16
       if(mode==ssPlaying || mode==ssPaused || mode==ssStopped){
 
17
-         int remain;
 
18
+         int remain = 0;
 
19
          if(tdisplay==0)
 
20
             remain=cdctl->getTrackLen(cdctl->getStatusTrack())-pos;
 
21
          if(tdisplay==1)