~ubuntu-branches/ubuntu/wily/yelp/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/08_g_thread_init_deprecation.patch

  • Committer: Package Import Robot
  • Author(s): Martin Pitt
  • Date: 2012-01-03 13:23:15 UTC
  • mfrom: (1.1.54)
  • Revision ID: package-import@ubuntu.com-20120103132315-yvk636rtjs1j62hx
Tags: 3.3.2-0ubuntu1
* debian/watch: Watch for development versions.
* New upstream release.
* debian/control.in: Add libgee-dev and libfolks-dev build dependencies as
  per upstream configure.ac.
* 01_lpi.patch, 06_setup_error_on_missing_dbus.patch: Unfuzz.
* Add 08_g_thread_init_deprecation.patch: Don't call g_thread_init().
  (LP: #911125)
* debian/libyelp0.symbols: Add new symbol from this upstream release.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 78a941e2163194c263df1ca4f5b9104019ca0c3b Mon Sep 17 00:00:00 2001
 
2
From: Martin Pitt <martin.pitt@ubuntu.com>
 
3
Date: Tue, 3 Jan 2012 13:11:05 +0100
 
4
Subject: [PATCH] Don't call g_thread_init()
 
5
 
 
6
This completes commit f5c1a48 and removes the remaining calls.
 
7
---
 
8
 docs/libyelp/Makefile.am    |    2 +-
 
9
 tests/test-location-entry.c |    2 +-
 
10
 tests/test-settings.c       |    2 +-
 
11
 tests/test-transform.c      |    1 -
 
12
 tests/test-uri.c            |    1 -
 
13
 tests/test-view.c           |    2 +-
 
14
 6 files changed, 4 insertions(+), 6 deletions(-)
 
15
 
 
16
Bug: https://bugzilla.gnome.org/show_bug.cgi?id=663285
 
17
Bug-Ubuntu: https://launchpad.net/bugs/911125
 
18
 
 
19
Index: yelp-3.3.2/docs/libyelp/Makefile.am
 
20
===================================================================
 
21
--- yelp-3.3.2.orig/docs/libyelp/Makefile.am    2011-03-17 16:51:13.000000000 +0100
 
22
+++ yelp-3.3.2/docs/libyelp/Makefile.am 2012-01-03 13:17:18.161058950 +0100
 
23
@@ -6,7 +6,7 @@
 
24
 
 
25
 SCAN_OPTIONS = --deprecated-guards="G_DISABLE_DEPRECATED" --rebuild-types
 
26
 
 
27
-SCANGOBJ_OPTIONS = --type-init-func="g_type_init();g_thread_init(NULL);"
 
28
+SCANGOBJ_OPTIONS = --type-init-func="g_type_init();"
 
29
 
 
30
 DOC_SOURCE_DIR = $(top_srcdir)/libyelp
 
31
 
 
32
Index: yelp-3.3.2/tests/test-settings.c
 
33
===================================================================
 
34
--- yelp-3.3.2.orig/tests/test-settings.c       2011-03-17 16:51:13.000000000 +0100
 
35
+++ yelp-3.3.2/tests/test-settings.c    2012-01-03 13:17:18.161058950 +0100
 
36
@@ -207,7 +207,7 @@
 
37
     GtkWidget *window, *hbox, *vbox, *widget, *scroll, *table;
 
38
     gint i;
 
39
 
 
40
-    g_thread_init (NULL);
 
41
+    g_type_init ();
 
42
     gtk_init (&argc, &argv);
 
43
 
 
44
     settings = yelp_settings_get_default ();
 
45
Index: yelp-3.3.2/tests/test-transform.c
 
46
===================================================================
 
47
--- yelp-3.3.2.orig/tests/test-transform.c      2011-03-17 16:51:13.000000000 +0100
 
48
+++ yelp-3.3.2/tests/test-transform.c   2012-01-03 13:17:18.161058950 +0100
 
49
@@ -119,7 +119,6 @@
 
50
     gchar *file;
 
51
 
 
52
     g_type_init ();
 
53
-    g_thread_init (NULL);
 
54
 
 
55
     context = g_option_context_new ("[STYLESHEET] FILE");
 
56
     g_option_context_add_main_entries (context, options, NULL);
 
57
Index: yelp-3.3.2/tests/test-uri.c
 
58
===================================================================
 
59
--- yelp-3.3.2.orig/tests/test-uri.c    2011-03-17 16:51:13.000000000 +0100
 
60
+++ yelp-3.3.2/tests/test-uri.c 2012-01-03 13:17:18.165058951 +0100
 
61
@@ -226,7 +226,6 @@
 
62
     YelpUri *uri = NULL;
 
63
 
 
64
     g_type_init ();
 
65
-    g_thread_init (NULL);
 
66
     g_log_set_always_fatal (G_LOG_LEVEL_ERROR | G_LOG_LEVEL_CRITICAL);
 
67
         
 
68
     if (argc < 2) {
 
69
Index: yelp-3.3.2/tests/test-view.c
 
70
===================================================================
 
71
--- yelp-3.3.2.orig/tests/test-view.c   2011-03-17 16:51:13.000000000 +0100
 
72
+++ yelp-3.3.2/tests/test-view.c        2012-01-03 13:17:18.165058951 +0100
 
73
@@ -68,7 +68,7 @@
 
74
     YelpDocument *document;
 
75
     GCancellable *cancellable;
 
76
 
 
77
-    g_thread_init (NULL);
 
78
+    g_type_init ();
 
79
     gtk_init (&argc, &argv);
 
80
 
 
81
     window = gtk_window_new (GTK_WINDOW_TOPLEVEL);
 
82
Index: yelp-3.3.2/docs/libyelp/Makefile.in
 
83
===================================================================
 
84
--- yelp-3.3.2.orig/docs/libyelp/Makefile.in    2011-12-21 15:29:19.000000000 +0100
 
85
+++ yelp-3.3.2/docs/libyelp/Makefile.in 2012-01-03 13:17:54.921060731 +0100
 
86
@@ -250,7 +250,7 @@
 
87
 DOC_MODULE = libyelp
 
88
 DOC_MAIN_SGML_FILE = libyelp-docs.xml
 
89
 SCAN_OPTIONS = --deprecated-guards="G_DISABLE_DEPRECATED" --rebuild-types
 
90
-SCANGOBJ_OPTIONS = --type-init-func="g_type_init();g_thread_init(NULL);"
 
91
+SCANGOBJ_OPTIONS = --type-init-func="g_type_init();"
 
92
 DOC_SOURCE_DIR = $(top_srcdir)/libyelp
 
93
 GTKDOC_CFLAGS = \
 
94
        $(YELP_CFLAGS)                                  \