~ubuntu-core-dev/ubuntu/maverick/eucalyptus/devel

« back to all changes in this revision

Viewing changes to debian/patches/11-state-cleanup-memleakfix.patch

  • Committer: Dustin Kirkland
  • Date: 2010-07-22 08:41:57 UTC
  • mfrom: (1050.1.19 ubuntu)
  • Revision ID: kirkland@x200-20100722084157-zh2p8dkawznvxxpn
Approving Dave Walker's merge of new upstream Eucalyptus 2.0 release.

Dustin Kirkland <kirkland@canonical.com>

* New major upstream version merge, 2.0 (r1211).
  - 01-wsdl-stubs.patch, debian/wsdl.md5sums: wsdl stubs updated.
  - 11-state-cleanup-memleakfix.patch: Removed, fixed upstream.
  - 21-eucalyptus-1.7-with-gwt-1.6.4.patch: New patch, allows 
    eucalyptus-1.7 to be built against gwt 1.6.4. Based on patch courtesy 
    of Dmitrii Zagorodnov, upstream. (LP: #597330)
* debian/eucalyptus-java-common.links: 
  - Changed symlink for groovy, point to groovy.all.jar, making compatiable 
    with groovy versions >1.7. (LP: #595421)
  - Added ant.jar & jetty-rewrite-handler.jar as they are now required.
* debian/control
  - & debian/build-jars: Added libjavassist-java and libjetty-extra-java as 
    build dependencies.
  - Added libjetty-extra-java as a dependency of eucalyptus-java-common
* The binary resulting jar's have been renamed from eucalyptus-*-1.6.2.jar
  to eucalyptus-*-main.jar:    
  - debian/eucalyptus-cc.upstart
  - debian/eucalyptus-cloud.install
  - debian/eucalyptus-common.eucalyptus.upstart
  - debian/eucalyptus-java-common.install
  - debian/eucalyptus-network.upstart
  - debian/eucalyptus-sc.install
  - debian/eucalyptus-walrus.install
* debian/eucalyptus-java-common.install: New upstream jars that have been
  installed:
  - eucalyptus-db-hsqldb-ext-main.jar
  - eucalyptus-component-main.jar
* debian/control:
  - Updated Standards Version to 3.8.4 (no change)
  - Updated the upstream Homepage to: http://open.eucalyptus.com/
  - Changed Vcs-Bzr to reflect new location of Ubuntu hosted development branch.
  - Made the Build Dependency of groovy and the binary eucalyptus-java-common
    package depend on version >=1.7.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: When cleaning up a walrus volume, there was a memory leak
2
 
Origin: Manually created from the diff between Ubuntu 1.6.2 branch and upstreams
3
 
--- a/clc/modules/core/src/main/java/edu/ucsb/eucalyptus/util/WalrusDataMessenger.java
4
 
+++ b/clc/modules/core/src/main/java/edu/ucsb/eucalyptus/util/WalrusDataMessenger.java
5
 
@@ -104,12 +104,23 @@
6
 
                return getQueue(key1, key2);
7
 
        }
8
 
 
9
 
+       public WalrusDataQueue<WalrusDataMessage> interruptAllAndGetQueue(String key1, String key2) {
10
 
+               ConcurrentHashMap<String,WalrusDataQueue<WalrusDataMessage>> queues = queueMap.get(key1);
11
 
+               if(queues != null) {
12
 
+                       for (WalrusDataQueue<WalrusDataMessage> queue: queues.values()) {
13
 
+                               queue.setInterrupted(true);
14
 
+                       }
15
 
+               }
16
 
+               return getQueue(key1, key2);
17
 
+       }
18
 
+
19
 
        public void removeQueue(String key1, String key2) {
20
 
                if(queueMap.containsKey(key1)) {
21
 
                        ConcurrentHashMap<String, WalrusDataQueue<WalrusDataMessage>> queues = queueMap.get(key1);
22
 
                        if(queues.containsKey(key2)) {
23
 
                                queues.remove(key2);
24
 
                        }
25
 
+                       queueMap.remove(key1);
26
 
                }
27
 
        }
28