~ubuntu-core-dev/ubuntu/maverick/eucalyptus/devel

« back to all changes in this revision

Viewing changes to debian/patches/21-eucalyptus-1.7-with-gwt-1.6.4.patch

  • Committer: Dustin Kirkland
  • Date: 2010-07-22 08:41:57 UTC
  • mfrom: (1050.1.19 ubuntu)
  • Revision ID: kirkland@x200-20100722084157-zh2p8dkawznvxxpn
Approving Dave Walker's merge of new upstream Eucalyptus 2.0 release.

Dustin Kirkland <kirkland@canonical.com>

* New major upstream version merge, 2.0 (r1211).
  - 01-wsdl-stubs.patch, debian/wsdl.md5sums: wsdl stubs updated.
  - 11-state-cleanup-memleakfix.patch: Removed, fixed upstream.
  - 21-eucalyptus-1.7-with-gwt-1.6.4.patch: New patch, allows 
    eucalyptus-1.7 to be built against gwt 1.6.4. Based on patch courtesy 
    of Dmitrii Zagorodnov, upstream. (LP: #597330)
* debian/eucalyptus-java-common.links: 
  - Changed symlink for groovy, point to groovy.all.jar, making compatiable 
    with groovy versions >1.7. (LP: #595421)
  - Added ant.jar & jetty-rewrite-handler.jar as they are now required.
* debian/control
  - & debian/build-jars: Added libjavassist-java and libjetty-extra-java as 
    build dependencies.
  - Added libjetty-extra-java as a dependency of eucalyptus-java-common
* The binary resulting jar's have been renamed from eucalyptus-*-1.6.2.jar
  to eucalyptus-*-main.jar:    
  - debian/eucalyptus-cc.upstart
  - debian/eucalyptus-cloud.install
  - debian/eucalyptus-common.eucalyptus.upstart
  - debian/eucalyptus-java-common.install
  - debian/eucalyptus-network.upstart
  - debian/eucalyptus-sc.install
  - debian/eucalyptus-walrus.install
* debian/eucalyptus-java-common.install: New upstream jars that have been
  installed:
  - eucalyptus-db-hsqldb-ext-main.jar
  - eucalyptus-component-main.jar
* debian/control:
  - Updated Standards Version to 3.8.4 (no change)
  - Updated the upstream Homepage to: http://open.eucalyptus.com/
  - Changed Vcs-Bzr to reflect new location of Ubuntu hosted development branch.
  - Made the Build Dependency of groovy and the binary eucalyptus-java-common
    package depend on version >=1.7.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Allows eucalyptus 1.7 to be compiled with gwt 1.6.4.
 
2
 This patch should be removed when gwt package has been updated to 2.0.* 
 
3
Author: Dmitrii Zagorodnov <dmitrii@eucalyptus.com>
 
4
Bug: https://launchpad.net/bugs/597330
 
5
--- a/clc/build.xml
 
6
+++ b/clc/build.xml
 
7
@@ -201,10 +201,10 @@
 
8
                <copy todir="${DESTDIR}${euca.lib.dir}" overwrite="true">
 
9
                        <fileset dir="${deps.lib.dir}">
 
10
                                <include name="**/*" />
 
11
-                               <exclude name="**/gwt-api-checker-*.jar" />
 
12
+                               <!--exclude name="**/gwt-api-checker-*.jar" />
 
13
                                <exclude name="**/gwt-dev-*.jar" />
 
14
                                <exclude name="**/gwt-soyc-vis-*.jar" />
 
15
-                               <exclude name="**/gwt-user-*.jar" />
 
16
+                               <exclude name="**/gwt-user-*.jar" /-->
 
17
                        </fileset>
 
18
                </copy>
 
19
                <!--copy admin tools -->
 
20
--- a/clc/modules/www/build.xml
 
21
+++ b/clc/modules/www/build.xml
 
22
@@ -85,6 +85,7 @@
 
23
        <property environment="env" />
 
24
        <path id="gwtclasspath">
 
25
                <fileset dir="${lib.dir}">
 
26
+            <include name="**/gwt-dev-linux-1.6.4.jar" />
 
27
                        <include name="**/*.jar" />
 
28
                </fileset>
 
29
                <pathelement path="conf" />
 
30
@@ -94,7 +95,7 @@
 
31
        </path>
 
32
        <path id="gwtcompilerclasspath">
 
33
                <fileset dir="${lib.dir}">
 
34
-                       <include name="**/gwt-dev.jar" />
 
35
+                       <include name="**/gwt-dev-linux-1.6.4.jar" />
 
36
                </fileset>
 
37
                <path refid="gwtclasspath" />
 
38
     <dirset dir="${modules.dir}">
 
39
--- a/clc/modules/www/src/main/java/edu/ucsb/eucalyptus/admin/EucalyptusWebInterface.gwt.xml
 
40
+++ b/clc/modules/www/src/main/java/edu/ucsb/eucalyptus/admin/EucalyptusWebInterface.gwt.xml
 
41
@@ -65,7 +65,7 @@
 
42
 <module>
 
43
        <!-- Inherit the core Web Toolkit stuff. -->
 
44
     <inherits name='com.google.gwt.user.User'/>
 
45
-    <inherits name="com.google.gwt.resources.Resources" />
 
46
+    <!--inherits name="com.google.gwt.resources.Resources" /-->
 
47
     <!-- <set-property name='user.agent' value='gecko1_8' /> -->
 
48
        <!-- Inherit internationalization support. -->
 
49
        <!-- <inherits name='com.google.gwt.i18n.I18N'/> -->
 
50
--- a/clc/modules/www/src/main/java/edu/ucsb/eucalyptus/admin/client/util/XHTML.java
 
51
+++ /dev/null
 
52
@@ -1,25 +0,0 @@
 
53
-package edu.ucsb.eucalyptus.admin.client.util;
 
54
-
 
55
-import com.google.gwt.resources.client.ImageResource;
 
56
-import com.google.gwt.user.client.ui.HTML;
 
57
-import com.google.gwt.user.client.ui.HasVerticalAlignment;
 
58
-import com.google.gwt.user.client.ui.HorizontalPanel;
 
59
-import com.google.gwt.user.client.ui.Image;
 
60
-
 
61
-public class XHTML {
 
62
-  public static String headerWithImage( final String text, final ImageResource image, final String style ) {
 
63
-    return new HorizontalPanel( ) {
 
64
-      {
 
65
-        setSpacing( 0 );
 
66
-        setVerticalAlignment( HasVerticalAlignment.ALIGN_MIDDLE );
 
67
-        add( new Image( image ) );
 
68
-        HTML headerText = new HTML( text ) {
 
69
-          {
 
70
-            setStyleName( style );
 
71
-          }
 
72
-        };
 
73
-        add( headerText );
 
74
-      }
 
75
-    }.getElement( ).getString( );
 
76
-  }
 
77
-}