~clint-fewbar/ubuntu/precise/erlang/merge-15b

« back to all changes in this revision

Viewing changes to debian/patches/clean.patch

  • Committer: Package Import Robot
  • Author(s): Sergei Golovan
  • Date: 2011-12-15 19:20:10 UTC
  • mfrom: (1.1.18) (3.5.15 sid)
  • mto: (3.5.16 sid)
  • mto: This revision was merged to the branch mainline in revision 33.
  • Revision ID: package-import@ubuntu.com-20111215192010-jnxcfe3tbrpp0big
Tags: 1:15.b-dfsg-1
* New upstream release.
* Upload to experimental because this release breaks external drivers
  API along with ABI, so several applications are to be fixed.
* Removed SSL patch because the old SSL implementation is removed from
  the upstream distribution.
* Removed never used patch which added native code to erlang beam files.
* Removed the erlang-docbuilder binary package because the docbuilder
  application was dropped by upstream.
* Documented dropping ${erlang-docbuilder:Depends} substvar in
  erlang-depends(1) manpage.
* Made erlang-base and erlang-base-hipe provide virtual package
  erlang-abi-15.b (the number means the first erlang version, which
  provides current ABI).

Show diffs side-by-side

added added

removed removed

Lines of Context:
3
3
Erlang leaves many files after make clean. This patch contains
4
4
a hack to remove them.
5
5
 
6
 
--- erlang-14.b.1-dfsg.orig/Makefile.in
7
 
+++ erlang-14.b.1-dfsg/Makefile.in
8
 
@@ -995,6 +995,7 @@
 
6
--- erlang-15.b-dfsg.orig/Makefile.in
 
7
+++ erlang-15.b-dfsg/Makefile.in
 
8
@@ -950,6 +950,7 @@
 
9
        find . -type f -name SKIP -print | xargs $(RM)
9
10
        cd erts && ERL_TOP=$(ERL_TOP) $(MAKE) clean
10
11
        cd lib  && ERL_TOP=$(ERL_TOP) $(MAKE) clean BUILD_ALL=true
11
 
        cd lib/dialyzer && ERL_TOP=$(ERL_TOP) $(MAKE) clean
12
12
+       $(MAKE) additional_clean
13
13
 
14
14
 #
15
15
 # Just wipe out emulator, not libraries
16
 
@@ -1030,3 +1031,170 @@
 
16
@@ -985,3 +986,166 @@
17
17
                || $(MAKE) BOOTSTRAP_ROOT=$(BOOTSTRAP_ROOT) bootstrap_root_clean
18
18
 
19
19
 # ----------------------------------------------------------------------
73
73
+       rm -rf $(ERL_TOP)/lib/crypto/c_src/$(TARGET)
74
74
+       rm -rf $(ERL_TOP)/lib/crypto/priv/lib/$(TARGET)
75
75
+       rm -rf $(ERL_TOP)/lib/crypto/priv/obj/$(TARGET)
76
 
+       rm -rf $(ERL_TOP)/lib/docbuilder/ebin/docbuilder.appup
77
76
+       rm -rf $(ERL_TOP)/lib/erl_interface/bin/$(TARGET)
78
77
+       rm -rf $(ERL_TOP)/lib/erl_interface/config.log
79
78
+       rm -rf $(ERL_TOP)/lib/erl_interface/config.status
129
128
+       rm -rf $(ERL_TOP)/lib/snmp/config.log
130
129
+       rm -rf $(ERL_TOP)/lib/snmp/config.status
131
130
+       rm -rf $(ERL_TOP)/lib/snmp/mibs/Makefile
132
 
+       rm -rf $(ERL_TOP)/lib/ssl/c_src/$(TARGET)
133
131
+       rm -rf $(ERL_TOP)/lib/ssl/doc/man6/ssl.6
134
 
+       rm -rf $(ERL_TOP)/lib/ssl/priv/bin/$(TARGET)
135
 
+       rm -rf $(ERL_TOP)/lib/ssl/priv/obj/$(TARGET)
136
132
+       rm -rf $(ERL_TOP)/lib/test_server/src/configure
137
133
+       rm -rf $(ERL_TOP)/lib/tools/c_src/$(TARGET)
138
134
+       rm -rf $(ERL_TOP)/lib/tools/src/xref_parser.erl