~clint-fewbar/ubuntu/precise/erlang/merge-15b

« back to all changes in this revision

Viewing changes to debian/patches/gnu.patch

  • Committer: Package Import Robot
  • Author(s): Sergei Golovan
  • Date: 2011-12-15 19:20:10 UTC
  • mfrom: (1.1.18) (3.5.15 sid)
  • mto: (3.5.16 sid)
  • mto: This revision was merged to the branch mainline in revision 33.
  • Revision ID: package-import@ubuntu.com-20111215192010-jnxcfe3tbrpp0big
Tags: 1:15.b-dfsg-1
* New upstream release.
* Upload to experimental because this release breaks external drivers
  API along with ABI, so several applications are to be fixed.
* Removed SSL patch because the old SSL implementation is removed from
  the upstream distribution.
* Removed never used patch which added native code to erlang beam files.
* Removed the erlang-docbuilder binary package because the docbuilder
  application was dropped by upstream.
* Documented dropping ${erlang-docbuilder:Depends} substvar in
  erlang-depends(1) manpage.
* Made erlang-base and erlang-base-hipe provide virtual package
  erlang-abi-15.b (the number means the first erlang version, which
  provides current ABI).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
gnu.patch by Aurelien Jarno <aurel32@debian.org> and
2
 
Sergei Golovan <sgolovan@debian.org>
 
1
Author: Aurelien Jarno <aurel32@debian.org>
 
2
Author: Sergei Golovan <sgolovan@debian.org>
 
3
Author: Pino Toscano <pino@debian.org>
3
4
 
4
5
(1) Defines GNU macros not only for Linux but also for any system
5
6
    with 'gnu' substring in OS name. Fixes FTBFS on GNU/kFreeBSD and GNU/Hurd.
6
7
 
7
8
(2) Undefines BSD4_4 for os_mon application for GNU/Hurd;
8
9
 
9
 
--- erlang-14.b.1-dfsg.orig/erts/configure.in
10
 
+++ erlang-14.b.1-dfsg/erts/configure.in
11
 
@@ -385,7 +385,7 @@
 
10
(3) Undefines AF_LINK for GNU/Hurd;
 
11
 
 
12
(4) Switch some PATH_MAX occurrences to MAXPATHLEN;
 
13
 
 
14
--- erlang-15.b-dfsg.orig/erts/configure.in
 
15
+++ erlang-15.b-dfsg/erts/configure.in
 
16
@@ -378,7 +378,7 @@
12
17
 
13
18
 dnl NOTE: CPPFLAGS will be included in CFLAGS at the end
14
19
 case $host_os in
17
22
     win32)
18
23
        # The ethread library requires _WIN32_WINNT of at least 0x0403.
19
24
        # -D_WIN32_WINNT=* from CPPFLAGS is saved in ETHR_DEFS.
20
 
@@ -1184,7 +1184,7 @@
 
25
@@ -1120,7 +1120,7 @@
21
26
            solaris*)
22
27
                enable_child_waiter_thread=yes
23
28
                ;;
26
31
                AC_MSG_CHECKING([whether dlopen() needs to be called before first call to dlerror()])
27
32
                if test "x$ETHR_THR_LIB_BASE_TYPE" != "xposix_nptl"; then
28
33
                    AC_DEFINE(ERTS_NEED_DLOPEN_BEFORE_DLERROR,[1],
29
 
--- erlang-14.b.1-dfsg.orig/lib/os_mon/c_src/memsup.c
30
 
+++ erlang-14.b.1-dfsg/lib/os_mon/c_src/memsup.c
 
34
--- erlang-15.b-dfsg.orig/lib/os_mon/c_src/memsup.c
 
35
+++ erlang-15.b-dfsg/lib/os_mon/c_src/memsup.c
31
36
@@ -110,6 +110,11 @@
32
37
 #include <memLib.h>
33
38
 #endif
40
45
 #ifdef BSD4_4
41
46
 #include <sys/types.h>
42
47
 #include <sys/sysctl.h>
 
48
--- erlang-15.b-dfsg.orig/erts/emulator/drivers/common/inet_drv.c
 
49
+++ erlang-15.b-dfsg/erts/emulator/drivers/common/inet_drv.c
 
50
@@ -532,6 +532,11 @@
 
51
         inet_driver_select((d)->port, (ErlDrvEvent)(long)(d)->event, (flags), (onoff)); \
 
52
    } while(0)
 
53
 
 
54
+#ifdef __GNU__
 
55
+#warning "Undefined AF_LINK for GNU/Hurd"
 
56
+#undef AF_LINK
 
57
+#endif
 
58
+
 
59
 
 
60
 #endif /* __WIN32__ */
 
61
 
 
62
--- erlang-15.b-dfsg.orig/erts/etc/common/erlexec.c
 
63
+++ erlang-15.b-dfsg/erts/etc/common/erlexec.c
 
64
@@ -1536,7 +1536,7 @@
 
65
     if (!bindir) {
 
66
        /* Determine bindir from absolute path to executable */
 
67
        char *p;
 
68
-       char buffer[PATH_MAX];
 
69
+       char buffer[MAXPATHLEN];
 
70
        strncpy(buffer, argv[0], sizeof(buffer));
 
71
        buffer[sizeof(buffer)-1] = '\0';
 
72
        
 
73
@@ -1550,7 +1550,7 @@
 
74
     if (!rootdir) {
 
75
        /* Determine rootdir from absolute path to bindir */
 
76
        char *p;
 
77
-       char buffer[PATH_MAX];
 
78
+       char buffer[MAXPATHLEN];
 
79
        strncpy(buffer, bindir, sizeof(buffer));
 
80
        buffer[sizeof(buffer)-1] = '\0';
 
81
        
 
82
--- erlang-15.b-dfsg.orig/erts/etc/common/escript.c
 
83
+++ erlang-15.b-dfsg/erts/etc/common/escript.c
 
84
@@ -53,7 +53,7 @@
 
85
 #  define IS_DIRSEP(c) ((c) == '/')
 
86
 #  define DIRSEPSTR "/"
 
87
 #  define PATHSEPSTR ":"
 
88
-#  define PMAX PATH_MAX
 
89
+#  define PMAX MAXPATHLEN
 
90
 #  define ERL_NAME "erl"
 
91
 #endif
 
92
 
 
93
--- erlang-15.b-dfsg.orig/erts/etc/unix/dyn_erl.c
 
94
+++ erlang-15.b-dfsg/erts/etc/unix/dyn_erl.c
 
95
@@ -149,8 +149,8 @@
 
96
 static char *
 
97
 find_prog(char *origpath)
 
98
 {
 
99
-    char relpath[PATH_MAX];
 
100
-    char abspath[PATH_MAX];
 
101
+    char relpath[MAXPATHLEN];
 
102
+    char abspath[MAXPATHLEN];
 
103
 
 
104
     strcpy(relpath, origpath);
 
105
 
 
106
@@ -161,7 +161,7 @@
 
107
         envpath = get_env("PATH");
 
108
         if (envpath) {
 
109
             /* Try to find the executable in the path */
 
110
-            char dir[PATH_MAX];
 
111
+            char dir[MAXPATHLEN];
 
112
             char *beg = envpath;
 
113
             char *end;
 
114
             int sz;
 
115
@@ -275,7 +275,7 @@
 
116
     /* List install dir and look for latest erts-vsn */
 
117
     DIR *dp;                    /* Pointer to directory structure. */
 
118
     struct dirent* dirp;        /* Pointer to directory entry.     */
 
119
-    char latest_vsn[PATH_MAX];  /* Latest erts-vsn directory name. */
 
120
+    char latest_vsn[MAXPATHLEN];/* Latest erts-vsn directory name. */
 
121
 
 
122
     dp = opendir(erl_top);
 
123
     if (dp == NULL) {
 
124
@@ -315,7 +315,7 @@
 
125
 
 
126
     char *p;
 
127
     char *p2;
 
128
-    char buffer[PATH_MAX];
 
129
+    char buffer[MAXPATHLEN];
 
130
 
 
131
     strcpy(buffer, erlpath);
 
132
 
 
133
@@ -358,9 +358,9 @@
 
134
     char *p;
 
135
     char *abspath;
 
136
     char *bindir;            /* Location of executables. */
 
137
-    char rootdir[PATH_MAX];  /* Root location of Erlang installation. */
 
138
-    char progname[PATH_MAX]; /* Name of this program. */
 
139
-    char erlexec[PATH_MAX];  /* Path to erlexec */
 
140
+    char rootdir[MAXPATHLEN];/* Root location of Erlang installation. */
 
141
+    char progname[MAXPATHLEN];/* Name of this program. */
 
142
+    char erlexec[MAXPATHLEN];/* Path to erlexec */
 
143
 
 
144
     /* Determine progname */
 
145
     abspath = find_prog(argv[0]);