~dannf/ubuntu/saucy/screen/lp1213278-from-debian

« back to all changes in this revision

Viewing changes to debian/patches/03fully_expand_screenencodings.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Martin Pitt
  • Date: 2007-10-23 17:36:30 UTC
  • mto: This revision was merged to the branch mainline in revision 4.
  • Revision ID: james.westby@ubuntu.com-20071023173630-6q4agogsxuzujhwd
Tags: 4.0.3-7ubuntu1
* Merge with Debian; remaining Ubuntu changes:
  - 07_norootpassword.dpatch: When locking a root-owned screen, check that
    root has a password set. If not, ask for an unlocking key. (LP#6760)
  - debian/preinst: Remove obsolete init script 'screen' on
    upgrades. The script is called 'screen-cleanup' in Debian and thus
    should be called the same in Ubuntu to avoid a permanent and pointless
    delta. This needs to be kept until after the next LTS.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 03fully_expand_screenencodings.dpatch by  <hesso@pool.math.tu-berlin.de>
 
3
##
 
4
## DP: SCREENENCODINGS contains ${prefix} from $datadir, which needs
 
5
## DP: an extra expansion step.
 
6
 
 
7
@DPATCH@
 
8
--- screen-4.0.3.orig/configure.in      2007-07-31 13:15:03.000000000 +0200
 
9
+++ screen-4.0.3/configure.in   2007-07-31 13:15:56.000000000 +0200
 
10
@@ -1283,7 +1283,7 @@
 
11
 SCREENENCODINGS="\"/usr/local/lib/screen/utf8encodings\""
 
12
 if test -n "$datadir"; then
 
13
 eval SCREENENCODINGS="$datadir/screen/utf8encodings"
 
14
-SCREENENCODINGS="\"$SCREENENCODINGS\""
 
15
+eval SCREENENCODINGS="\\\"$SCREENENCODINGS\\\""
 
16
 fi
 
17
 AC_MSG_CHECKING(for the utf8-encodings location)
 
18
 AC_DEFINE_UNQUOTED(SCREENENCODINGS,$SCREENENCODINGS)