~dannf/ubuntu/saucy/screen/lp1213278-from-debian

« back to all changes in this revision

Viewing changes to debian/patches/13split_info_files.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Martin Pitt
  • Date: 2007-10-23 17:36:30 UTC
  • mto: This revision was merged to the branch mainline in revision 4.
  • Revision ID: james.westby@ubuntu.com-20071023173630-6q4agogsxuzujhwd
Tags: 4.0.3-7ubuntu1
* Merge with Debian; remaining Ubuntu changes:
  - 07_norootpassword.dpatch: When locking a root-owned screen, check that
    root has a password set. If not, ask for an unlocking key. (LP#6760)
  - debian/preinst: Remove obsolete init script 'screen' on
    upgrades. The script is called 'screen-cleanup' in Debian and thus
    should be called the same in Ubuntu to avoid a permanent and pointless
    delta. This needs to be kept until after the next LTS.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 13split_info_files.dpatch by  <hesso@pool.math.tu-berlin.de>
 
3
##
 
4
## DP: Split the info files at 50k to match the distribution style
 
5
## DP: of the orig tarball.
 
6
 
 
7
@DPATCH@
 
8
--- screen-4.0.3.orig/doc/Makefile.in   2007-07-23 23:32:50.000000000 +0200
 
9
+++ screen-4.0.3/doc/Makefile.in        2007-07-23 23:33:11.000000000 +0200
 
10
@@ -27,7 +27,7 @@
 
11
 
 
12
 info screen.info: screen.texinfo
 
13
        @rm -f screen.info*
 
14
-       $(MAKEINFO) $(srcdir)/screen.texinfo -o screen.info
 
15
+       $(MAKEINFO) --split 50000 $(srcdir)/screen.texinfo -o screen.info
 
16
 
 
17
 install: installdirs
 
18
        $(INSTALL_DATA) $(srcdir)/screen.1 $(DESTDIR)$(mandir)/man1/screen.1