~diwic/ubuntu/lucid/pulseaudio/bugfixes

« back to all changes in this revision

Viewing changes to debian/patches/0003-Define-PULSE_INTERNAL.patch

  • Committer: Bazaar Package Importer
  • Author(s): Luke Yelavich
  • Date: 2008-11-04 15:46:00 UTC
  • mfrom: (1.2.1 upstream) (1.1.6 lenny)
  • Revision ID: james.westby@ubuntu.com-20081104154600-hlzknpcazaam0nxm
Tags: 0.9.13-1ubuntu1
* Merge from Debian unstable, remaining changes:
  - Don't build against, and create jack package. Jack is not in main.
  - Remove --disable-per-user-esound-socket from configure flags, as we still
    want per user esound sockets.
  - Remove stop links from rc0 and rc6.
  - Change default resample algorithm and bubffer size.
  - Add alsa configuration files to route alsa applications via pulseaudio.
  - Move libasound2-plugins from Recommends to Depends.
* debian/pulseaudio.preinst: When upgrading from intrepid, remove
  /etc/X11/Xsession.d/70pulseaudio, as this was used to minimize a race
  condition when starting GNOME in intrepid. This race should not exist in
  jaunty once libcanberra is built to use pulseaudio as a backend.
* Do not spawn a pulseaudio server if clients fail to find a running server.
* Remove explicit version dependency for libspeex-dev to allow the package
  to be built for now.
* Regenerate autotools files to work with Ubuntu's newer libtool/libltdl.
* debian/control: libpulsecore5 -> libpulsecore8 to match the library
  soname.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 7d213f4c7a5328190626b5efdccc45901408650d Mon Sep 17 00:00:00 2001
2
 
From: Sjoerd Simons <sjoerd@luon.net>
3
 
Date: Sun, 27 Apr 2008 21:39:08 +0200
4
 
Subject: [PATCH] Define PULSE_INTERNAL
5
 
 
6
 
---
7
 
 src/daemon/main.c |    1 +
8
 
 1 files changed, 1 insertions(+), 0 deletions(-)
9
 
 
10
 
diff --git a/src/daemon/main.c b/src/daemon/main.c
11
 
index 1e3b358..1b6fe3f 100644
12
 
--- a/src/daemon/main.c
13
 
+++ b/src/daemon/main.c
14
 
@@ -677,6 +677,7 @@ int main(int argc, char *argv[]) {
15
 
 #endif
16
 
     }
17
 
 
18
 
+    set_env("PULSE_INTERNAL", "1");
19
 
     pa_assert_se(chdir("/") == 0);
20
 
     umask(0022);
21