~diwic/ubuntu/lucid/pulseaudio/bugfixes

« back to all changes in this revision

Viewing changes to debian/patches/0007-Perfer-client.conf-over-X11-property-variables.patch

  • Committer: Bazaar Package Importer
  • Author(s): Luke Yelavich
  • Date: 2008-11-04 15:46:00 UTC
  • mfrom: (1.2.1 upstream) (1.1.6 lenny)
  • Revision ID: james.westby@ubuntu.com-20081104154600-hlzknpcazaam0nxm
Tags: 0.9.13-1ubuntu1
* Merge from Debian unstable, remaining changes:
  - Don't build against, and create jack package. Jack is not in main.
  - Remove --disable-per-user-esound-socket from configure flags, as we still
    want per user esound sockets.
  - Remove stop links from rc0 and rc6.
  - Change default resample algorithm and bubffer size.
  - Add alsa configuration files to route alsa applications via pulseaudio.
  - Move libasound2-plugins from Recommends to Depends.
* debian/pulseaudio.preinst: When upgrading from intrepid, remove
  /etc/X11/Xsession.d/70pulseaudio, as this was used to minimize a race
  condition when starting GNOME in intrepid. This race should not exist in
  jaunty once libcanberra is built to use pulseaudio as a backend.
* Do not spawn a pulseaudio server if clients fail to find a running server.
* Remove explicit version dependency for libspeex-dev to allow the package
  to be built for now.
* Regenerate autotools files to work with Ubuntu's newer libtool/libltdl.
* debian/control: libpulsecore5 -> libpulsecore8 to match the library
  soname.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 08cd4f12dfce31abceb617e82caaf76384541d06 Mon Sep 17 00:00:00 2001
2
 
From: Colin Guthrie <pulse@colin.guthr.ie>
3
 
Date: Tue, 3 Jun 2008 19:22:29 +0000
4
 
Subject: [PATCH] Perfer client.conf over X11 property variables.
5
 
 To explain: X11 properties are always set on the root window if pulseaudio is started
6
 
 during X11 login (which is the most likey time to start it). This means that any settings
7
 
 specified in client.conf will almost never be used. As the default client.conf is empty
8
 
 it makes more sense to listen to it if a user cares to bother altering it.
9
 
 
10
 
git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@2494 fefdeb5f-60dc-0310-8127-8f9354f1896f
11
 
---
12
 
 src/pulse/context.c |    2 +-
13
 
 1 files changed, 1 insertions(+), 1 deletions(-)
14
 
 
15
 
diff --git a/src/pulse/context.c b/src/pulse/context.c
16
 
index 7243a29..97432a4 100644
17
 
--- a/src/pulse/context.c
18
 
+++ b/src/pulse/context.c
19
 
@@ -151,10 +151,10 @@ pa_context *pa_context_new(pa_mainloop_api *mainloop, const char *name) {
20
 
 #endif
21
 
 
22
 
     c->conf = pa_client_conf_new();
23
 
-    pa_client_conf_load(c->conf, NULL);
24
 
 #ifdef HAVE_X11
25
 
     pa_client_conf_from_x11(c->conf, NULL);
26
 
 #endif
27
 
+    pa_client_conf_load(c->conf, NULL);
28
 
     pa_client_conf_env(c->conf);
29
 
 
30
 
     if (!(c->mempool = pa_mempool_new(!c->conf->disable_shm))) {
31
 
1.5.6.4
32