~kklimonda/ubuntu/natty/hamster-applet/lp.697667

« back to all changes in this revision

Viewing changes to debian/patches/01_startup-fix.patch

  • Committer: Bazaar Package Importer
  • Author(s): Chris Coulson
  • Date: 2010-02-10 02:52:31 UTC
  • mfrom: (1.1.14 upstream)
  • Revision ID: james.westby@ubuntu.com-20100210025231-x0q5h4q7nlvihl09
Tags: 2.29.90-0ubuntu1
* New upstream version
  - workspace tracking - switch activity, when switching desktops
  - chart improvements - theme friendly and less noisier
  - for those without GNOME panel there is now a standalone version, 
    accessible via Applications -> Accessories -> Time Tracker
  - overview window remembers position
  - maintaining cursor on the selected row after edits / refreshes
  - descriptions once again in the main input field, delimited by comma
  - activity suggestion box now sorts items by recency (Patryk Zawadzki)
  - searching
  - simplified save report dialog, thanks to the what you see is what you 
    report revamp
  - overview/stats replaced with activities / totals and stats accessible 
    from totals
  - interactive graphs to drill down in totals
  - miscellaneous performance improvements
  - pixel-perfect graphs
* Updated 01_startup-fix.patch to apply to new source layout
* debian/control:
  - Add build-depend on gnome-doc-utils

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
Remove path checks, they prevent applet from starting
2
2
 
3
 
diff -Nur -x '*.orig' -x '*~' hamster-applet-2.28.0/hamster/configuration.py hamster-applet-2.28.0.new/hamster/configuration.py
4
 
--- hamster-applet-2.28.0/hamster/configuration.py      2009-09-01 11:32:49.000000000 +0200
5
 
+++ hamster-applet-2.28.0.new/hamster/configuration.py  2009-10-01 22:47:50.000000000 +0200
6
 
@@ -44,10 +44,8 @@
 
3
diff -Nur -x '*.orig' -x '*~' hamster-applet-2.29.90/src/hamster/configuration.py hamster-applet-2.29.90.new/src/hamster/configuration.py
 
4
--- hamster-applet-2.29.90/src/hamster/configuration.py 2010-02-02 09:00:01.000000000 +0000
 
5
+++ hamster-applet-2.29.90.new/src/hamster/configuration.py     2010-02-10 02:44:46.202601207 +0000
 
6
@@ -59,10 +59,7 @@
7
7
         gettext.install("hamster-applet", unicode = True)
8
8
 
9
9
         # Typically shared data dir is /usr/share/hamster-applet
10
10
-        if os.path.realpath(__file__).startswith(defs.PYTHONDIR):
11
11
-            data_dir = os.path.join(defs.DATA_DIR, "hamster-applet")
12
12
-        else:
13
 
-            data_dir = os.path.realpath(os.path.join(os.path.dirname(__file__), '..', 'data'))
14
 
+        data_dir = os.path.join(defs.DATA_DIR, "hamster-applet")
15
 
+
 
13
-            data_dir = os.path.realpath(os.path.join(os.path.dirname(__file__), '..', '..', 'data'))
 
14
+       data_dir = os.path.join(defs.DATA_DIR, "hamster-applet")
16
15
         self.data_dir = data_dir
17
16
         self.dispatcher = Dispatcher()
18
17
         self.storage = Storage(self.dispatcher)