~rdoering/ubuntu/intrepid/erlang/fix-535090

« back to all changes in this revision

Viewing changes to debian/patches/30kfreebsd.diff

  • Committer: Bazaar Package Importer
  • Author(s): Soren Hansen
  • Date: 2007-05-01 16:57:10 UTC
  • mfrom: (1.1.9 upstream)
  • Revision ID: james.westby@ubuntu.com-20070501165710-2sapk0hp2gf3o0ip
Tags: 1:11.b.4-2ubuntu1
* Merge with Debian Unstable. Remaining changes:
  - Add -fno-stack-protector to fix broken crypto_drv.
* DebianMaintainerField update.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
30kfreebsd.diff by Aurelien Jarno <aurel32@debian.org>
 
2
 
 
3
Defines GNU macros not only for Linux but also for any system
 
4
with 'gnu' substring in OS name. Fixes FTBFS on GNU/kfreebsd.
 
5
 
 
6
Index: erlang/erts/configure.in
 
7
=====================================================================
 
8
--- erlang.orig/erts/configure.in
 
9
+++ erlang/erts/configure.in
 
10
@@ -202,7 +202,7 @@
 
11
 
 
12
 dnl NOTE: CPPFLAGS will be included in CFLAGS at the end
 
13
 case $host_os in
 
14
-    linux*) CPPFLAGS="$CPPFLAGS -D_GNU_SOURCE";; 
 
15
+    linux*|*gnu*) CPPFLAGS="$CPPFLAGS -D_GNU_SOURCE";; 
 
16
     *) ;;
 
17
 esac
 
18
 
 
19
@@ -725,7 +725,7 @@
 
20
            solaris*)
 
21
                enable_child_waiter_thread=yes
 
22
                ;;
 
23
-           linux*)
 
24
+           linux*|*gnu*)
 
25
                AC_DEFINE(USE_RECURSIVE_MALLOC_MUTEX,[1],
 
26
                        [Define if malloc should use a recursive mutex])
 
27
                # -D_GNU_SOURCE already defined in CFLAGS remove it