~rdoering/ubuntu/intrepid/erlang/fix-535090

« back to all changes in this revision

Viewing changes to debian/patches/50odbc.diff

  • Committer: Bazaar Package Importer
  • Author(s): Soren Hansen
  • Date: 2007-05-01 16:57:10 UTC
  • mfrom: (1.1.9 upstream)
  • Revision ID: james.westby@ubuntu.com-20070501165710-2sapk0hp2gf3o0ip
Tags: 1:11.b.4-2ubuntu1
* Merge with Debian Unstable. Remaining changes:
  - Add -fno-stack-protector to fix broken crypto_drv.
* DebianMaintainerField update.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
50odbc.diff by Sergei Golovan <sgolovan@nes.ru>
 
2
 
 
3
Patch makes odbc driver build on 64-bit platforms.
 
4
See http://www.erlang.org/ml-archive/erlang-questions/200605/msg00072.html
 
5
 
 
6
Index: erlang/lib/odbc/c_src/Makefile.in
 
7
=====================================================================
 
8
--- erlang.orig/lib/odbc/c_src/Makefile.in
 
9
+++ erlang/lib/odbc/c_src/Makefile.in
 
10
@@ -57,11 +57,9 @@
 
11
 WIN32_TARGET = $(WIN_BIN_DIR)/odbcserver.exe
 
12
 EXE_TARGET = $(WIN32_TARGET)
 
13
 else
 
14
-ifneq ($(BITS64),yes)
 
15
 EI_LIB = -lerl_interface -lei
 
16
 UNIX_TARGET = $(BIN_DIR)/odbcserver
 
17
 EXE_TARGET = $(UNIX_TARGET)
 
18
-endif
 
19
 endif
 
20
 
 
21
 C_FILES = odbcserver.c