~rdoering/ubuntu/karmic/erlang/fix-535090

« back to all changes in this revision

Viewing changes to debian/patches/30kfreebsd.diff

  • Committer: Bazaar Package Importer
  • Author(s): Luca Falavigna
  • Date: 2008-11-04 22:26:12 UTC
  • mfrom: (3.1.1 lenny)
  • Revision ID: james.westby@ubuntu.com-20081104222612-1uwzavuet6ar35fw
Tags: 1:12.b.3-dfsg-4ubuntu1
* Merge from Debian unstable, remaining Ubuntu changes:
  + debian/patches/glibc2.8_compatibility.patch:
    - Fix FTBFS with new glibc.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
30kfreebsd.diff by Aurelien Jarno <aurel32@debian.org>
2
 
and Sergei Golovan <sgolovan@debian.org>
3
 
 
4
 
Defines GNU macros not only for Linux but also for any system
5
 
with 'gnu' substring in OS name. Fixes FTBFS on GNU/kfreebsd.
6
 
 
7
 
Also, allows to build erlang regexp driver for common_test application.
8
 
 
9
 
--- erlang-12.b.3-dfsg.orig/erts/configure.in
10
 
+++ erlang-12.b.3-dfsg/erts/configure.in
11
 
@@ -275,7 +275,7 @@
12
 
 
13
 
 dnl NOTE: CPPFLAGS will be included in CFLAGS at the end
14
 
 case $host_os in
15
 
-    linux*) CPPFLAGS="$CPPFLAGS -D_GNU_SOURCE";; 
16
 
+    linux*|*gnu*) CPPFLAGS="$CPPFLAGS -D_GNU_SOURCE";; 
17
 
     win32)
18
 
        # The ethread library requires _WIN32_WINNT of at least 0x0403.
19
 
        # -D_WIN32_WINNT=* from CPPFLAGS is saved in ETHR_DEFS.
20
 
@@ -858,7 +858,7 @@
21
 
            solaris*)
22
 
                enable_child_waiter_thread=yes
23
 
                ;;
24
 
-           linux*)
25
 
+           linux*|*gnu*)
26
 
                AC_DEFINE(USE_RECURSIVE_MALLOC_MUTEX,[1],
27
 
                        [Define if malloc should use a recursive mutex])
28
 
                AC_MSG_CHECKING([whether dlopen() needs to be called before first call to dlerror()])
29
 
--- erlang-12.b.3-dfsg.orig/lib/common_test/Makefile
30
 
+++ erlang-12.b.3-dfsg/lib/common_test/Makefile
31
 
@@ -28,9 +28,13 @@
32
 
 ifeq ($(findstring solaris,$(TARGET)),solaris)
33
 
 SUB_DIRECTORIES = doc/src src c_src priv
34
 
 else
35
 
+ifeq ($(findstring kfreebsd,$(TARGET)),kfreebsd)
36
 
+SUB_DIRECTORIES = doc/src src c_src priv
37
 
+else
38
 
 SUB_DIRECTORIES = doc/src src priv
39
 
 endif
40
 
 endif
41
 
+endif
42
 
 
43
 
 include vsn.mk
44
 
 VSN = $(COMMON_TEST_VSN)
45
 
--- erlang-12.b.3-dfsg.orig/lib/common_test/priv/Makefile.in
46
 
+++ erlang-12.b.3-dfsg/lib/common_test/priv/Makefile.in
47
 
@@ -42,9 +42,13 @@
48
 
 ifeq ($(findstring solaris,$(TARGET)),solaris)
49
 
 XNIX = true
50
 
 else
51
 
+ifeq ($(findstring kfreebsd,$(TARGET)),kfreebsd)
52
 
+XNIX = true
53
 
+else
54
 
 XNIX = false
55
 
 endif
56
 
 endif
57
 
+endif
58
 
 
59
 
 ifneq ($(findstring win32,$(TARGET)),win32)
60