~rdoering/ubuntu/karmic/erlang/fix-535090

« back to all changes in this revision

Viewing changes to debian/patches/hurd.diff

  • Committer: Bazaar Package Importer
  • Author(s): Luca Falavigna
  • Date: 2008-11-04 22:26:12 UTC
  • mfrom: (3.1.1 lenny)
  • Revision ID: james.westby@ubuntu.com-20081104222612-1uwzavuet6ar35fw
Tags: 1:12.b.3-dfsg-4ubuntu1
* Merge from Debian unstable, remaining Ubuntu changes:
  + debian/patches/glibc2.8_compatibility.patch:
    - Fix FTBFS with new glibc.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
hurd.diff by Sergei Golovan <sgolovan@debian.org>
2
 
 
3
 
Patch helps to build erlang on hurd-i386 architecture.
4
 
 
5
 
To do that it:
6
 
  (1) allows to build erlang regexp driver for common_test application;
7
 
  (2) undefines BSD4_4 for os_mon application;
8
 
  (3) skips building SSL certificate examples (Debian GNU Hurd has no
9
 
      a random translator yet).
10
 
 
11
 
--- erlang-12.b.3-dfsg.orig/lib/common_test/Makefile
12
 
+++ erlang-12.b.3-dfsg/lib/common_test/Makefile
13
 
@@ -31,10 +31,14 @@
14
 
 ifeq ($(findstring kfreebsd,$(TARGET)),kfreebsd)
15
 
 SUB_DIRECTORIES = doc/src src c_src priv
16
 
 else
17
 
+ifeq ($(findstring gnu0.3,$(TARGET)),gnu0.3)
18
 
+SUB_DIRECTORIES = doc/src src c_src priv
19
 
+else
20
 
 SUB_DIRECTORIES = doc/src src priv
21
 
 endif
22
 
 endif
23
 
 endif
24
 
+endif
25
 
 
26
 
 include vsn.mk
27
 
 VSN = $(COMMON_TEST_VSN)
28
 
--- erlang-12.b.3-dfsg.orig/lib/common_test/priv/Makefile.in
29
 
+++ erlang-12.b.3-dfsg/lib/common_test/priv/Makefile.in
30
 
@@ -45,10 +45,14 @@
31
 
 ifeq ($(findstring kfreebsd,$(TARGET)),kfreebsd)
32
 
 XNIX = true
33
 
 else
34
 
+ifeq ($(findstring gnu0.3,$(TARGET)),gnu0.3)
35
 
+XNIX = true
36
 
+else
37
 
 XNIX = false
38
 
 endif
39
 
 endif
40
 
 endif
41
 
+endif
42
 
 
43
 
 ifneq ($(findstring win32,$(TARGET)),win32)
44
 
 
45
 
--- erlang-12.b.3-dfsg.orig/lib/os_mon/c_src/memsup.c
46
 
+++ erlang-12.b.3-dfsg/lib/os_mon/c_src/memsup.c
47
 
@@ -95,6 +95,11 @@
48
 
 #include <memLib.h>
49
 
 #endif
50
 
 
51
 
+#ifdef __GNU__
52
 
+#warning "Undefined BSD4_4 for GNU Hurd"
53
 
+#undef BSD4_4
54
 
+#endif
55
 
+
56
 
 #ifdef BSD4_4
57
 
 #include <sys/types.h>
58
 
 #include <sys/sysctl.h>
59
 
--- erlang-12.b.3-dfsg.orig/lib/ssl/Makefile
60
 
+++ erlang-12.b.3-dfsg/lib/ssl/Makefile
61
 
@@ -29,8 +29,15 @@
62
 
 SKIP_BUILDING_BINARIES := true
63
 
 endif
64
 
 else
65
 
+ifeq ($(HOST_OS),)
66
 
+HOST_OS := $(shell $(ERL_TOP)/erts/autoconf/config.guess)
67
 
+endif
68
 
+ifeq ($(findstring gnu0.3,$(HOST_OS)),gnu0.3)
69
 
+SKIP_BUILDING_BINARIES := true
70
 
+else
71
 
 SKIP_BUILDING_BINARIES := false
72
 
 endif
73
 
+endif
74
 
 
75
 
 ifeq ($(SKIP_BUILDING_BINARIES), true)
76
 
 SUB_DIRECTORIES = pkix src c_src doc/src