~rdoering/ubuntu/karmic/erlang/fix-535090

« back to all changes in this revision

Viewing changes to debian/patches/native.patch

  • Committer: Bazaar Package Importer
  • Author(s): Luca Falavigna
  • Date: 2008-11-04 22:26:12 UTC
  • mfrom: (3.1.1 lenny)
  • Revision ID: james.westby@ubuntu.com-20081104222612-1uwzavuet6ar35fw
Tags: 1:12.b.3-dfsg-4ubuntu1
* Merge from Debian unstable, remaining Ubuntu changes:
  + debian/patches/glibc2.8_compatibility.patch:
    - Fix FTBFS with new glibc.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
native.patch by Sergei Golovan <sgolovan@debian.org>
 
2
 
 
3
Adds native code to all Erlang binaries if HiPE is enabled.
 
4
 
 
5
--- erlang-12.b.3-dfsg.orig/make/otp.mk.in
 
6
+++ erlang-12.b.3-dfsg/make/otp.mk.in
 
7
@@ -66,6 +66,11 @@
 
8
       ERL_COMPILE_FLAGS += +slim
 
9
     else
 
10
       ERL_COMPILE_FLAGS += +debug_info
 
11
+      ifeq ($(HIPE_ENABLED),yes)
 
12
+        ifeq ($(BUILD_ALL),true)
 
13
+          ERL_COMPILE_FLAGS += +native
 
14
+        endif
 
15
+      endif
 
16
     endif
 
17
   endif
 
18
 endif