~ubuntu-branches/debian/jessie/sane-backends/jessie

« back to all changes in this revision

Viewing changes to debian/patches/fix_v4l_build.patch

  • Committer: Package Import Robot
  • Author(s): Markus Koschany
  • Date: 2013-07-04 17:41:47 UTC
  • mfrom: (1.1.13)
  • Revision ID: package-import@ubuntu.com-20130704174147-tl5tzd8bwvmctka2
Tags: 1.0.23-1
* QA upload.
* New upstream release.
* This package has been orphaned. Set maintainer to the Debian QA Group.
* Bump compat level to 9 (was 5) and require debhelper >= 9.
* debian/control:
  - sane-utils: Inherit Section: graphics from source package sane-backends.
  - Remove versioned dependencies. They are trivially satisfied.
* Drop the following patches. They are merged upstream now.
  - fix_v4l_build.patch
  - hurd_path_max_fix.patch
  - sane_desc_udev+acl.patch
  - scanimage_man_batch_start.patch
  - udev_usb_suspend.patch
  - xerox_mfp_add_scx_4623fw.patch
  - xerox_mfp_fix_usb_device.patch
* Drop disable_rpath.patch because the RPATH is already removed by chrpath
  in debian/rules.
* Rebase and refresh all other patches against the new upstream relase.
* debian/rules:
  - Simplify debian/rules by using dh sequencer.
  - Build with --parallel and with autotools_dev.
  - Enable all hardening build flags.
  - Install umax_pp with sane-utils.install.
* Build-Depend on libtiff5-dev. Thanks to Michael Terry for the patch.
  (Closes: #681079)
* Build-Depend on libusb-1.0-0-dev and enable libusb1.0 support in
  debian/rules. Thanks to Martin Pitt for the report and Whoopie for the
  patch. (Closes: #687137)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
commit c5ca46c2d1be78c651afb843cc834cf2b5b24953
2
 
Author: Julien BLACHE <jb@jblache.org>
3
 
Date:   Wed Feb 16 19:37:43 2011 +0100
4
 
 
5
 
    Fix v4l build with libv4l 0.8.3+
6
 
 
7
 
Index: sane-backends-1.0.22/backend/v4l.c
8
 
===================================================================
9
 
--- sane-backends-1.0.22.orig/backend/v4l.c     2011-02-16 19:20:51.193016002 +0100
10
 
+++ sane-backends-1.0.22/backend/v4l.c  2011-02-16 19:21:00.497016002 +0100
11
 
@@ -84,9 +84,8 @@
12
 
 #include "../include/sane/sanei_config.h"
13
 
 #define V4L_CONFIG_FILE "v4l.conf"
14
 
 
15
 
-#include "v4l.h"
16
 
-
17
 
 #include <libv4l1.h>
18
 
+#include "v4l.h"
19
 
 
20
 
 static const SANE_Device **devlist = NULL;
21
 
 static int num_devices;
22
 
Index: sane-backends-1.0.22/backend/v4l.h
23
 
===================================================================
24
 
--- sane-backends-1.0.22.orig/backend/v4l.h     2011-02-16 19:20:07.537016001 +0100
25
 
+++ sane-backends-1.0.22/backend/v4l.h  2011-02-16 19:20:41.889016001 +0100
26
 
@@ -29,6 +29,7 @@
27
 
 #ifndef v4l_h
28
 
 #define v4l_h
29
 
 
30
 
+#ifndef __LINUX_VIDEODEV_H
31
 
 /* Kernel interface */
32
 
 /* Only the stuff we need. For more features, more defines are needed */
33
 
 
34
 
@@ -165,7 +166,7 @@
35
 
 
36
 
 
37
 
 /* end of kernel interface */
38
 
-
39
 
+#endif /* !__LINUX_VIDEODEV_H */
40
 
 
41
 
 #include <../include/sane/sane.h>
42