~ubuntu-branches/debian/sid/f-spot/sid

« back to all changes in this revision

Viewing changes to debian/patches/git_transition_duration.patch

  • Committer: Bazaar Package Importer
  • Author(s): Iain Lane
  • Date: 2010-05-17 11:59:58 UTC
  • mfrom: (2.4.6 sid)
  • Revision ID: james.westby@ubuntu.com-20100517115958-rplbws9ddda5ikcp
* New upstream release 0.6.2:
 + Stable release before starting large cleanup refactorings, mostly 
   usability, bug fixes and translations as well as some modernization.
   A large part of this comes from the Ubuntu one hundred papercuts effort.
 + Replaced the old slow slideshow code with new fast SlideShow
   (Gabriel Burt)
 + Wording changes for clarity (Edit Tag) (Jeffrey Finkelstein)
 + Fix version selection tooltip (Lorenzo Milesi)
 + Add gconf schema (Jeffrey Stedfast)
 + Added a border to filmstrip thumbnails (Matt Perry) (LP: #513036)
 + Fix display names of color profiles (Pascal de Bruijn)
 + Fix histogram colors on theme change (Paul Wellner Bou)
 + Always update ImageView adjustments when scaling.
   (Wojciech Dzierżanowski)
 + Correctly set attributes on copying (Yann Leprince)
 + Correct mnemonics in create tag dialog (Yves Kurz)
 + Provide sane defaults for image resize size (Yves Kurz)
 + Updates to the build system, including fixes for distcheck
   (Ruben Vermeersch)
 + Fix wording for duplicate hashing (Matt Perry)
 + Fix wording for imported tags tag (Ian Churcher)
 + Fix label alignment in preferences dialog (Pascal de Bruijn)
 + Add unique# and use it to handle our activation (Stephane Delcroix)
 + Stop bundling Mono.Addins (Stephane Delcroix)
 + Avoid leakage in straighten and softfocus editor (Stephane Delcroix)
 + Allow to copy files to clipboard (Stephane Delcroix)
 + Large number of color management related fixes (Stephane Delcroix)
 + Removed the Beagle plugin at the request of the openSUSE team
   (Ruben Vermeersch)
 + A pile of other cleanups and fixes (Ruben Vermeersch)
   - Including '"Import tags" category sounds like an action' (LP: #488784)
 + Two performance improvement patches for our database interaction
   (Michal Nánási)
 + Fix the longstanding issue of F-Spot changing photo timestamps
   (Paul Wellner Bou) (Closes: #445511) (LP: #175191)
 + Tons of translation updates (seriously)
* debian/control, debian/rules: Drop gnome-screensaver build-dep and set
  variables at configure time. Should reduce the BD chain significantly. 
* debian/control: Increase minimum version on libgphoto2-dev BD in line with
  configure requirements.
* debian/control: Add build-dependency on libunique-dev to build new
  unique-sharp bindings which f-spot now uses to handle activation.
* debian/patches/debian_link-system-mono-addins.patch: Drop, now upstream 
* debian/patches/*: Refresh to apply to new upstream version 
* debian/rules: Pass include directories to autoreconf to have the correct
  macros in scope for the new build system 
* debian/patches/ubuntu*: Steal patches from Ubuntu package to improve
  --view mode and add an undo/redo stack. Rebase on new upstream version.
  Thanks to Chris Halse Rogers.
* debian/patches/ubuntu_fname_quote_percent.patch: Drop, now upstream.
* debian/patches/git_transition_duration.patch: Cherrypick patch from
  upstream to reduce the transition duration when entering fullscreen to
  600ms. 
* debian/rules: Incorporate Ubuntu specific changes, and guard by a call to
  dpkg-vendor.
* debian/rules: Don't try to install the gconf schemas when building 

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 0d705371f388410d62172e1413c060d8629ac0f6 Mon Sep 17 00:00:00 2001
 
2
From: Iain Lane <laney@ubuntu.com>
 
3
Date: Tue, 09 Mar 2010 19:36:20 +0000
 
4
Subject: Fix for bgo#608216
 
5
 
 
6
src/Fader.cs: Change the constructor for the fader to accept a double
 
7
              representing the number of milliseconds to fade for,
 
8
                          instead of the number of seconds.
 
9
 
 
10
src/FullScreenView.cs: Change the timeout for entering full screen view to 600ms.
 
11
---
 
12
Index: f-spot.git/src/Fader.cs
 
13
===================================================================
 
14
--- f-spot.git.orig/src/Fader.cs        2010-05-19 15:18:08.036710007 +0100
 
15
+++ f-spot.git/src/Fader.cs     2010-05-19 15:49:45.186710570 +0100
 
16
@@ -21,12 +21,12 @@
 
17
                double target_opacity;
 
18
                DoubleAnimation fadin;
 
19
 
 
20
-               public Fader (Gtk.Window win, double target, int sec)
 
21
+               public Fader (Gtk.Window win, double target, double msec)
 
22
                {
 
23
                        this.win = win;
 
24
                        win.Mapped += HandleMapped;
 
25
                        win.Unmapped += HandleUnmapped;
 
26
-                       fadin = new DoubleAnimation (0.0, target, new TimeSpan (0, 0, sec), delegate (double opacity) {
 
27
+                       fadin = new DoubleAnimation (0.0, target, TimeSpan.FromMilliseconds(msec), delegate (double opacity) {
 
28
                                CompositeUtils.SetWinOpacity (win, opacity);
 
29
                        });     
 
30
                }
 
31
Index: f-spot.git/src/FullScreenView.cs
 
32
===================================================================
 
33
--- f-spot.git.orig/src/FullScreenView.cs       2010-05-19 15:18:08.056710820 +0100
 
34
+++ f-spot.git/src/FullScreenView.cs    2010-05-19 15:49:45.186710570 +0100
 
35
@@ -85,7 +85,7 @@
 
36
                                slide_show.Activated += SlideShowAction;
 
37
                                actions.Add (slide_show);
 
38
 
 
39
-                               new Fader (this, 1.0, 3);
 
40
+                               new Fader (this, 1.0, 600);
 
41
                                notebook = new Notebook ();
 
42
                                notebook.ShowBorder = false;
 
43
                                notebook.ShowTabs = false;