~ubuntu-branches/debian/sid/f-spot/sid

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu_add_other_files_in_directory_in_view_mode.patch

  • Committer: Bazaar Package Importer
  • Author(s): Iain Lane
  • Date: 2010-05-17 11:59:58 UTC
  • mfrom: (2.4.6 sid)
  • Revision ID: james.westby@ubuntu.com-20100517115958-rplbws9ddda5ikcp
* New upstream release 0.6.2:
 + Stable release before starting large cleanup refactorings, mostly 
   usability, bug fixes and translations as well as some modernization.
   A large part of this comes from the Ubuntu one hundred papercuts effort.
 + Replaced the old slow slideshow code with new fast SlideShow
   (Gabriel Burt)
 + Wording changes for clarity (Edit Tag) (Jeffrey Finkelstein)
 + Fix version selection tooltip (Lorenzo Milesi)
 + Add gconf schema (Jeffrey Stedfast)
 + Added a border to filmstrip thumbnails (Matt Perry) (LP: #513036)
 + Fix display names of color profiles (Pascal de Bruijn)
 + Fix histogram colors on theme change (Paul Wellner Bou)
 + Always update ImageView adjustments when scaling.
   (Wojciech Dzierżanowski)
 + Correctly set attributes on copying (Yann Leprince)
 + Correct mnemonics in create tag dialog (Yves Kurz)
 + Provide sane defaults for image resize size (Yves Kurz)
 + Updates to the build system, including fixes for distcheck
   (Ruben Vermeersch)
 + Fix wording for duplicate hashing (Matt Perry)
 + Fix wording for imported tags tag (Ian Churcher)
 + Fix label alignment in preferences dialog (Pascal de Bruijn)
 + Add unique# and use it to handle our activation (Stephane Delcroix)
 + Stop bundling Mono.Addins (Stephane Delcroix)
 + Avoid leakage in straighten and softfocus editor (Stephane Delcroix)
 + Allow to copy files to clipboard (Stephane Delcroix)
 + Large number of color management related fixes (Stephane Delcroix)
 + Removed the Beagle plugin at the request of the openSUSE team
   (Ruben Vermeersch)
 + A pile of other cleanups and fixes (Ruben Vermeersch)
   - Including '"Import tags" category sounds like an action' (LP: #488784)
 + Two performance improvement patches for our database interaction
   (Michal Nánási)
 + Fix the longstanding issue of F-Spot changing photo timestamps
   (Paul Wellner Bou) (Closes: #445511) (LP: #175191)
 + Tons of translation updates (seriously)
* debian/control, debian/rules: Drop gnome-screensaver build-dep and set
  variables at configure time. Should reduce the BD chain significantly. 
* debian/control: Increase minimum version on libgphoto2-dev BD in line with
  configure requirements.
* debian/control: Add build-dependency on libunique-dev to build new
  unique-sharp bindings which f-spot now uses to handle activation.
* debian/patches/debian_link-system-mono-addins.patch: Drop, now upstream 
* debian/patches/*: Refresh to apply to new upstream version 
* debian/rules: Pass include directories to autoreconf to have the correct
  macros in scope for the new build system 
* debian/patches/ubuntu*: Steal patches from Ubuntu package to improve
  --view mode and add an undo/redo stack. Rebase on new upstream version.
  Thanks to Chris Halse Rogers.
* debian/patches/ubuntu_fname_quote_percent.patch: Drop, now upstream.
* debian/patches/git_transition_duration.patch: Cherrypick patch from
  upstream to reduce the transition duration when entering fullscreen to
  600ms. 
* debian/rules: Incorporate Ubuntu specific changes, and guard by a call to
  dpkg-vendor.
* debian/rules: Don't try to install the gconf schemas when building 

Show diffs side-by-side

added added

removed removed

Lines of Context:
5
5
Bug-LP: https://bugs.edge.launchpad.net/ubuntu/+source/f-spot/+bug/484887
6
6
Bug: https://bugzilla.gnome.org/show_bug.cgi?id=333189
7
7
 
8
 
Index: f-spot-0.6.1.5/src/SingleView.cs
 
8
Index: f-spot.git/src/SingleView.cs
9
9
===================================================================
10
 
--- f-spot-0.6.1.5.orig/src/SingleView.cs       2010-03-18 10:21:52.944271424 +1100
11
 
+++ f-spot-0.6.1.5/src/SingleView.cs    2010-03-18 10:22:14.234260906 +1100
12
 
@@ -59,6 +59,8 @@
 
10
--- f-spot.git.orig/src/SingleView.cs   2010-05-19 14:28:58.147959007 +0100
 
11
+++ f-spot.git/src/SingleView.cs        2010-05-19 14:28:58.167959093 +0100
 
12
@@ -60,6 +60,8 @@
13
13
                UndoCache undo_history;
14
14
                
15
15
                FullScreenView fsview;
18
18
 
19
19
                private static Gtk.Tooltips toolTips = new Gtk.Tooltips ();
20
20
 
21
 
@@ -82,28 +84,53 @@
 
21
@@ -68,28 +70,53 @@
22
22
                        string glade_name = "single_view";
23
23
                        this.uri = uris[0];
24
24
                        
78
78
                        StockItem undo_info = Stock.Lookup (Stock.Undo);
79
79
                        undo = new ToolButton (undo_info.StockId);
80
80
                        undo.Label = undo_info.Label;
81
 
@@ -118,7 +145,7 @@
 
81
@@ -104,7 +131,7 @@
82
82
                        fs_button.Clicked += HandleViewFullscreen;
83
83
                        fs_button.SetTooltip (toolTips, Catalog.GetString ("View photos fullscreen"), null);
84
84
                        toolbar.Insert (fs_button, -1);
87
87
                        ToolButton ss_button = GtkUtil.ToolButtonFromTheme ("media-playback-start", Catalog.GetString ("Slideshow"), true);
88
88
                        ss_button.Clicked += HandleViewSlideshow;
89
89
                        ss_button.SetTooltip (toolTips, Catalog.GetString ("View photos in a slideshow"), null);
90
 
@@ -143,9 +170,10 @@
 
90
@@ -129,9 +156,10 @@
91
91
                        toolbar.Insert (next_image, -1);
92
92
                        next_image.TooltipText = Catalog.GetString ("Next photo");
93
93
                        next_image.Clicked += (sender, args) => { image_view.Item.MoveNext (); };
100
100
                        undo_history = new UndoCache ();
101
101
                        undo_history.UndoStateChanged += HandleUndoStateChanged;
102
102
 
103
 
@@ -201,7 +229,7 @@
 
103
@@ -187,7 +215,7 @@
104
104
                        
105
105
                        Window.ShowAll ();
106
106
 
109
109
                        sidebar.Context = ViewContext.Single;
110
110
 
111
111
                        zoom_scale.ValueChanged += HandleZoomScaleValueChanged;
112
 
@@ -237,14 +265,119 @@
 
112
@@ -223,14 +251,119 @@
113
113
                        UpdateStatusLabel ();
114
114
                        UpdateToolbar (image_view.Item.Collection);
115
115
                        
231
231
                void ToggleFilmstrip (bool enabled)
232
232
                {
233
233
                        Gtk.Widget packed_filmstrip = display_vbox.AllChildren.Cast<Gtk.Widget> ().FirstOrDefault ((widget) => {return widget == filmstrip;});
234
 
Index: f-spot-0.6.1.5/src/UriCollection.cs
 
234
Index: f-spot.git/src/UriCollection.cs
235
235
===================================================================
236
 
--- f-spot-0.6.1.5.orig/src/UriCollection.cs    2010-03-18 10:17:41.546760090 +1100
237
 
+++ f-spot-0.6.1.5/src/UriCollection.cs 2010-03-18 10:21:55.324260046 +1100
 
236
--- f-spot.git.orig/src/UriCollection.cs        2010-05-19 13:49:44.436739359 +0100
 
237
+++ f-spot.git/src/UriCollection.cs     2010-05-19 14:28:58.167959093 +0100
238
238
@@ -21,25 +21,31 @@
239
239
 
240
240
 namespace FSpot {