~ubuntu-branches/debian/sid/mafft/sid

« back to all changes in this revision

Viewing changes to debian/patches/20_manpages_are_no_binaries.patch

  • Committer: Bazaar Package Importer
  • Author(s): Andreas Tille
  • Date: 2011-03-12 00:02:43 UTC
  • mfrom: (1.1.7 upstream)
  • Revision ID: james.westby@ubuntu.com-20110312000243-1yx6ho40e2kf9nxw
Tags: 6.850-1
* New upstream version
* Adapted patch to new upstream
* Debhelper 8 (control + compat)
* debian/rules: Switch to dh
* debian/links: override broken symlinks created in Makefile

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Author: Andreas Tille <tille@debian.org>
2
 
Description: Prevent upstream Makefile from handling manpages as binaries
3
 
--- mafft-6.713-without-extensions.orig/core/Makefile
4
 
+++ mafft-6.713-without-extensions/core/Makefile
5
 
@@ -107,7 +107,7 @@
6
 
 all : $(PROGS) $(SCRIPTS)
7
 
        cp $(SCRIPTS) ../scripts
 
1
--- mafft-6.850-without-extensions.orig/core/Makefile
 
2
+++ mafft-6.850-without-extensions/core/Makefile
 
3
@@ -113,7 +113,6 @@
8
4
        chmod 755 ../scripts/*
9
 
-       cp $(PROGS) $(MANPAGES) ../binaries
10
 
+       cp $(PROGS) ../binaries
 
5
        cp $(PROGS) ../binaries
11
6
        chmod 755 ../binaries/*
 
7
-       cp $(MANPAGES) ../binaries
12
8
        @echo done.
13
9
 
14
 
@@ -484,7 +484,7 @@
15
 
        chmod 755 $(SCRIPTS)
 
10
 univscript: univscript.tmpl Makefile
 
11
@@ -490,7 +489,6 @@
16
12
        $(INSTALL) $(SCRIPTS)  $(BINDIR)
17
13
        chmod 755 $(PROGS)
18
 
-       $(INSTALL) $(PROGS) $(MANPAGES) $(LIBDIR)
19
 
+       $(INSTALL) $(PROGS) $(LIBDIR)
 
14
        $(INSTALL) $(PROGS) $(LIBDIR)
 
15
-       $(INSTALL) --mode=644 $(MANPAGES) $(LIBDIR)
 
16
 
20
17
        ( cd $(BINDIR); \
21
18
 rm -f linsi ginsi einsi fftns fftnsi nwns nwnsi xinsi qinsi; \
22
 
 rm -f mafft-linsi mafft-ginsi mafft-einsi mafft-fftns mafft-fftnsi mafft-nwns mafft-nwnsi mafft-xinsi mafft-qinsi; \
23
 
@@ -499,4 +499,4 @@
24
 
 
25
 
        mkdir -p $(MANDIR)
26
 
        chmod 755 $(MANDIR)
27
 
-       $(INSTALL) $(MANPAGES) $(MANDIR)
28
 
+       $(INSTALL) --mode=644 $(MANPAGES) $(MANDIR)