~ubuntu-branches/debian/squeeze/boa-constructor/squeeze

« back to all changes in this revision

Viewing changes to debian/patches/maxint

  • Committer: Bazaar Package Importer
  • Author(s): Luca Falavigna
  • Date: 2009-08-27 19:17:37 UTC
  • Revision ID: james.westby@ubuntu.com-20090827191737-1qjflqlj1f4ta16c
Tags: 0.6.1-7
* Update my e-mail address.
* Remove DM-Upload-Allowed field.
* Switch to debhelper 7:
  - Bump compat level to 7.
  - Minimize debian/rules.
  - Build-Depend on debhelper (>= 7.0.50) and quilt (>= 0.46-7).
* debian/patches/no_double_free.patch:
  - Do not attempt to free menu objects twice (Closes: #532988).
* Depend on ${misc:Depends} to fix a lintian warning.
* Bump Standards-Version to 3.8.3, no changes required.
* Fix some wxWindows spelling errors in the description.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Hardcode sys.maxint value to the one returned by 32-bit platforms.
2
 
https://launchpad.net/bugs/313952
3
 
 
4
 
Index: boa-constructor-0.6.1/Companions/SizerCompanions.py
5
 
===================================================================
6
 
--- boa-constructor-0.6.1.orig/Companions/SizerCompanions.py    2009-04-11 16:52:51.000000000 +0200
7
 
+++ boa-constructor-0.6.1/Companions/SizerCompanions.py 2009-04-11 16:54:05.000000000 +0200
8
 
@@ -743,7 +743,7 @@
9
 
 class PositiveIntPropEdit(IntPropEdit):
10
 
     def inspectorEdit(self):
11
 
         IntPropEdit.inspectorEdit(self)
12
 
-        self.editorCtrl.editorCtrl.SetRange(0, sys.maxint)
13
 
+        self.editorCtrl.editorCtrl.SetRange(0, 2L**31-1)
14
 
     
15
 
 class RowColDTC(HelperDTC):
16
 
     propName = 'Prop'
17
 
Index: boa-constructor-0.6.1/ExternalLib/pyparsing.py
18
 
===================================================================
19
 
--- boa-constructor-0.6.1.orig/ExternalLib/pyparsing.py 2009-04-11 16:52:52.000000000 +0200
20
 
+++ boa-constructor-0.6.1/ExternalLib/pyparsing.py      2009-04-11 16:55:04.000000000 +0200
21
 
@@ -770,7 +770,7 @@
22
 
         if max > 0:
23
 
             self.maxLen = max
24
 
         else:
25
 
-            self.maxLen = sys.maxint
26
 
+            self.maxLen = 2L**31-1
27
 
 
28
 
         if exact > 0:
29
 
             self.maxLen = exact
30
 
@@ -843,7 +843,7 @@
31
 
         if max > 0:
32
 
             self.maxLen = max
33
 
         else:
34
 
-            self.maxLen = sys.maxint
35
 
+            self.maxLen = 2L**31-1
36
 
 
37
 
         if exact > 0:
38
 
             self.maxLen = exact
39
 
@@ -921,7 +921,7 @@
40
 
         if max > 0:
41
 
             self.maxLen = max
42
 
         else:
43
 
-            self.maxLen = sys.maxint
44
 
+            self.maxLen = 2L**31-1
45
 
 
46
 
         if exact > 0:
47
 
             self.maxLen = exact
48
 
Index: boa-constructor-0.6.1/ExternalLib/tarfile.py
49
 
===================================================================
50
 
--- boa-constructor-0.6.1.orig/ExternalLib/tarfile.py   2009-04-11 16:52:51.000000000 +0200
51
 
+++ boa-constructor-0.6.1/ExternalLib/tarfile.py        2009-04-11 16:54:29.000000000 +0200
52
 
@@ -1684,7 +1684,7 @@
53
 
            be mixed up (!).
54
 
         """
55
 
         if size < 0:
56
 
-            size = sys.maxint
57
 
+            size = 2L**31-1
58
 
 
59
 
         nl = self.linebuffer.find("\n")
60
 
         if nl >= 0:
61
 
Index: boa-constructor-0.6.1/PropEdit/InspectorEditorControls.py
62
 
===================================================================
63
 
--- boa-constructor-0.6.1.orig/PropEdit/InspectorEditorControls.py      2009-04-11 16:52:52.000000000 +0200
64
 
+++ boa-constructor-0.6.1/PropEdit/InspectorEditorControls.py   2009-04-11 16:55:44.000000000 +0200
65
 
@@ -130,7 +130,7 @@
66
 
         self.editorCtrl = wx.SpinCtrl(parent, self.wID, value,
67
 
               (-2, idx*Preferences.oiLineHeight -2),
68
 
               (sizeX, Preferences.oiLineHeight+3), style=wx.SP_VERTICAL,
69
 
-              max=sys.maxint, min=-sys.maxint)
70
 
+              max=2L**31-1, min=-(2L**31-1))
71
 
         parent.Bind(wx.EVT_TEXT_ENTER, self.OnSelect, id=self.wID)
72
 
         parent.Bind(wx.EVT_SPINCTRL, self.OnSelect, id=self.wID)
73
 
         InspectorEditorControl.createControl(self)