~ubuntu-branches/debian/squeeze/boa-constructor/squeeze

« back to all changes in this revision

Viewing changes to debian/patches/no_double_free.patch

  • Committer: Bazaar Package Importer
  • Author(s): Luca Falavigna
  • Date: 2009-08-27 19:17:37 UTC
  • Revision ID: james.westby@ubuntu.com-20090827191737-1qjflqlj1f4ta16c
Tags: 0.6.1-7
* Update my e-mail address.
* Remove DM-Upload-Allowed field.
* Switch to debhelper 7:
  - Bump compat level to 7.
  - Minimize debian/rules.
  - Build-Depend on debhelper (>= 7.0.50) and quilt (>= 0.46-7).
* debian/patches/no_double_free.patch:
  - Do not attempt to free menu objects twice (Closes: #532988).
* Depend on ${misc:Depends} to fix a lintian warning.
* Bump Standards-Version to 3.8.3, no changes required.
* Fix some wxWindows spelling errors in the description.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description:    Do not attempt to free menu objects twice
 
2
Origin:         Debian
 
3
Bug-Debian:     http://bugs.debian.org/532988
 
4
Forwarded:      https://sourceforge.net/tracker/?func=detail&aid=2825234&group_id=1909&atid=101909
 
5
 
 
6
Index: boa-constructor-0.6.1/Editor.py
 
7
===================================================================
 
8
--- boa-constructor-0.6.1.orig/Editor.py        2009-07-30 22:44:08.000000000 +0200
 
9
+++ boa-constructor-0.6.1/Editor.py     2009-07-30 22:36:18.000000000 +0200
 
10
@@ -1467,11 +1467,6 @@
 
11
                     wx.LogError(str(error))
 
12
                     return
 
13
 
 
14
-            # disconnect and destroy menus that would have been cleaned up by
 
15
-            # closeModulePage
 
16
-            for idx, name, modPage in modPageList:
 
17
-                modPage.destroy()
 
18
-
 
19
             # stop accepting files over socket
 
20
             if self.closed:
 
21
                 self.closed.set()