~ubuntu-branches/debian/squeeze/boa-constructor/squeeze

« back to all changes in this revision

Viewing changes to debian/patches/select_wxpython_2_6.patch

  • Committer: Bazaar Package Importer
  • Author(s): Luca Falavigna
  • Date: 2009-08-27 19:17:37 UTC
  • Revision ID: james.westby@ubuntu.com-20090827191737-1qjflqlj1f4ta16c
Tags: 0.6.1-7
* Update my e-mail address.
* Remove DM-Upload-Allowed field.
* Switch to debhelper 7:
  - Bump compat level to 7.
  - Minimize debian/rules.
  - Build-Depend on debhelper (>= 7.0.50) and quilt (>= 0.46-7).
* debian/patches/no_double_free.patch:
  - Do not attempt to free menu objects twice (Closes: #532988).
* Depend on ${misc:Depends} to fix a lintian warning.
* Bump Standards-Version to 3.8.3, no changes required.
* Fix some wxWindows spelling errors in the description.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description:    Use xwpython 2.6.
 
2
Origin:         Debian
 
3
Forwarded:      not-needed
 
4
 
 
5
Index: boa-constructor-0.6.1/Boa.py
 
6
===================================================================
 
7
--- boa-constructor-0.6.1.orig/Boa.py   2009-04-11 15:57:01.000000000 +0200
 
8
+++ boa-constructor-0.6.1/Boa.py        2009-04-11 15:57:09.000000000 +0200
 
9
@@ -230,7 +230,7 @@
 
10
     if not hasattr(sys, 'frozen'):
 
11
         import wxversion
 
12
         if wxVersionSelect is None:
 
13
-            wxversion.ensureMinimal('2.5')
 
14
+            wxversion.select('2.6')
 
15
         else:
 
16
             wxversion.select(wxVersionSelect)
 
17
 except ImportError: